KDE Plasma hangs on start

I dropped a video into the VLC media player which caused the display to flicker, then freeze. The taskbar disappeared and a number of notifications in red flashed in the lower right corner of the screen specifying a screen-related problem, I believe. These popped in and out before I could read them. The computer completely hung and did not recover over a period of time. Attempted to restart, however occurred on boot:

  1. No task bar
  2. The Thunderbird email client which I have set to start on boot, did come up, but is very slow to react. It is usable with some patience.
  3. I started Konsole, took about 5-10 minutes to fully come up. Entered commands show up and process up to about 10 minutes after entering them. Some commands timeout due to the delay for the password to be accepted.
  4. There is a major system update available - the system has not yet been updated though
  5. plasmashell uses 80-90% CPU, and Xorg about 18% CPU, then after a bit they switch; Xorg uses about 80-90% CPU and plasmashell about 30-40%. These switch back and forth regularly.

I have tried to toggle the compositor using the keyboard shortcut, but no difference. I have had some issues with that some time ago.

At the time was running FreeCAD for the first time, and working through some tutorial videos that I had downloaded. These have played fine on VLC earlier without issue.

The kernel is 5.18.

Any help would be much appreciated!

do you have installed a different kernel than the 5.18? if so switch to it in grub menu, if not install the 5.19 (not the rt one), reboot and it will automatically boot with it, but just to be sure check with: uname -r
if you have still issues, create a new test user from system settings, log out, and log in with the test user and check if it has also issues …if not we then can try to ‘repair’ the main user, if it however does have the same issue, post formatted output from:
inxi -Faz
mhwd -l && mhwd -li

Thank-you for the suggestions. So I booted into kernel 5.15 - same thing here. I thought that it would be best to then continue with 5.18, so rebooted again, this time into 5.18. The system came up fine, however the USB subsystem didn’t fully come up. Mouse worked, but not the keyboard or external drives. Rebooted again and all is well.

The remaining question is, is there an underlying problem that may cause a repeat of this situation? Is there anything that I should check for?

the linux518 is end of life, so you should switch to another kernel anyway - install the 5.19 (not the rt one) - and if everyhting works with it, remove the 5.18

Thank-you again for your help. This is the second time you have come to the rescue and this is very much appreciated! I did plan to update last night, but will do so this evening.

so switch to the 5.15 kernel before updating, since the 5.18 is eol and you are also using nvidia, so you would end up in a black screen