KDE Application launcher doesn't open when Meta key is pressed

Title is self descriptive, I didn’t change any keybind settings and it doesn’t want to open. I have tried rebinding the widget to alt+f1 or meta+f1 but that didn’t work.

1 Like

I noticed the same with the latest testing update (KDE Plasma 5.20.1).

A question for the both of you: do you have the launcher icon on the panel? If you don’t, then Plasma will ignore a single press on the Meta key.

@kaly: Are you on the Stable branch?

you need to assign the keybind to open the launcher to alt+f1

Yep, stable branch, Also, I had the application launcher widget on the main KDE panel i use.

I did set the keybind to alt+f1

I do have the launcher on the panel, yes.

I think i’ve found the problem: it doesn’t activate when the widget is placed on a application menu bar panel. Otherwise, it works fine.

Maybe: Bug 391322 - Meta key randomly stops opening Plasma launcher menu

Or

I can’t bind the Meta key to open the Application Launcher anymore!
There is one sentence at the above link, which has another link (“this section”). I posted a snipped from “this section”.

If it’s not working, make sure your “Start Menu” widget has a global shortcut like Alt+F1 set (you can’t assign it directly to Meta, but it will open with Meta if another shortcut is assigned).

This issue appears multiple times at forum.kde.org.

Yes, I’ve set it to alt+f1

There was more at that link… which was similar to the work around in the bug report (comment 23).

Putting them together:

.config/kwinrc

[ModifierOnlyShortcuts]
Meta=org.kde.plasmashell,/PlasmaShell,org.kde.PlasmaShell,activateLauncherMenu

qdbus org.kde.KWin /KWin reconfigure

If you have qdbusviewer installed you can follow the path to the method:
org.kde.plasmashell > PlasmaShell > org.kde.PlasmaShell > activateLauncherMenu
If you double click the method it will open the launcher. This is just an educational or verification step.

I do not have this problem, but KDE isn’t my main machine anymore. I looked in my kwinrc and didn’t have a ModifierOnlyShortcuts section, but I added it anyway along with the next line and restarted kwin. The Meta key still worked, and I didn’t appear to break anything :slight_smile: I am using the Application Menu, but changed it to the alternative, Application Launcher and the Meta key worked there too. I set Meta= nothing, to confirm I could unassign it and that worked too. Absent any other fix, this is one option to potentially try.

2 Likes

Mine doesn’t have it either, but I am using the Plasma Dashboard as my application launcher. It opens on pressing either Meta or Alt+F1.

I tried Meta= and Meta=org... with the Plasma Dashboard and got the expected results. I have 3 alternative start menus (Application Dashboard, Application Launcher, and Application Menu). and tried with each. At most I can say it shouldn’t break anything and it might make the Meta key work based on the bug report and the Plasma/Tips. Defintely watch the above bug.

Same for me. Assigning Alt+F1 also enabled the Meta key again.

1 Like

This didn’t work for me

Does it still work for you if you put the application launcher widget on a application menu bar panel?

I was also having same problem after a testing update, but I also installed plasma wayland session to try it on the side, don’t know it has any correlation to it. But for me it worked only after removing the widgets from panel, adding again and manually applying Alt+F1 shortcut to it. (Using X11 session currently).

Also I noticed under system settings > shortcuts ‘Activate Application Launcher Widget’ is listed 4 times though I have the widget only twice on panels on two different monitors.

An application menu bar, as you call it, is really nothing other than an empty panel with the global menu widget already on it. But that is not how I set things up on my end. I simply moved the original panel from the bottom to the top, made it thinner, removed the task bar widget, and added the global menu widget (and a few other widgets).

It’s the exact same thing, really. The option to add an application menu bar is simply a shortcut that the KDE folks provided for people who don’t want to do all of this manually. It’s just a standard panel.

And yes, last time I did it as you describe, it worked. But that was a long time ago and on another machine. On this machine here I set things up as I explained above, and I’m not going to mess with that, because it works perfectly and just the way I want it. :wink:

The same here.

1 Like

I had the same issue suddenly noticed today. I had to mess around/reboot a lot. I didn’t even have Meta + … input registering when trying to assign shortcuts. Then after removing all shortcuts (yeah, one guy said he had four, I had two application launcher configurable shortcut + the one in the actual application launcher for whatever reason), changing keyboard to another one and back to generic 105 keys, I had Meta key registering again so I add Alt+F1 shortcut to the application launcher settings, then in System Settings->Shortcuts->Application launcher I change the first one to Alt+F1 too and it started working again…

Another KDE special treat lol

1 Like