Iwlwifi firmware issue after upgrade kernel to 515

my dmesg shows

[   13.180081] Intel(R) Wireless WiFi driver for Linux
[   13.183096] iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-so-a0-hr-b0-66.ucode failed with error -2
[   13.183122] iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-so-a0-hr-b0-65.ucode failed with error -2
[   13.183138] iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-so-a0-hr-b0-64.ucode failed with error -2
[   13.183153] iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-so-a0-hr-b0-63.ucode failed with error -2
[   13.183167] iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-so-a0-hr-b0-62.ucode failed with error -2
[   13.183182] iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-so-a0-hr-b0-61.ucode failed with error -2
[   13.183196] iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-so-a0-hr-b0-60.ucode failed with error -2
[   13.183212] iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-so-a0-hr-b0-59.ucode failed with error -2
[   13.183229] iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-so-a0-hr-b0-58.ucode failed with error -2
[   13.183243] iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-so-a0-hr-b0-57.ucode failed with error -2
[   13.183258] iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-so-a0-hr-b0-56.ucode failed with error -2
[   13.183273] iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-so-a0-hr-b0-55.ucode failed with error -2
[   13.183287] iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-so-a0-hr-b0-54.ucode failed with error -2
[   13.183304] iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-so-a0-hr-b0-53.ucode failed with error -2
[   13.183317] iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-so-a0-hr-b0-52.ucode failed with error -2
[   13.183332] iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-so-a0-hr-b0-51.ucode failed with error -2
[   13.183346] iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-so-a0-hr-b0-50.ucode failed with error -2
[   13.183360] iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-so-a0-hr-b0-49.ucode failed with error -2
[   13.183375] iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-so-a0-hr-b0-48.ucode failed with error -2
[   13.183390] iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-so-a0-hr-b0-47.ucode failed with error -2
[   13.183403] iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-so-a0-hr-b0-46.ucode failed with error -2
[   13.183417] iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-so-a0-hr-b0-45.ucode failed with error -2
[   13.183432] iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-so-a0-hr-b0-44.ucode failed with error -2
[   13.183447] iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-so-a0-hr-b0-43.ucode failed with error -2
[   13.183462] iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-so-a0-hr-b0-42.ucode failed with error -2
[   13.183475] iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-so-a0-hr-b0-41.ucode failed with error -2
[   13.183491] iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-so-a0-hr-b0-40.ucode failed with error -2
[   13.183504] iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-so-a0-hr-b0-39.ucode failed with error -2
[   13.183506] iwlwifi 0000:00:14.3: no suitable firmware found!
[   13.183507] iwlwifi 0000:00:14.3: minimum version required: iwlwifi-so-a0-hr-b0-39
[   13.183508] iwlwifi 0000:00:14.3: maximum version supported: iwlwifi-so-a0-hr-b0-66
[   13.183509] iwlwifi 0000:00:14.3: check git://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git

seems linux-firmware issue.
so I tried latest linux-firmware and linux-firmware-git. but the kernel log show ‘no suitable firmware found’ again!

my laptop:

System:
  Kernel: 5.15.102-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=72bda64a-6bf6-4f72-9919-77683bf068c6 rw quiet splash apparmor=1
    security=apparmor resume=UUID=62df3349-81c5-415c-9128-efcbd0a07048
    udev.log_priority=3
  Desktop: Xfce v: 4.18.1 tk: Gtk v: 3.24.36 info: xfce4-panel wm: xfwm
    v: 4.18.0 vt: 2 dm: GDM v: 42.0 Distro: Manjaro Linux base: Arch Linux


...

CPU:
  Info: model: 12th Gen Intel Core i7-12700H bits: 64 type: MST AMCP
    arch: Alder Lake gen: core 12 level: v3 note: check built: 2021+
    process: Intel 7 (10nm ESF) family: 6 model-id: 0x9A (154) stepping: 3
    microcode: 0x428

...


Network:
  Device-1: Intel Alder Lake-P PCH CNVi WiFi driver: N/A modules: iwlwifi
    bus-ID: 00:14.3 chip-ID: 8086:51f0 class-ID: 0280
  Device-2: Intel Ethernet I219-V vendor: Lenovo driver: e1000e v: kernel
    port: N/A bus-ID: 00:1f.6 chip-ID: 8086:1a1f class-ID: 0200
  IF: enp0s31f6 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IF-ID-1: br-392586ce1eeb state: up speed: 10000 Mbps duplex: unknown
    mac: <filter>
  IF-ID-2: br-6215353f3ae4 state: down mac: <filter>
  IF-ID-3: docker0 state: down mac: <filter>
  IF-ID-4: utun state: unknown speed: 10 Mbps duplex: full mac: N/A
  IF-ID-5: veth6ffb32b state: up speed: 10000 Mbps duplex: full mac: <filter>
  IF-ID-6: vethb821179 state: up speed: 10000 Mbps duplex: full mac: <filter>
  IF-ID-7: vethe5357ad state: up speed: 10000 Mbps duplex: full mac: <filter>


VERY URGENT! NO WIFI CAN USE OMG!

Mind trying a newer kernel? Seen a similar problem in Intel community forum and the reporter says it’s fixed in 5.17. Of course since 5.17 is now EOL you can try the next LTS 6.11 instead, maybe 6.2 since it’s already out as stable.

I have had identical issue since installing linux-firmware-20230210.bf4115c-1
As told by leledumbo I tried kernel 6.1, the wifi came back to life but all the rest didn’t work correclty (first of all nvidia driver).
The workaround I used to make wifi works again is been to downgrade it to the previous linux firmware package

# cd /var/cache/pacman/pkg
# pacman -U linux-firmware-20230117.7e4f0ed-1-any.pkg.tar.zst

Hope this help

2 Likes

I too have the same issue, I’m currently in kernel 5.15, shall I upgrade to 6.1 as it’s currently being released by Manjaro?

PS: After installing 6.1 kernel, I couldn’t even boot into Manjaro. I reverted back to faulty 5.15 kernel.

Thanks,it works.
But My problem was that i can’t find any wifi I used connected.
Do this back to previous linux firmware package and reboot my computer ,then wifi connect.

Thanks a lot. And for those who dont know how to downgrade the firmware pacckage:

  1. download the archive firmware package
    h t t p s://archive.archlinux.org/packages/l/linux-firmware/linux-firmware-20230117.7e4f0ed-1-any.pkg.tar.zst
    h t t p s://archive.archlinux.org/packages/l/linux-firmware-whence/linux-firmware-whence-20230117.7e4f0ed-1-any.pkg.tar.zst
  2. force install the downloaded package
    yay -U linux-firmware-20230117.7e4f0ed-1-any.pkg.tar.zst
    yay -U linux-firmware-whence-20230117.7e4f0ed-1-any.pkg.tar.zst
  3. (Optional) ignore the firmware updates
    Add/Remove Software → Preference → Advance → Ignore → add
1 Like

Thanks guys. kernel 6.2 cannot work with Nvidia card too, but okay with intel wifi.

Have you tried kernel parameter ibt=off with kernels 6.1 LTS or 6.2?

Yah, I tried but the problem is the mouse pointer and graphics lags a lot, I have intel i7 12700h rtx 3060 laptop, wifi works in kernel 6.1 and 6.2, graphics issue in these kernels

You should create a new post for that issue in a new thread with a full inxi output as described here: