Issues with Plasma 6 upgrade

Hi. I am using Wayland. After the system update(upgrade to Plasma 6), all the applications disappear, and nothing works. Luckily, I have the snapshots to go back to, but I cannot install anything or update anymore since it always gives the same result.

I followed the steps KDE - ArchWiki, but the panel doesn’t work since it was latte-dock.

Is it okay if I use the previous version of Plasma, or is it recommended that I upgrade it? What do you recommend doing in case of using Wayland? I am not able to find a suitable dock and cannot normally open any application. Can I update the system but not choose to upgrade Plasma?

Also nothing is showing in All Applications, but I can open applications from terminal. Is it again because of the dock?
here is my system info

  Kernel: 6.6.32-1-MANJARO arch: x86_64 bits: 64 compiler: gcc
    v: 14.1.1
  Desktop: KDE Plasma v: 6.0.5 Distro: Manjaro base: Arch Linux
  Type: Laptop System: LENOVO product: 82UX v: Lenovo Slim 7 16ARH7
    serial: <superuser required>
  Mobo: LENOVO model: LNVNB161216 v: SDK0T76530 WIN
    serial: <superuser required> UEFI: LENOVO v: KLCN19WW
    date: 06/08/2023
  ID-1: BAT0 charge: 48.8 Wh (76.2%) condition: 64.0/75.0 Wh (85.4%)
    volts: 16.1 min: 15.4 model: LENOVO AP16L5J status: not charging
  Info: 8-core model: AMD Ryzen 7 6800HS Creator Edition bits: 64
    type: MT MCP arch: Zen 3+ rev: 1 cache: L1: 512 KiB L2: 4 MiB
    L3: 16 MiB
  Speed (MHz): avg: 662 high: 1647 min/max: 400/4785 cores: 1: 1396
    2: 400 3: 400 4: 400 5: 400 6: 400 7: 400 8: 400 9: 1353 10: 400
    11: 400 12: 400 13: 1647 14: 400 15: 1408 16: 400 bogomips: 102249
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a
    ssse3 svm
  Device-1: NVIDIA GA107BM [GeForce RTX 3050 Mobile] vendor: Lenovo
    driver: N/A arch: Ampere bus-ID: 01:00.0
  Device-2: AMD Rembrandt [Radeon 680M] vendor: Lenovo
    driver: amdgpu v: kernel arch: RDNA-2 bus-ID: 05:00.0 temp: 60.0 C
  Device-3: IMC Networks Integrated RGB Camera driver: uvcvideo
    type: USB bus-ID: 5-1:2
  Display: wayland server: v: with: Xwayland
    v: 24.1.0 compositor: kwin_wayland driver: X: loaded: amdgpu
    unloaded: modesetting dri: radeonsi gpu: amdgpu resolution:
    1: 1920x1080 2: 1707x1067
  API: EGL v: 1.5 drivers: kms_swrast,radeonsi,swrast platforms:
    active: gbm,wayland,x11,surfaceless,device inactive: N/A
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa
    v: 24.0.8-manjaro1.1 glx-v: 1.4 direct-render: yes renderer: AMD
    Radeon Graphics (radeonsi rembrandt LLVM 17.0.6 DRM 3.54
  API: Vulkan v: 1.3.279 drivers: radv surfaces: xcb,xlib,wayland
    devices: 1
  Device-1: AMD Rembrandt Radeon High Definition Audio vendor: Lenovo
    driver: snd_hda_intel v: kernel bus-ID: 05:00.1
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: Lenovo
    driver: snd_pci_acp6x v: kernel bus-ID: 05:00.5
  Device-3: AMD Family 17h/19h HD Audio vendor: Lenovo
    driver: snd_hda_intel v: kernel bus-ID: 05:00.6
  API: ALSA v: k6.6.32-1-MANJARO status: kernel-api
  Server-1: JACK v: 1.9.22 status: off
  Server-2: PipeWire v: 1.0.7 status: off
  Server-3: PulseAudio v: 17.0 status: active
  Device-1: Realtek RTL8852BE PCIe 802.11ax Wireless Network
    vendor: Lenovo driver: rtw89_8852be v: kernel port: 2000
    bus-ID: 02:00.0
  IF: wlp2s0 state: up mac: <filter>
  Device-1: Realtek Bluetooth Radio driver: btusb v: 0.8 type: USB
    bus-ID: 3-3:3
  Report: rfkill ID: hci0 rfk-id: 2 state: up
    address: see --recommends
  Local Storage: total: 931.51 GiB used: 174.4 GiB (18.7%)
  ID-1: /dev/nvme0n1 vendor: Western Digital
    model: WD BLACK SN850X 1000GB size: 931.51 GiB temp: 48.9 C
  ID-1: / size: 577.2 GiB used: 174.34 GiB (30.2%) fs: ext4
    dev: /dev/nvme0n1p5
  ID-2: /boot/efi size: 256 MiB used: 67.7 MiB (26.4%) fs: vfat
    dev: /dev/nvme0n1p1
  ID-1: swap-1 type: file size: 4 GiB used: 0 KiB (0.0%)
    file: /swapfile
  System Temperatures: cpu: 60.8 C mobo: N/A gpu: amdgpu temp: 60.0 C
  Fan Speeds (rpm): N/A
  Memory: total: 16 GiB note: est. available: 13.34 GiB
    used: 2.02 GiB (15.1%)
  Processes: 349 Uptime: 1m Init: systemd
  Packages: 1659 Compilers: clang: 17.0.6 gcc: 14.1.1 Shell: Zsh
    v: 5.9 inxi: 3.3.34

Let me know if you need any other information.

This might be your issue, but I’m no expert on Nvidia stuff. Does an X11 session work OK?

One other thing, did you do the Plasma6 upgrade by logging out and using a TTY, as instructed in the Stable Update Announcements?

Edited to add: This post may be helpful if you restore a snapshot and then proceed with the Plasma6 (and subsequent) upgrade process.


Thank you for the reply and for the resources. I didnt know about the right ways of updating. I just tried updating from TTY. All the applications are now available from the menu. The only thing is that the latte-dock is not supported anymore I guess.

I will have to use the default panel as I understand. I will keep the updates for a while to see if there are any other bugs after the update and write here.

Thank you very much

1 Like

latte-dock is discontinued and does not work with plasma 6.

There have been murmurs about revitalizing it.
I dont know how necessary it really is or what shape it is in now but you can watch the progress here:

1 Like

and probably this could helps to with your Wayland problem:

1 Like

Plasma 6 does allow for a panel to behave as a dock — e.g. dodging the application window if the window is too tall or maximized.

The only thing it doesn’t do (yet?) is zoom the icons as you move the mouse over them, but personally I see no real added value in using a third-party dock. Your mileage may vary, of course. :wink:


Thank you all very much. I personally liked latte-dock because it works well with an external display since it can be duplicated and be visible on both displays. I think theres no such functionality on default panel.

Thank you for the resources I will refer to them. I think everything works fine after updating the system correctly.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.