Issue with permanent keyboard configuration for accented letters (Portuguese ABNT2)

Hello all!

I’m not an advanced user, although I’ve been running Linux (Ubuntu/Unity & Gnome) for some ten years. I’m wholly new to Manjaro and KDE.

Apparently there is a known issue involving correctly configuring KDE to accept accented characters, i.e., a configuration which delivers “é” or “ã” or “ô” when you press ’ and then “e”, ~ and them “a”, ^ and then “o”, and so forth.

I’ve seen the issue reported and discussed in a few posts – confined to the relatively small Portuguese or Spanish-speaking communities – here and there, but I have failed to find a permanent solution.

The workarounds I have found involve either adding “setxkbmap -model abnt2 -layout br -variant abnt2” to /etc/bashrc or employing a combination of keystrokes involving the “modifier” key + “e” or “a” and so forth.

The first workaround is inelegant (=P) in addition to being not entirely convenient: in my machine, at least, for reasons unknown, the accentuation keystroke combinations will sometimes randomly lose effectiveness, i.e., at the beginning of the session ’ + e = é, but after a while, ’ + e begins to mysteriously produce only 'e.

The second workaround is unpractical. I use the computer basically to write in Portuguese and Spanish, and having to readjust my typing skills is not really an option at this point!

I am expecting that posting the issue here to a broader audience may help me find alternative solutions.

(By the way, the solution presented in Plasma resetting keyboard layout after boot didn’t work for me, as the abnt2 layout does not appear in the “Keyboard Settings” submenu).

Thanks in advance!

All the best,

Pedro

Welcome to the forum! :slight_smile:

Well, I can’t really help you with locale-specific keyboard layouts, but you should be able to pick an alternative layout in the Manjaro Settings Manager for your locale that works better.

That said, in Plasma, you can also define a compose key, i.e. a key that lets you combine certain characters in order to form new ones. In System Settings, go to… :arrow_down:

Hardware → Input Devices ─ KeyboardAdvanced

Select “Position of compose key” and set your compose key there. I myself am using the right-hand Meta (Win) key as a compose key.

Thank you for your reply!
I had tried selecting keyboards out of the Keyboard Settings list, but the keyboards who actually do look like my own keyboard did not deliver the expected results (when I select them, ´ + a = 'a, not á). But then I did a strange thing, and selected a few of the other keyboards, that don’t look like mine. And turns out one of them works! So, there you go. I should probably have tried the random approach to begin with. Anyway, thanks!
(And thanks for the compose key hint, as well!)

1 Like

Bad news! The system is losing keyboard configuration each time it is reset.

At some point, I had chosen a certain keyboard setting through the System Settings > Keyboard Settings GUI – “Portuguese (Brazil, no dead keys)”. When using this setting, accentuation in my keyboard stops working (obviously, since it is a “no dead keys” setting).

Later, following Aragorn’s suggestion, I picked a different setting which did work (“Portuguese (Brazil, Sun Type 6/7)”. Later, after restarting the system, the keyboard setting went back to “Portuguese (Brazil, no dead keys)”, and accentuation stopped working again. Help?

Ok, I got it now.

In KDE 5.20, there are two separate but strangely concurrent ways to set up your keyboard in the System Settings GUI: one is “Keyboard Settings”, right at the top, under “Manjaro”; the other is down below under Hardware > Input Devices > Keyboard > Layouts. After I set up the keyboard to the same layout in both places, the problem was gone.

Specifically: in order for my Brazilian Portuguese / ABNT2 keyboard to work, I used Keyboard Model: Microsoft Internet and Portuguese / Portuguese (Brazil Sun Type 6/7) in the “Keyboard Settings” screen, and Map: br / Layout: Portuguese (Brazil) and Variant: Portuguese (Brazil Sun Type 6/7) in the “Input Devices > Keyboard” screen.

1 Like