Help fix keyboard issue (accents not working)


I’m back to Manjaro, and yesterday night I just finished a fresh install with the latest ISO available. After everything was done I realized that my keyboard accents was not working properly. I made some investigation here on the forum but one solution pointed from other user is not working see post below :frowning:

My locale language is set to American English, this way is better to find documentation and support.

System Settings → input device → Keyboard → Hardware → Set to Generic 105 keys

System Settings → input device → Keyboard → Layout → Set to Portuguese (Brazil) No dead keys

Manjaro Setting Manager → Keyboard Settings → Portuguese Brazil no dead keys

  • The 1st foot print i found that an issue is because changing Manjaro Setting Manager Keyboard don’t make the accent works.

  • The 2nd foot print I found about it’s an issue is because when I reboot my machine the Manjaro Setting Manager back the Keyboard Settings automatically to English Default, it suggests conflicts anywhere in the config files. Maybe once it’s see my locale defined as English and changes my keyboard and do not respect user choice.

Previously, when I was using xorg some year ago, the way to fix it was only using the command line: “setxkbmap -model abnt2 -layout br -variant abnt2”

Since Wayland, time to time I face issues :frowning: and I didn’t find the correct way to fix it, with all improvements from plasma, it should work by default.

expected behavior: ã or ô
current behavior: ~a or ^o

Thanks in advance.



  Kernel: 6.1.44-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: hpet,acpi_pm
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-6.1-x86_64
    root=UUID=84e0bfca-0d47-4324-b85a-614ea38dc5f9 rw rootflags=subvol=@ quiet
    splash udev.log_priority=3
  Desktop: KDE Plasma v: 5.27.7 tk: Qt v: 5.15.10 wm: kwin_wayland vt: 1
    dm: SDDM Distro: Manjaro Linux base: Arch Linux
  Type: Desktop Mobo: MACHINIST model: E5-MR9A v: V1.0
    serial: <superuser required> UEFI: American Megatrends v: 5.11
    date: 10/25/2022
  Message: No system battery data found. Is one present?
  System RAM: total: 32 GiB note: est. available: 31.19 GiB
    used: 2.79 GiB (9.0%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges required.
  Info: model: Intel Xeon E5-2667 v4 bits: 64 type: MT MCP arch: Broadwell
    level: v3 note: check built: 2015-18 process: Intel 14nm family: 6
    model-id: 0x4F (79) stepping: 1 microcode: 0xB000040
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 2 MiB desc: 8x256 KiB L3: 25 MiB
    desc: 1x25 MiB
  Speed (MHz): avg: 1568 high: 3600 min/max: 1200/3600 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 1245 2: 1200 3: 1200
    4: 3492 5: 1197 6: 1200 7: 1198 8: 1200 9: 1200 10: 1200 11: 1197 12: 3600
    13: 1197 14: 2366 15: 1200 16: 1200 bogomips: 102198
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon
    avx avx2 bmi1 bmi2 bts cat_l3 cdp_l3 clflush cmov constant_tsc cpuid
    cpuid_fault cqm cqm_llc cqm_mbm_local cqm_mbm_total cqm_occup_llc cx16 cx8
    dca de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est f16c flexpriority
    flush_l1d fma fpu fsgsbase fxsr hle ht ibpb ibrs ida intel_ppin intel_pt
    invpcid invpcid_single lahf_lm lm mca mce md_clear mmx monitor movbe msr
    mtrr nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm pdpe1gb pebs pge
    pln pni popcnt pse pse36 pti pts rdrand rdseed rdt_a rdtscp rep_good rtm
    sdbg sep smap smep smx ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall
    tm tm2 tpr_shadow tsc tsc_adjust tsc_deadline_timer vme vmx vnmi vpid
    x2apic xsave xsaveopt xtopology xtpr
  Type: gather_data_sampling status: Not affected
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
  Type: retbleed status: Not affected
  Type: spec_rstack_overflow status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort mitigation: Clear CPU buffers; SMT vulnerable
  Device-1: AMD Navi 10 [Radeon RX 5600 OEM/5600 XT / 5700/5700 XT]
    vendor: Micro-Star MSI driver: amdgpu v: kernel arch: RDNA-1 code: Navi-1x
    process: TSMC n7 (7nm) built: 2019-20 pcie: gen: 4 speed: 16 GT/s lanes: 16
    ports: active: DP-2 empty: DP-1,DP-3,HDMI-A-1 bus-ID: 05:00.0
    chip-ID: 1002:731f class-ID: 0300
  Display: wayland server: v: with: Xwayland v: 23.1.2
    compositor: kwin_wayland driver: X: loaded: amdgpu
    unloaded: modesetting,radeon alternate: fbdev,vesa dri: radeonsi
    gpu: amdgpu display-ID: 0
  Monitor-1: DP-2 res: 2560x1440 size: N/A modes: N/A
  API: OpenGL v: 4.6 Mesa 23.1.5 renderer: AMD Radeon RX 5700 XT (navi10
    LLVM 15.0.7 DRM 3.49 6.1.44-1-MANJARO) direct-render: Yes
  Device-1: Intel 8 Series/C220 Series High Definition Audio
    driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:8c20
    class-ID: 0403
  Device-2: AMD Navi 10 HDMI Audio driver: snd_hda_intel v: kernel pcie:
    gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 05:00.1 chip-ID: 1002:ab38
    class-ID: 0403
  API: ALSA v: k6.1.44-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 0.3.77 status: off with: wireplumber status: active
    tools: pw-cli,wpctl
  Server-3: PulseAudio v: 16.1 status: active with: pulseaudio-alsa
    type: plugin tools: pacat,pactl
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: d000
    bus-ID: 08:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp8s0 state: up speed: 100 Mbps duplex: full mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: global
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Message: No bluetooth data found.
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 2.73 TiB used: 1.46 TiB (53.7%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital
    model: WD Blue SN570 500GB size: 465.76 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
    fw-rev: 234100WD temp: 27.9 C scheme: GPT
  ID-2: /dev/nvme1n1 maj-min: 259:2 vendor: A-Data model: LEGEND 850 Lite
    size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: V0922A0 temp: 25.9 C
    scheme: GPT
  ID-3: /dev/sda maj-min: 8:0 vendor: Western Digital model: WD20PURZ-85GU6Y0
    size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    tech: HDD rpm: 5400 serial: <filter> fw-rev: 0A80 scheme: MBR
  Message: No optical or floppy data found.
  ID-1: / raw-size: 465.46 GiB size: 465.46 GiB (100.00%)
    used: 29.45 GiB (6.3%) fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:4
    label: N/A uuid: 84e0bfca-0d47-4324-b85a-614ea38dc5f9
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 576 KiB (0.2%) fs: vfat dev: /dev/nvme1n1p1 maj-min: 259:3 label: N/A
    uuid: 21D8-DE05
  ID-3: /home raw-size: 465.46 GiB size: 465.46 GiB (100.00%)
    used: 29.45 GiB (6.3%) fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:4
    label: N/A uuid: 84e0bfca-0d47-4324-b85a-614ea38dc5f9
  ID-4: /home/<filter>/Games raw-size: 465.76 GiB size: 457.38 GiB (98.20%)
    used: 106.46 GiB (23.3%) fs: ext4 dev: /dev/nvme0n1p1 maj-min: 259:1
    label: GAMES uuid: b5780269-0438-4193-9b38-7df4aaf9b229
  ID-5: /home/<filter>/HDD-2TB raw-size: 1.82 TiB size: 1.79 TiB (98.37%)
    used: 1.33 TiB (74.4%) fs: ext4 dev: /dev/sda1 maj-min: 8:1 label: 2TB-EXT4
    uuid: b9d4d0f9-d1ce-425d-8fe4-e2f830005289
  ID-6: /swap raw-size: 465.46 GiB size: 465.46 GiB (100.00%)
    used: 29.45 GiB (6.3%) fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:4
    label: N/A uuid: 84e0bfca-0d47-4324-b85a-614ea38dc5f9
  ID-7: /var/cache raw-size: 465.46 GiB size: 465.46 GiB (100.00%)
    used: 29.45 GiB (6.3%) fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:4
    label: N/A uuid: 84e0bfca-0d47-4324-b85a-614ea38dc5f9
  ID-8: /var/log raw-size: 465.46 GiB size: 465.46 GiB (100.00%)
    used: 29.45 GiB (6.3%) fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:4
    label: N/A uuid: 84e0bfca-0d47-4324-b85a-614ea38dc5f9
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) zswap: yes
    compressor: zstd max-pool: 20%
  ID-1: swap-1 type: file size: 512 MiB used: 25.7 MiB (5.0%) priority: -2
    file: /swap/swapfile
  Message: No unmounted partitions found.
  Hub-1: 1-0:1 info: full speed or root hub ports: 2 rev: 2.0
    speed: 480 Mb/s (57.2 MiB/s) lanes: 1 mode: 2.0 chip-ID: 1d6b:0002
    class-ID: 0900
  Hub-2: 1-1:2 info: Intel Integrated Rate Matching Hub ports: 6 rev: 2.0
    speed: 480 Mb/s (57.2 MiB/s) lanes: 1 mode: 2.0 chip-ID: 8087:8008
    class-ID: 0900
  Hub-3: 2-0:1 info: full speed or root hub ports: 2 rev: 2.0
    speed: 480 Mb/s (57.2 MiB/s) lanes: 1 mode: 2.0 chip-ID: 1d6b:0002
    class-ID: 0900
  Hub-4: 2-1:2 info: Intel Integrated Rate Matching Hub ports: 8 rev: 2.0
    speed: 480 Mb/s (57.2 MiB/s) lanes: 1 mode: 2.0 chip-ID: 8087:8000
    class-ID: 0900
  Hub-5: 3-0:1 info: hi-speed hub with single TT ports: 15 rev: 2.0
    speed: 480 Mb/s (57.2 MiB/s) lanes: 1 mode: 2.0 chip-ID: 1d6b:0002
    class-ID: 0900
  Device-1: 3-1:2 info: SINO WEALTH Gaming KB type: keyboard,HID
    driver: hid-generic,usbhid interfaces: 2 rev: 1.1 speed: 12 Mb/s (1.4 MiB/s)
    lanes: 1 mode: 1.1 power: 500mA chip-ID: 258a:002a class-ID: 0300
  Device-2: 3-2:3 info: [Maxxter] USB GAMING MOUSE type: mouse,keyboard
    driver: hid-generic,usbhid interfaces: 2 rev: 1.1 speed: 1.5 Mb/s (183 KiB/s)
    lanes: 1 mode: 1.0 power: 100mA chip-ID: 18f8:0fc0 class-ID: 0301
  Hub-6: 4-0:1 info: super-speed hub ports: 6 rev: 3.0
    speed: 5 Gb/s (596.0 MiB/s) lanes: 1 mode: 3.2 gen-1x1 chip-ID: 1d6b:0003
    class-ID: 0900
  System Temperatures: cpu: 21.0 C mobo: N/A gpu: amdgpu temp: 31.0 C
    mem: 32.0 C
  Fan Speeds (rpm): N/A gpu: amdgpu fan: 843
  Processes: 361 Uptime: 5m wakeups: 0 Init: systemd v: 253 default: graphical
  tool: systemctl Compilers: gcc: 13.2.1 clang: 15.0.7 Packages: 1283
  pm: pacman pkgs: 1254 libs: 409 tools: pamac pm: flatpak pkgs: 29 Shell: Zsh
  v: 5.9 default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.29

You do need “dead keys” for typing accents on alphabetical characters if your keyboard layout does not have designated accented keys for the letters in question. The modus operandi is then to type the accent first, immediately followed by the character that must be accented.

What you could try is delete the following file while logged out of Plasma… :arrow_down:

rm -f ~/.local/share/kded5/keyboard/session/layout_memory.xml

I too had keyboard layout corruption in Plasma a short while ago, and deleting that file fixed it. But you have to be logged out of Plasma while doing it.

The no dead keys here is use to differentiate keyboard layout sold in the market, who creates those architecture defined that. In case of no dead key for Portuguese Brazilian ABNT2, it means the accents are in a specific position indicated below, this is working properly, so the key I press deliver the correct output.

This is the issue, yes we do press the accent 1st and the letter next, so the operational system understand and combine those two keyboard types into a single character but this is not happening I my case. Manjaro+Plasma is not combining the accent+letter.

this file is no present in my system, the folder ~ /.local/share/kded5/keyboard/session/ is empty.

This is strange, because in my case, the file recreated itself on the next login. :face_with_raised_eyebrow:

One time, if I remember well, I think I fix similar issue changing some config file, maybe there could be a conflict between GUI information and config files, I will try to check arch wiki or other place to see if Plasma Wayland storage keyboard information anywhere and check the content.

output from the command line “localectl”

System Locale: LANG=en_US.UTF-8
    VC Keymap: br-abnt2
   X11 Layout: br
    X11 Model: pc105
  X11 Variant: nodeadkeys

Maybe it’s a Plasma bug related to IBUS as indicates in the bug report below. If it’s the case, could some one help me with a work around and it’s fixed?

output from “~.config/kxkbrc/”



That’s because you have selected “no dead keys”.

Don’t forget .XCompose for adding extras (or alternatives for stuff you forget how to type).

<Multi_key> <t> <i> <c> <k>: "✔"

Anything you like :heart: :heavy_check_mark: ( ͡❛ ͜ʖ ͡❛) ♪♪♪

1 Like

If dead keys is the reason, what layout correspond to my keyboard hardware? below you can a photo.

It’s not the hardware. You have to select the “no dead keys” variant of the keyboard layout you’ve chosen.

I may not get your point. I have been selecting the “no dead keys” as demonstrated in the logs and images.

Maybe if you give more detail about what to change and where and can better understand what you are suggesting. maybe if you could rephrase or add images.

Oops, I’m sorry — my mistake. You need the variant with the dead keys.

I just tried to change both settings (Manjaro and plasma) to Portuguese (Brazil Sun type 6/7) that has very similar layout as mine with “no dead keys” variant, and it’s working as expected.

What is still an issue is why Manjaro was resetting they keyboard setup on Manjaro Setting Manager after reboot? I will keep my eyes on it and keep providing info here.

if Manjaro stops resetting the settings I will mark as solved.

I’m guessing it was an update to Plasma that did this. :man_shrugging:

No, I just reboot to test it right now and Manjaro change it again. The good part is that the keyboard is still working correctly, so maybe the system is taking into consideration the information from plasma that is preserved and is correct but not from Manjaro Setting Manager.

Maybe it’s just and outdated code or oriented to a different DE, but if needed, I could help with someone guidance, in any way to understand why this is changing while it should be preserving user choice.

@Aragorn thanks for all the help and discussion.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.