Plasma resetting keyboard layout after boot

I started using colemak as my keyboard layout, which was a simple enough process, but every time I reboot my system everything is back to QWERTY. After a little bit of research I found a post from the old forum, which even Wayback Machine couldn’t save and not much help beyond it.

So, how can I make the switch without having to go to the settings every system start?

You can add/change the line
Option "XkbVariant" ",colemak"
inside /etc/X11/xorg.conf.d/00-keyboard.conf

or use as startup
setxkbmap -layout colemak
Se more here

1 Like

Okay, I don’t even know what I did that made it work.

You can add/change the line
Option “XkbVariant” “,colemak”
inside /etc/X11/xorg.conf.d/00-keyboard.conf

When I opened the file to add that it was already set up like that, and when I restarted the system it “just worked”. Thanks for the help tho.

EDIT: Okay, I kinda found the real issue here, just don’t know how to solve it. I have the CapsLock behavior modified in the settings to act as an extra Hyper key, but every time I toggle that option the keyboard layout resets back to QWERTY, and that is probably whats been resetting it during boot. I just tried rebooting again to be sure it worked, and surprise surprise, it didn’t.

Okay, so in the end it was just Plasma settings being unnecessarily confusing. I wasn’t supposed to change the layout in the “keyboard settings” submenu. I had to go all the way down to hardware and “input devices” (the same way I’d do to change the caps behavior) than go to layouts and change there to colemak in order to make the changes permanent.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.