Is BTRFS unstable? (Update: It's not unstable, the problem is probably something else)

A different test idea is to copy your current storage to a different one with a different filesystem type, make it bootable and try running on that one for a month.
If no issues, then profit for you a one more brick in the wall for btrfs.
If issues continue, then continue debugging.

No issues so far. I once had that annoying KDE Unlock bug, but that’s not related. And that notification system for BTRFS that i installed didn’t show up once, and i copied about 22 GB of pictures from my mobile to the drive, no issues.

I did remove xanmod, so maybe it was that kernel related after all.

I do have another SSD where WIndows used to be, but i’m too lazy to sift through it to see what’s there, and if i just copy everything to a folder and name it “backup” (lol) it shall forever remain untouched. :stuck_out_tongue:
But i don’t want to install the OS and configure it again, and chances are that, if i just run stock and browse internet on it, nothing will ever happen. A true test would be to do the exact same things i did on this install, then see if there’s a difference. But that’s too much time to re-do i’d like to avoid that if i can.

1 Like

Let’s hope it was that and your issue is gone for good :wink:

1 Like

Yeah! But also, there was recently some huge update where almost every package got updated, so the issue might have been fixed in one of those without me knowing…
In any case, it seems BTRFS, ssd health or memory are not the issue, and that’s what’s important.
I doubt it’s the motherboard as well, i would have had way more problems if it’s that.

So far so good in any case. :stuck_out_tongue:

1 Like

Well, that btrfs notification popped up that i installed:
It told me to check dmesg for grep, so i wrote sudo dmesg | grep btrfs in the terminal.

[ 6536.342454] BTRFS: error (device nvme0n1p2) in btrfs_commit_transaction:2447: errno=-5 IO failure (Error while writing out transaction)
[ 6536.343495] BTRFS: error (device nvme0n1p2: state EA) in btrfs_sync_log:3187: errno=-5 IO failure

Disk is healthy, memory is not corrupted memtest is ok, everything works except btrfs…
I’m even using the default kernel now. I removed xanmod.
I’m going to finish the work i have left for today, back up everything, then i’m reinstalling with ext4…
I’m not looking forward to another qemu GPU passthrough setup but whatever lol…

Be careful, smartctl and memtest have some limits.

I would suggest to test copying any large file. you need to test repeats more than 10 times:

  1. Create any file larger than 10 GB+ on another disk/partition and a checksum e.g. sha1sum.
  2. Copy this file to your bad Btrfs partition nvme0n1p2
  3. Check the file’s checksum if it matches correctly.
  4. delete this file, then copying it again.
  5. repeat copy and verification more than 10 times if you see a btrfs notification popping up.

I know but, memtest ran for like, 6+ hours over night, did a bunch of passes, it would have detected an error at least once during that time, no?

Yeah, i’ll do that before i try and reinstall everything.

EDIT: Sorry, how do i check that?

md5sum --help

:mag: md5sum
:mag: checksum

No, in my experience I had run memtest 3 times more than 14 hours+, all passed. But manually copying and checking a large file found the error easier in a short time less than 1 hour.

I had sent the faulty RAM to the official PassMark company (Memtest was made by PassMark) in Australia. PassMark tested it with memtest PRO more than 30 repetitions and found a binary error in the RAM after 2 months. :melting_face:

That is why my suggestion would be to copy and verify a large file on RAM, disk and CPU cache more efficiently than memtest. If you have 32GB RAM, try copying and verifying a 20 GB+ file.

$ sha1sum {Your_file}

It reads any large file from disk and does a lot of calculations using CPU cache and RAM, probably to catch an error.

Copy a large file: that is, reading/loading it from another disk/partition → RAM → write it to your disk/partition, probably catching an I/O error.

1 Like

Well, just in case, i ran memtest again, now for about 9 hours, 6 passes, still no errors.

About the file transfer. I formatted the second SSD to btrfs, and put a 65GB file on it.
So i first check sha1sum on that file, copy it, then check the copy if it matches. Got it.
Then repeat 9 more times.

Then if there’s an error, that means it’s RAM?

Have you ever heard of:


Well, i copied the 65Gb file to the other SSD, generated a sha1sum from terminal for it.
Then copied it to the nvme 10 times, and checking the sha1sum after each time.

All checks passed, no errors from the notification.

I think it’ safe to say it’s not RAM, and if it’s not BTRFS which seems less likely, and if it was the disk - i just copied the entire capacity of the disk and more to it and deleted, it would have made an error in any of the 650Gb copied.
Then it’s Manjaro itself or the kernel, or what?
Cause each time the error happens, some aspect of Manjaro breaks (and gets fixed on reboot).

Last time it happened, i was switching activities, and the activity panel got “stuck” and frozen, as well as the taskbar. Can it be KDE?

Of course, this can go the other way - they got frozen because of the error, but none of the errors ever appeared on some random file…

So i’m completely at a loss here at what’s happening and why.
Between me running memtest 2 times for combined about 15 hours, plus moving 650Gb around to disk and off, you’d think an error would appear at that time…

If you mean the issue, I see there are many same errors (ksmserver-logou, kioslave5 and plasmashell) in your log. Yes, they are related to bad KDE environment and configuration, that I guess.

1 Like

If you’re desperately looking for the error, it’s easy to miss something. Try to use logic to find the problem!

Write your confirmed findings on a piece of paper. (this often helps)

Some arguments not to be overlooked:

  • Many people use Manjaro
  • Many people use btrfs
  • Many people use KDE

Have you heard a lot of complaints?

So what’s different?

  • They use their own PC. (With a different combination of RAM, motherboard, SSD…)
  • You may have other additional programs installed
  • You may have a different system configuration

But apparently not the problems you’re having.

What remains ?

Something local in your PC environment.

But only you sit in front of your PC. We can only guess blindly because we are not on site.

Just think again carefully. What is special about your PC?

Is your RAM or CPU overclocked? Is the power supply unreliable? Are any connectors loose? Has the PC not seen a vacuum cleaner for a long time? There are definitely 100 questions you could ask. But you are on site and can best ask the questions yourself.

But I would stop looking at the “standard system”. That doesn’t get you anywhere.

1 Like

Yes, that, among other things.

Come to think of it - KDE is really behaving bad from the start…
From being unable to unlock my computer from sleep/inactivity, seemingly at random, to that one time i lost write privileges for something KDE related, to just random freezes to the UI and yes, latest thing being freeze when switching activities - all errors really did in some way relate to KDE…

Maybe i should reinstall with Xfce or something.


I think it actually might be the environment, KDE… Every time an error appeared, it was related to KDE in some way, i explained how above.

And i know many people use KDE, but like you said, different configurations, etc.
There’s nothing special about my PC, i didn’t overclock it, i didn’t do anything out of the ordinary.
It’s just a Ryzen 5 5600g, 32Gb ram with integrated graphics, i don’t even think it CAN be overclocked.
So that’s not it.

The connectors are fine.
I vacuumed the PC thoroughly when i installed that RAM stick not that far back.
There’s nothing “not standard” about my PC at all, it’s just what basically amounts to a kind of better office PC.

The only thing “different” is that i have an audio interface, and not a sound card (i mean, i do, on the mobo, but i don’t use it, nor is it i think installed, it’s not recognized), and a separate GPU for PCI passthrough that doesn’t even work when it’s not being used by the VM. Or does, but in an idle state.
The PSU is a 600W suppy which should be more than enough for what i have.

Here’s the calculator of the Wattage:

According to this, it’s barely using half of what i have.

I don’t know, maybe the next troubleshooting step would be to install Xfce with btrfs manjaro, then see if that keeps happening on there. Cause all the errors were related to KDE, so that’s my only lead right now.

I can confirm that xfce is very stable. I’m always amazed to read the complaints of others using KDE. But that may also be due to the temptation to heavily adapt KDE to your own taste.

It’s like with a car. I drive a car to get from A to B. I don’t prefer any particular brand. It has to be practical. need little fuel. Be inexpensive to maintain and durable. Others buy the car by color :wink: or other criteria.

You get what you choose :wink:

1 Like

I will switch to xfce then.
From what i can tell, every error was in some way related to KDE. I’m also not super into any brand, i just tried KDE cause i haven’t used it since forever. And i like some of its features, like activities, but i also need to use my computer, i can’t go to TTY and reboot every time KDE decides to out of nowhere present the unlock button, and have it not work…

So if any of this instability is related to KDE, then i definitely will backup my data, and reinstall manjaro with Xfce.

Fingers crossed!

I don’t believe one second your BTRFS issues are related to KDE.

Reinstalling may or may not fix the issue. Anyway you’ll not be able to know what the issue was by reinstalling, that’s a fact. You may believe, if the issue don’t come back, that the issue was KDE if you don’t have the issue on XFCE, but it could also be the same if you reinstall KDE.

I believe you have a hardware failure, be it a bad cable, bad disk, bad RAM or RAM settings like when you load the XMP profile especially when you have two different RAM sticks from different manufacturers (I know you 100% exclude that because your repetitive tests of the same tool didn’t produce an error) or whatever. Maybe something is corrupt in the system files, maybe, but for now I think it is hardware failure.

1 Like

It’s not a BTRFS issue, it’s a KDE issue. If it was a BTRFS issue, it would have happened at least once copying 650GB of data, not to mention, thousands and thousands of files that i copied around not related to the test with the large file. At least one would have been corrupted (and btrfs would catch it).
Now, out of nowhere, all my wallpapers got replaced by the default ones, and the activity switcher lost all graphics. Literally everything else besides KDE works, so i don’t know what else it could be.

I mean, the point is to not have issues, so, if it doesn’t come back, and KDE is the only thing i changed, then it will have been KDE…

I specifically asked for the same RAM stick, size, CL, speed and manufacturer.
And if the tests show everything ok, i really don’t know what else it could be.
I’ll check what XMP profiles are, but, i don’t really see how, with the same exact RAM, anything could happen.

But as it has been established in this thread already - BTRFS would catch that…
And it has, multiple times. Each time some file related to KDE…

I’m sorry but, KDE seems to be the issue right now.
If XFCE keeps crashing, and having same issues as i have now, i’ll consider further troubleshooting.

But for now, KDE seems more trouble than it’s worth.

I like KDE, don’t get me wrong, but the way it (and it alone) has been behaving, i can’t really call that a usable experience. I know a lot of people use it daily and don’t have problems, but for some reason, it just doesn’t work for me.

Also, i’m not excluding hardware faliure, but, so far, the only thing that’s consistently having issue is KDE. If i change that, leave everything else as is - and the issues don’t stop, then i’ll investigate further.

Just to drive the point a bit further…
Again one of KDEs processes became buggy and not writeable. Abd btrfs notification popped up telling me about it of course.

This only ever happened with KDE related files, never anything else… Weird.

Well, good thing i backed up my files.

In any case, why are only KDE files causing the problem if its not a KDE issue then?

Well see how xfce works and if this continues to happen there.

1 Like