Interrupted update caused Kernel to stop showing on bootloader

Hi friends,

It’s my first time writing on the forum, so I’ll try to give as much information about my problem without any unnecessarily long descriptions, here we go.

So this morning I was updating some packages on my system, when Manjaro crashed in the middle of the update. I tried booting it up again, but the Kernels I had installed were corrupted (I had an older one and the current my computer was running, “linux61”). But selecting either of them resulted in the grub terminal starting up and showing the error error: file ‘boot/vmlinuz-5.15-x86_64’ not found.

After browsing the forum for a bit I found a handful of threads with the similar problem, none of which had a solution that worked for me so far.

So long story short:

  1. I followed the steps on this thread with no success;
  2. Installed a new Kernel on my device’s main partition (where Manjaro is installed), and the bootloader is not showing It as an option (it only shows UEFI firmware settings and Memory test);

And here’s the thing, I suspect my problem has something to do with this output from update-grub:

But I don’t really know what it means, and I think it’s probably not that hard a fix…

Here are some helpful prints and info:

  • I am running all the commands through a live USB, via manjaro-chroot -a (that I don’t exactly know what Is does);

  • I have only Manjaro installed on my Notebook, no dual-boot;

  • My device’s partitions (notice the UEFI fat32 partition) are:

  • Output from manjaro-chroot -a:

I would appreciate any help as this Is my main computer, and I don’t really want to have to reinstall Manjaro… anyway thanks in advance.

The /usr/bin/grub-prober: warning can be safely ignored.

Did you abort the update process within manjaro-chroot or why ends your Querying mirrors in Bangladesh? Here you have to be patient and wait until this is finished even if it takes some minutes.

1 Like

Thanks for the answer!

Yes I waited through the whole process, It just ends there because I took the print before it did.
Also, don’t know if its relevant but I did the process a couple of times from beginning to end.

Try this, instead:

pacman-mirrors --geoip --fasttrack=5

Will try! post update in a bit.

And please don’t post images of text. Use preformatted </> text.

The only thing you have to do in chroot is issue -Syu AND also reinstall kernels you have (well, had :p). Choosing faster/different mirror is optional.


This is the output for pacman-mirrors --geoip --fasttrack=5

[manjaro /]# pacman-mirrors --geoip --fasttrack=5
Version 4.24.0
 pacman-mirrors [-h] [-f [NUMBER]] [-i [-d]] [-m METHOD] [--status]
                [-c COUNTRY [COUNTRY...] | [--geoip] | [--continent]]
                [-l] [-lc] [-q] [-t SECONDS] [-v] [-n]
                [--api] [-S/-B BRANCH] [-p PREFIX]
                        [-P PROTO [PROTO...]] [-R] [-U URL]
pacman-mirrors: error: argument -f/--fasttrack: not allowed with argument --geoip

But does it needs to be exactly the kernel I had going before?
(think) It was 6.1, but now I guess its on 6.5, at least is what it says when I run
mhwd-kernel -li
Currently running: 6.5.5-1-MANJARO (linux65) The following kernels are installed in your system:;
Either way, maybe reinstalling grub on the Manjaro drive will do the trick? I saw some people commenting on this on another thread. I know It apparently has no problems, but I just can’t understand why it can’t recognize the Kernel after reinstalling it.

Also, now I don’t seem to be able to install new kernels at all:

[manjaro /]# mhwd-kernel -i linux61
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
error: no targets specified (use -h for help)

Is target the path to the device?

What is the output of… :point_down:

ls -l /boot


I just found a thread about this :sweat_smile:
But apparently I have no kernels installed, and can’t install them using mhwd-kernel

[manjaro /]# ls -l /boot
total 7200
drwxr-xr-x 3 root root    4096 Dec 31  1969 efi
drwxr-xr-x 6 root root    4096 Nov 15 15:38 grub
-rw-r--r-- 1 root root 7360512 Aug  8 15:19 intel-ucode.img
drwxr-xr-x 2 root root    4096 Jul 28 17:41 memtest86+

Let’s try it with pacman then. :point_down:

pacman -S linux61
mkinitcpio -P

… all assuming that you’re working from the chroot, of course.

1 Like

If you want easy life just learn pacman.

You’ll know how to search things you have, how to install things you want, etc. It’s easy, you just have to read pacman - ArchWiki and then apply things you read in situations like this.

Also, you can use same commands on any arch-based distro or even arch.


Ok, ran the commands from chroot, and now the Kernel installed! But trying to boot from it I get an error on Grub console:

error: symbol 'grub_is_shim_lock_enabled' not found.
error: symbol 'grub_is_shim_lock_enabled' not found.

Press any key to continue...

Failed to boot both default and fallback entries.

That suggests that you have Secure Boot enabled. Manjaro does not support this.

is that a motherboard configuration?

I’ve been reading the wiki a lot, and the community is really helpful aswell! I’m kinda new to Linux, and especially Arch. Posted this in the hopes of avoiding yet another reinstall, but at least this time It wasn’t my fault what happened (probably was tbh).

It’s in the UEFI settings. You must disable Secure Boot, as well as CSM (i.e. legacy BIOS emulation) if enabled, and if you dual-boot with Wintendo, make sure that Wintendo’s “fast startup” is disabled as well.

1 Like

It worked! Thanks!
I just am a bit confused as to why mhwd didn’t work, but anyway as @zbe said I’ll use pacman more from now on.
Thanks guys.

1 Like

@Anck8, what exactly was the solution to get rid of

error: symbol 'grub_is_shim_lock_enabled' not found.
error: symbol 'grub_is_shim_lock_enabled' not found.


# mkinitcpio -P
# update-grub

or disabling Secure Boot (why was it suddenly set before?), CSM (again why being set?) or Windoze Fast startup?