Can't install new kernel after kernel panic - no target specified

Hi friendly people. I’m writing this from a Manjaro Plasma live USB.
After I changed my kernel, something happened and my install won’t boot anymore.
I’m assuming that the kernel GRUB’s pointing to doesn’t exist.
I’ve chrooted in, remade the GRUB config and updated GRUB, but that didn’t fix it.
I tried reinstalling a more stable kernel (4.19), but that isn’t working, with a pacman error message.

[manjaro@manjaro ~]$ uname -a
Linux manjaro 5.8.16-2-MANJARO #1 SMP PREEMPT Mon Oct 19 11:33:03 UTC 2020 x86_64 GNU/Linux
[manjaro@manjaro ~]$ manjaro-chroot /mnt /bin/bash
[manjaro /]# uname -a
Linux manjaro 5.8.16-2-MANJARO #1 SMP PREEMPT Mon Oct 19 11:33:03 UTC 2020 x86_64 GNU/Linux
[manjaro /]# mhwd-kernel -li
Currently running: 5.8.16-2-MANJARO (linux58)
The following kernels are installed in your system:
   * linux54
[manjaro /]# mhwd-kernel -i linux419
:: Synchronizing package databases...
 core       [###] 100%
 extra      [###] 100%
 community  [###] 100%
 multilib   [###] 100%
error: no targets specified (use -h for help)
[manjaro /]# 

Thanks in advance for your help.

Welcome to the forum! :wink:

Can you please post the output of… :arrow_down:

ls -l /boot

…?

Thanks for the fast replay Aragorn.
Here 's the output of ls -l /boot when in chroot:

total 46728
-rw-r--r-- 1 root root    40960 Oct 23 08:26 amd-ucode.img
drwxr-xr-x 2 root root     4096 Oct 31 10:48 efi
drwxr-xr-x 5 root root     4096 Nov 10 14:53 grub
-rw-r--r-- 1 root root 31173024 Nov 10 13:15 initramfs-5.4-x86_64-fallback.img
-rw-r--r-- 1 root root 10114920 Nov 10 13:14 initramfs-5.4-x86_64.img
-rw-r--r-- 1 root root       21 Nov  1 08:42 linux54-x86_64.kver
drwxr-xr-x 2 root root     4096 Oct 19 08:53 memtest86+
-rw-r--r-- 1 root root  6498624 Nov 10 13:14 vmlinuz-5.4-x86_64

That all looks fine to me. You have 5.4 installed. But you say it won’t boot? What exactly happens when you select it in GRUB?

The laptop boots to a black screen. The screen where the GRUB choices would be is black and doesn’t show the installed theme (although it does seem to wait the specified 10 seconds to begin booting according to the laptop). After that it just hangs there blankly.

Edit the /etc/default/grub file in the chroot environment and make sure you have the following at the top of the file… :arrow_down:

GRUB_DEFAULT=saved
GRUB_TIMEOUT=10
GRUB_TIMEOUT_STYLE=menu
GRUB_DISTRIBUTOR='Manjaro'
GRUB_CMDLINE_LINUX_DEFAULT="quiet udev.log_priority=3"
GRUB_CMDLINE_LINUX=""

Pay attention to that third line. Yours may say “hidden” instead. If it does, change that, save the file, and then run… :arrow_down:

update-grub

GRUB’s menu is here again, but now my Windows partition is missing from the list, and booting to the Manjaro install returns ‘no irq handler for vector’ five or six times and then hangs again.

Alternately, could reinstalling Manjaro be a faster choice to be able to work again? If so, do you know of a non-destructive way I could just reinstall the system and have my files, programs and preferences remain there? (the old system was Manj. 20 Plasma if that helps at all)

In the chroot environment, try this… :arrow_down:

grub-install --recheck --no-rs-codes
update-grub

Well, if you have /home on a separate partition, then you can reinstall without formatting /home. If not, then I hope you have backups. :frowning_face:

The good news is that the live USB contains timeshift, so you can use that for making a backup to another drive. Or, you could copy over your files manually, of course. :man_shrugging:

1 Like
[manjaro /]# grub-install --recheck --no-rs-codes
Installing for x86_64-efi platform.
grub-install: error: cannot find EFI directory.

Specifying --efi-directory=/boot/efi and the related flags doesn’t help it either.
Since the partition can be mounted I think I’ll copy what I need and reinstall it, taking note to backup regularly this time and be a bit less careless when changing the kernel.
Oh and thanks for your help, this is likely one of the nicest experiences I’ve had on a public forum.

1 Like

check in /etc/mkinitcpio.d/*.preset
you should have a version linux54.preset