Internet speed is slow

Hello friends , I am new to linux .I installed manjaro alongside with windows 4 days ago. Everything is fine except that I face low internet speed everytime from the time of installation .
I searched on web but I was not able to fix it. Internet works fine in windows but whenever I switch to manjaro it gets very slow .Here are the screenshots.

Windows

and Manjaro


Here is my laptop specs

    ~  inxi --admin --verbosity=7 --filter --width                                                                                                             ✔ 
System:
  Kernel: 5.16.2-1-rt19-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.16-rt-x86_64
    root=UUID=2934a53f-fd77-4a35-ace0-700d88535683 rw quiet apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: KDE Plasma 5.23.5 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
Machine:
  Type: Laptop System: LENOVO product: ACLU12 v: Lenovo G50 70
    serial: <superuser required> Chassis: type: 10 v: Lenovo G50 70
    serial: <superuser required>
  Mobo: LENOVO model: VIUU4 serial: <superuser required>
    UEFI-[Legacy]: LENOVO v: 9ACN31WW date: 04/20/2015
Battery:
  ID-1: BAT0 charge: 16.4 Wh (58.6%) condition: 28.0/31.7 Wh (88.4%)
    volts: 15.4 min: 14.4 model: Lenovo IdeaPad type: Unknown serial: <filter>
    status: Discharging
Memory:
  RAM: total: 3.73 GiB used: 1.77 GiB (47.4%)
  RAM Report:
    permissions: Unable to run dmidecode. Root privileges required.
CPU:
  Info: model: Intel Core i5-4210U bits: 64 type: MT MCP arch: Haswell
    family: 6 model-id: 0x45 (69) stepping: 1 microcode: 0x26
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 3 MiB desc: 1x3 MiB
  Speed (MHz): avg: 1696 high: 1697 min/max: 800/2700 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 1696 2: 1697 3: 1696
    4: 1696 bogomips: 19155
  Flags: abm acpi aes aperfmperf apic arat arch_perfmon avx avx2 bmi1 bmi2
    bts clflush cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64
    dtherm dts epb ept ept_ad erms est f16c flexpriority flush_l1d fma fpu
    fsgsbase fxsr ht ibpb ibrs ida invpcid invpcid_single lahf_lm lm mca mce
    md_clear mmx monitor movbe msr mtrr nonstop_tsc nopl nx pae pat pbe pcid
    pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts rdrand
    rdtscp rep_good sdbg sep smep ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp
    syscall tm tm2 tpr_shadow tsc tsc_adjust tsc_deadline_timer vme vmx vnmi
    vpid xsave xsaveopt xtopology xtpr
  Vulnerabilities:
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
    mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
    IBRS_FW, STIBP: conditional, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel Haswell-ULT Integrated Graphics vendor: Lenovo driver: i915
    v: kernel bus-ID: 00:02.0 chip-ID: 8086:0a16 class-ID: 0300
  Device-2: IMC Networks Lenovo EasyCamera type: USB driver: uvcvideo
    bus-ID: 2-6:3 chip-ID: 13d3:5727 class-ID: 0e02 serial: <filter>
  Display: x11 server: X.org 1.21.1.3 compositor: kwin_x11 driver:
    loaded: modesetting alternate: fbdev,vesa resolution: <missing: xdpyinfo>
  OpenGL: renderer: Mesa DRI Intel HD Graphics 4400 (HSW GT2)
    v: 4.5 Mesa 21.3.5 compat-v: 3.0 direct render: Yes
Audio:
  Device-1: Intel Haswell-ULT HD Audio vendor: Lenovo driver: snd_hda_intel
    v: kernel bus-ID: 00:03.0 chip-ID: 8086:0a0c class-ID: 0403
  Device-2: Intel 8 Series HD Audio vendor: Lenovo driver: snd_hda_intel
    v: kernel bus-ID: 00:1b.0 chip-ID: 8086:9c20 class-ID: 0403
  Sound Server-1: ALSA v: k5.16.2-1-rt19-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.20 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.45 running: yes
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Lenovo driver: r8169 v: kernel port: 3000 bus-ID: 01:00.0
    chip-ID: 10ec:8168 class-ID: 0200
  IF: enp1s0 state: down mac: <filter>
  Device-2: Intel Wireless 3160 driver: iwlwifi v: kernel bus-ID: 02:00.0
    chip-ID: 8086:08b4 class-ID: 0280
  IF: wlp2s0 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
Bluetooth:
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8
    bus-ID: 2-7:4 chip-ID: 8087:07dc class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 3 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: see --recommends
Logical:
  Message: No logical block device data found.
RAID:
  Message: No RAID data found.
Drives:
  Local Storage: total: 931.51 GiB used: 28.47 GiB (3.1%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital
    model: WD10JPCX-24UE4T0 size: 931.51 GiB block-size: physical: 4096 B
    logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter>
    rev: 1A01 scheme: MBR
  Optical-1: /dev/sr0 vendor: HL-DT-ST model: DVDRAM GUC0N rev: T.02
    dev-links: cdrom
  Features: speed: 24 multisession: yes audio: yes dvd: yes
    rw: cd-r,cd-rw,dvd-r,dvd-ram state: running
Partition:
  ID-1: / raw-size: 292.97 GiB size: 287.31 GiB (98.07%)
    used: 28.47 GiB (9.9%) fs: ext4 dev: /dev/sda3 maj-min: 8:3 label: N/A
    uuid: 2934a53f-fd77-4a35-ace0-700d88535683
Swap:
  Alert: No swap data was found.
Unmounted:
  ID-1: /dev/sda1 maj-min: 8:1 size: 96.68 GiB fs: ntfs label: N/A
    uuid: EA965E41965E0F07
  ID-2: /dev/sda2 maj-min: 8:2 size: 244.14 GiB fs: ntfs label: N/A
    uuid: 9058C1A958C18F02
  ID-3: /dev/sda4 maj-min: 8:4 size: 297.72 GiB fs: ntfs label: N/A
    uuid: 8C02D34302D33146
USB:
  Hub-1: 1-0:1 info: Full speed or root hub ports: 2 rev: 2.0 speed: 480 Mb/s
    chip-ID: 1d6b:0002 class-ID: 0900
  Hub-2: 1-1:2 info: Intel Integrated Rate Matching Hub ports: 8 rev: 2.0
    speed: 480 Mb/s chip-ID: 8087:8000 class-ID: 0900
  Hub-3: 2-0:1 info: Hi-speed hub with single TT ports: 9 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 2-4:2 info: Realtek RTS5129 Card Reader Controller
    type: <vendor specific> driver: rtsx_usb,rtsx_usb_ms,rtsx_usb_sdmmc
    interfaces: 1 rev: 2.0 speed: 480 Mb/s power: 500mA chip-ID: 0bda:0129
    class-ID: ff00 serial: <filter>
  Device-2: 2-6:3 info: IMC Networks Lenovo EasyCamera type: Video
    driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA
    chip-ID: 13d3:5727 class-ID: 0e02 serial: <filter>
  Device-3: 2-7:4 info: Intel Bluetooth wireless interface type: Bluetooth
    driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA
    chip-ID: 8087:07dc class-ID: e001
  Hub-4: 3-0:1 info: Super-speed hub ports: 4 rev: 3.0 speed: 5 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
Sensors:
  System Temperatures: cpu: 38.0 C mobo: N/A
  Fan Speeds (RPM): N/A
^AInfo:
  Processes: 216 Uptime: 32m wakeups: 1 Init: systemd v: 250 tool: systemctl
  Compilers: gcc: 11.1.0 clang: 13.0.1 Packages: pacman: 1235 lib: 349
  flatpak: 0 Shell: Zsh v: 5.8 default: Bash v: 5.1.16 running-in: konsole
  inxi: 3.3.12
    ~                                                                                                                                                   ✔  6s  

It really is frustrating to have low internet speed.
How should I proceed now ?

What internet speed is reached with Windows ?

Download speed genrally reaches 40 Mb/s.

You could write a config file…

  1. Create a file here: /etc/modprobe.d/wifi.conf and open an editor:
sudo nano /etc/modprobe.d/wifi.conf
  1. Add there:
options iwlwifi swcrypto=1 # enables software crypto
options iwlwifi power_save=0 # disables power management
options iwlwifi 11n_disable=1 # disables 11n connections
options iwlwifi disable_11ac=1 # disables 11ac connections
options iwlwifi disable_11ax=1 # disables 11ax connections
  1. Save it and exit.

Save: CTRL + S

Close: CTRL + X

  1. Reboot your system.

More options here: modinfo iwlwifi

1 Like

I have done it

options iwlwifi swcrypto=1 # enables software crypto
options iwlwifi power_save=0 # disables power management

but how do I save the file .

I added it:

1 Like

I did exactly what you have said . I ran speedtest after rebooting my system . This is the screenshot of result


Speed improved slightly but still I am not getting my download speed anywhere near 40 Mbps .

your upload-speed is absolutely okay, only your download is corrupted. may you check your physical connection first ? it would be weird if only download-speed would be corrupted if it’s a software-failure. nothing is impossible, but that would be very strange.

I have connected it wirelessly . It is not connected via ethernet cable.

hm… maybe NetworkManager enables it again?

  1. Create a file here: /etc/NetworkManager/conf.d/wifi-powersave-off.conf
sudo nano /etc/NetworkManager/conf.d/wifi-powersave-off.conf
  1. With this content:
[connection]
# Values are 0 (use default), 1 (ignore/don't touch), 2 (disable) or 3 (enable).
wifi.powersave = 2

I added 3 more options:

That will disable 802.11n , 802.11ac and 802.11ax. So you will stay at 54Mbit. Maybe this works then and you get your 40Mbit ?

sometimes it happened that people with exact the same problem had to simply clear the local dns cache.
give it a try, it doesn’t harm and maybe it is as “simple” as this

sudo systemd-resolve --flush-caches

I did it . Here is the output

    ~  sudo nano/etc/NetworkManager/conf.d/wifi-powersave-off.conf                                                                                             ✔ 
[sudo] password for goldy: 
sudo: nano/etc/NetworkManager/conf.d/wifi-powersave-off.conf: command not found
    ~                                                                                                                                                 1 ✘  4s  

Read again… there is a space that I corrected already :wink:

I did it , here is the result

sudo systemd-resolve                                                                                                                                  1 ✘ 
Too few arguments.

and I checked the speed again it did not improve.

sudo systemd-resolve --flush-caches

It failed to do .

sudo systemd-resolve --flush-caches                                                                                                                   1 ✘ 
Failed to flush caches: Unit dbus-org.freedesktop.resolve1.service not found.

okay, as i explained it’s a worth a try and nothing else.
megavolt already adviced to edit a config, but from what i checked the internet it’s always made at startup. give it a try, but you have to reboot. if it doesn’t help you can remove the file with ‘sudo rm /etc/modprobe.d/iwlwifi.conf’

echo 'options iwlwifi swcrypto=1 bt_coex_active=1 11n_disable=8' | sudo tee /etc/modprobe.d/iwlwifi.conf

Hey bro download speed improved a lot it reached first time above 20 Mbps while testing.

and on fast net

Is anything else that should I do ?

And can you please tell me what was that command about