Internet speed is slow

What is your config right now?

cat /etc/modprobe.d/*.conf 

This one?

This is my config

cat /etc/modprobe.d/*.conf                                                                                                                              ✔ 
options iwlwifi 11n_disable=1 # disables 11n connections
options iwlwifi disable_11ac=1 # disables 11ac connections
options iwlwifi disable_11ax=1 # disables 11ax connections
options iwlwifi swcrypto=1 # enables software crypto
options iwlwifi power_save=0 # disables power management

I just wanted to know out of curiosity what these commands made changes in the system .

And is there anything else I can do by your help so that speed reaches around 40. :smiley:

change it to 8 and try for changes but reboot after changing or use modprobe

This just disables other protocols than 11b and 11g. Meaning these ones: IEEE 802.11 - Wikipedia

By default it uses the hardware on the chip for encrypting the connection. This replace it with a software one, what could result in a faster connection:

That disables the power managment of the wifi card. That means it will always stay at 100% and don’t try to save power:

So at this moment both connection are equal balanced (Download and Upload)…

Replace this option (1->8):

options iwlwifi 11n_disable=8

Explanation:
RX → Download
TX → Upload

11n_disable: disable 11n functionality
bitmap: 
1: full
2: disable agg TX (uint)
4: disable agg RX (uint)
8: enable agg TX (uint)

I am not 100% what the result will be, but worth a try. So as @Olli suggested.

@Olli
I had done what you all have told . I changed

options iwlwifi 11n_disable=1

to

options iwlwifi 11n_disable=8

but sadly it decreased my speed to 800kbps ,
so I undo it and rebooted so now the speed got back to 20Mbps.

1 Like

ok… I looked up your card: Intel Dual Band WirelessAC 3160 Product Specifications

Maybe enable 11ac again?

options iwlwifi disable_11ac=0

If your router has 11ac enabled it should connect on that protocol, but that would be then 5Ghz instead of 2.4Ghz.

I did it and rebooted .Here is the result

I think it increased by 2-3 Mbps .

goldy,
may you use ‘modinfo iwlwifi | grep parm’ and post it. this should output all parameters that are actually set of your wifi-connector.

Okay I will do it

Here is the output.

 modinfo iwlwifi | grep parm                                                                                                                             ✔ 
parm:           debug:debug output mask (uint)
parm:           swcrypto:using crypto in software (default 0 [hardware]) (int)
parm:           11n_disable:disable 11n functionality, bitmap: 1: full, 2: disable agg TX, 4: disable agg RX, 8 enable agg TX (uint)
parm:           amsdu_size:amsdu size 0: 12K for multi Rx queue devices, 2K for AX210 devices, 4K for other devices 1:4K 2:8K 3:12K (16K buffers) 4: 2K (default 0) (int)
parm:           fw_restart:restart firmware in case of error (default true) (bool)
parm:           nvm_file:NVM file name (charp)
parm:           uapsd_disable:disable U-APSD functionality bitmap 1: BSS 2: P2P Client (default: 3) (uint)
parm:           enable_ini:Enable debug INI TLV FW debug infrastructure (default: true (bool)
parm:           bt_coex_active:enable wifi/bt co-exist (default: enable) (bool)
parm:           led_mode:0=system default, 1=On(RF On)/Off(RF Off), 2=blinking, 3=Off (default: 0) (int)
parm:           power_save:enable WiFi power management (default: disable) (bool)
parm:           power_level:default power save level (range from 1 - 5, default: 1) (int)
parm:           disable_11ac:Disable VHT capabilities (default: false) (bool)
parm:           remove_when_gone:Remove dev from PCIe bus if it is deemed inaccessible (default: false) (bool)
parm:           disable_11ax:Disable HE capabilities (default: false) (bool)
 

@megavolt @Olli Why is the driver 8169??

don’t worry, this is the succesor/newer driver but your device is included. it causes more trouble using the older driver.

just for testing, can you power up your adapter to max and check for changes ? (don’t forget reboot)

options iwlwifi power_level=5

I checked the Internet speed on my phone ,it was same as that on laptop 23 Mbps . I think speed is probably slowed by my Isp or maybe it is slow due to multiple device connections .

Thanks @megavolt and @Olli for your help .
I will mark the solution.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.