Internal mic as well as bluetooth headphone mic not working on HP omen dh0137tx

Internal mic as well as bluetooth headphone(beoplay H4) mic not working on manjaro while I can use this two on windows without any issue.I am able to use mic by using type-c earphones but not with headphone jack .

System:    Kernel: 5.8.0-2-MANJARO x86_64 bits: 64 compiler: N/A Desktop: KDE Plasma 5.19.4 
           tk: Qt 5.15.0 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: HP product: OMEN by HP Laptop 15-dh0xxx v: N/A 
           serial: <filter> Chassis: type: 10 serial: <filter> 
           Mobo: HP model: 8600 v: 44.43 serial: <filter> UEFI: AMI v: F.30 date: 06/04/2020 
Battery:   ID-1: BAT1 charge: 63.7 Wh condition: 63.7/69.0 Wh (92%) volts: 13.1/11.6 
           model: COMPAL PABAS0241231 serial: <filter> status: Full 
CPU:       Topology: 6-Core model: Intel Core i7-9750H bits: 64 type: MT MCP arch: Kaby Lake 
           rev: A L2 cache: 12.0 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 62431 
           Speed: 800 MHz min/max: 800/4500 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 
           4: 800 5: 800 6: 800 7: 800 8: 800 9: 800 10: 800 11: 801 12: 800 
Graphics:  Device-1: NVIDIA TU106M [GeForce RTX 2060 Mobile] vendor: Hewlett-Packard 
           driver: nvidia v: 440.100 bus ID: 01:00.0 chip ID: 10de:1f11 
           Device-2: Chicony HP Wide Vision HD Camera type: USB driver: uvcvideo 
           bus ID: 1-5:2 chip ID: 04f2:b627 
           Display: x11 server: X.Org 1.20.8 compositor: kwin_x11 driver: nvidia 
           resolution: 1920x1080~144Hz s-dpi: 143 
           OpenGL: renderer: GeForce RTX 2060/PCIe/SSE2 v: 4.6.0 NVIDIA 440.100 
           direct render: Yes 
Audio:     Device-1: Intel Cannon Lake PCH cAVS vendor: Hewlett-Packard driver: snd_hda_intel 
           v: kernel bus ID: 00:1f.3 chip ID: 8086:a348 
           Device-2: NVIDIA TU106 High Definition Audio vendor: Hewlett-Packard 
           driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 10de:10f9 
           Sound Server: ALSA v: k5.8.0-2-MANJARO 
Network:   Device-1: Intel Wireless-AC 9560 [Jefferson Peak] driver: iwlwifi v: kernel 
           bus ID: 00:14.3 chip ID: 8086:a370 
           IF: wlp0s20f3 state: up mac: <filter> 
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
           vendor: Hewlett-Packard driver: r8169 v: kernel port: 3000 bus ID: 3c:00.0 
           chip ID: 10ec:8168 
           IF: enp60s0 state: down mac: <filter> 
Drives:    Local Storage: total: 1.38 TiB used: 78.96 GiB (5.6%) 
           ID-1: /dev/nvme0n1 vendor: Samsung model: MZVLB512HAJQ-000H1 size: 476.94 GiB 
           speed: 31.6 Gb/s lanes: 4 serial: <filter> 
           ID-2: /dev/sda vendor: Seagate model: ST1000LM049-2GH172 size: 931.51 GiB 
           speed: 6.0 Gb/s serial: <filter> 
RAID:      Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci v: 3.0 
           bus ID: 00:17.0 chip ID: 8086.282a 
Partition: ID-1: / size: 195.86 GiB used: 78.93 GiB (40.3%) fs: ext4 dev: /dev/nvme0n1p5 
Swap:      Alert: No Swap data was found. 
Sensors:   System Temperatures: cpu: 64.0 C mobo: 10.0 C gpu: nvidia temp: 49 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 305 Uptime: 15m Memory: 15.51 GiB used: 2.12 GiB (13.6%) Init: systemd 
           v: 245 Compilers: gcc: 10.1.0 alt: 8/9 Packages: pacman: 1394 Shell: Bash 
           v: 5.0.18 running in: konsole inxi: 3.1.05


I’ve found a solution on the old forum. Hope it helps :wink:


sudo nano /etc/modprobe.d/audiofix.conf

and add

options snd-hda-intel dmic_detect=0
options snd-hda-intel model=laptop-amic enable=yes

Then reboot the laptop.

I have already tried this , it didn’t helped. :worried:

1 Like

I’ve edited your output for better readability :slight_smile:


I’ve researched the kernel bugzilla and i found this:

Could you send the output of:

lsmod | grep snd
ls /lib/modules/
ls /sound/soc/intel/skylake
ls /sound/soc/intel/boards
ls /etc/modprobe.d/

just to compare please?

It could be possible that the kernel have to be compiled with skylake support…

I’ve had the same issue on my Omen dh1059nr (looks to be about the same model but with i7-10750h). Building the latest pulseaudio 13.99 from source fixed the internal mic, but I still can’t use the mic on my 3.5mm headset. Then updating to kernel 5.8 breaks sound completely, the Comet Lake card doesn’t even appear, but booting back into 5.7 is fine.

lsmod | grep snd

snd_seq_dummy          16384  0
snd_hrtimer            16384  1
snd_seq                86016  7 snd_seq_dummy
snd_seq_device         16384  1 snd_seq
snd_sof_pci            24576  0
snd_sof_intel_byt      20480  1 snd_sof_pci
snd_sof_intel_ipc      20480  1 snd_sof_intel_byt
snd_sof_intel_hda_common    90112  1 snd_sof_pci
snd_soc_hdac_hda       24576  1 snd_sof_intel_hda_common
snd_sof_xtensa_dsp     16384  2 snd_sof_intel_hda_common,snd_sof_intel_byt
snd_sof_intel_hda      20480  1 snd_sof_intel_hda_common
snd_sof               135168  4 snd_sof_pci,snd_sof_intel_hda_common,snd_sof_intel_byt,snd_sof_in
snd_soc_skl           180224  0
snd_soc_sst_ipc        20480  1 snd_soc_skl
snd_soc_sst_dsp        40960  1 snd_soc_skl
snd_hda_ext_core       36864  4 snd_sof_intel_hda_common,snd_soc_hdac_hda,snd_soc_skl,snd_sof_int
snd_soc_acpi_intel_match    45056  3 snd_sof_pci,snd_sof_intel_hda_common,snd_soc_skl
snd_soc_acpi           16384  4 snd_soc_acpi_intel_match,snd_sof_intel_hda_common,snd_sof_intel_b
snd_hda_codec_realtek   135168  1
snd_soc_core          323584  4 snd_sof,snd_sof_intel_hda_common,snd_soc_hdac_hda,snd_soc_skl
snd_hda_codec_generic    98304  1 snd_hda_codec_realtek
ledtrig_audio          16384  3 snd_hda_codec_generic,snd_hda_codec_realtek,snd_sof
snd_compress           32768  1 snd_soc_core
snd_hda_codec_hdmi     73728  1
ac97_bus               16384  1 snd_soc_core
snd_pcm_dmaengine      16384  1 snd_soc_core
snd_hda_intel          57344  5
snd_intel_dspcfg       24576  4 snd_hda_intel,snd_sof_pci,snd_sof_intel_hda_common,snd_soc_skl
snd_hda_codec         167936  5 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_co
snd_hda_core          106496  10 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_e
snd_hwdep              16384  1 snd_hda_codec
snd_pcm               147456  10 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_sof,snd_sof_i
snd_timer              45056  3 snd_seq,snd_hrtimer,snd_pcm
snd                   114688  24 snd_hda_codec_generic,snd_seq,snd_seq_device,snd_hda_codec_hdmi,
soundcore              16384  1 snd

ls /lib/modules/

5.6.17-2-rt9-MANJARO  5.8.0-2-MANJARO              extramodules-5.7-MANJARO
5.7.14-1-MANJARO      extramodules-5.6-rt-MANJARO  extramodules-5.8-MANJARO

ls /sound/soc/intel/skylake

ls: cannot access '/sound/soc/intel/skylake': No such file or directory

ls /sound/soc/intel/boards

ls: cannot access '/sound/soc/intel/boards': No such file or directory

ls /etc/modprobe.d/

alsa-base.conf  audiofix.conf  mhwd-gpu.conf  snd-hda-intel.conf

option to disable internal microphone array from post in May is no longer viable for kernel v5.8, see this later post from July

Bad audio quality from earphones - Hardware - Manjaro Linux Forum

!!ALSA/HDA dmesg

[ 2.126856] snd_hda_intel 0000:00:1f.3: dmic_detect option is deprecated, pass snd-intel-dspcfg.dsp_driver=1 option instead

I replaced dmic_detect option with snd-intel-dspcfg.dsp_driver=1 now my speaker also won’t work. Reversing back to dmic_detect option , my speaker started working.

PS: If you are running kernel 5.8 then you will get this issue.

installed sof-firmware and build pulseaudio 13.99 from source.Now my bluetooth headset mic are working but now I have another issue that, under bluetooth option my headphones will be connected but I will not receive any sound and mic also won’t work but sometimes both works fine.

Replacing dmic_detect option with snd-intel-dspcfg.dsp_driver=1 is the solution .If it doesn’t work check if speaker is muted. Thank You Everyone. :smile:

PS: This doesn’t work on kernel 5.8 .

the option snd-intel-dspcfg.dsp_driver=1 replaced the previous option
but should check in sudo dmesg | grep snd to see if system advises changing option
the modprobe option is to disable the internal DMIC array microphone to continue using the ‘legacy’ driver snd_hda_intel so is not a full solution

full solution is to support internal microphone array using sof-hda-dsp driver
by installing sof-firmware and pulseaudio-git (as already mentioned)
the previous modprobe options should be removed for new packages to work correctly

1 Like

Yes! I have installed sof-firmware and pulseaudio 13.99 (git) and I have blacklisted snd_hda_intel.Just mentioned it in another reply. :smile: Should I write whole procedure or its okay (I am new on the forum).

Whole procedure is not really necessary. sometime soon ( :crossed_fingers:)Pulseaudio will release v14 and everything should work for most users without need for extra packages

I have moved the solution mark from my post to your last post, because it is the correct answer

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.