Hp omen 2020, internal mic not working. Ryzen 4800h,1660ti

System Info

inxi -SAz

System:    Kernel: 5.10.42-1-MANJARO x86_64 bits: 64 Desktop: KDE Plasma 5.21.5 
           Distro: Manjaro Linux 
Audio:     Device-1: AMD Raven/Raven2/FireFlight/Renoir Audio Processor 
           driver: snd_rn_pci_acp3x 
           Device-2: AMD Family 17h HD Audio driver: snd_hda_intel 
           Sound Server-1: ALSA v: k5.10.42-1-MANJARO running: yes 
           Sound Server-2: PulseAudio v: 14.2 running: yes 

arecord -l

**** List of CAPTURE Hardware Devices ****
card 0: Generic [HD-Audio Generic], device 0: ALC245 Analog [ALC245 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: acp [acp], device 0: DMIC capture dmic-hifi-0 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0

What i tried

  1. I tried to force dmic_check on grub_commandline
  2. I tried to update the kernel to release 5.12 from 5.10
  3. uncommenting loadmodule module-alsa-source device=hw:1,0 in /etc/pulse/default.pa fixes it but on reboot the arecord -l shows changed mapping as the dmic entry moves sometimes to 0,0 or 1,0 so i have to manually hook it up for the audio to work. And with this it shows two mics one of which doesn’t work.

Start reading from here on:

I did try the solution but it didn’t work for me.

options snd-intel-dspcfg dsp-driver=1

in /etc/modprobe.d/alsa.conf

in /etc/pulse/default.pa
ucommentting the source module start up the microphone
speaker also works