Inconsistent global scale in KDE on 1440p monitor

I have been running the KDE plasma edition for many months on a 1080p monitor without any issues. The following anomaly started after I changed to a 2560x1440p monitor.

With global scale set at 100% most KDE applications and system UI elements are scaled to the equivalent of 150% (or there about). Other applications such as web browsers are scaled as I would expect for this monitor at 100% scale. Increasing the scale to 125% changes the scaling of KDE applications etc to what appears to be 100%. Browsers and other applications increase to 125% scale. Changing global scale to 150% appears to result in uniform scaling at 150%.

I have tested my hardware setup with a live USB environment and scaling worked perfectly.

I would like to have scaling set at 100% to maximise the screen real estate that I have but just can’t do it currently with the inconsistent scaling levels. I am hoping there is a fix so that I don’t have to reinstall the OS.

Any advice would be appreciated.

Hello and welcome,

Since everything looks fine in Live session, it means you have settings (either at user level or system wide) that are conflictual to your curent setup. In KDE Plasma you can probably remove/edit the following files:

Example given by @dalto at some point:

  • Edit the file “plasma-org.kde.plasma.desktop-appletsrc”
  • Search the file for “SystrayContainmentId” there will be a number after the “=” sign
  • Scroll down to “[Containments][8][General]” replacing “8” with your number from the previous step
  • If iconSize is not already in that section add a line that reads “iconSize=2”. Replace 2 with your desired scale factor

Probably you could reset all the configs for KDE and start over. Here is what for instance @xircon used to recommend:
Reset and backup plasma

cd /home/<your-username>/.config
mkdir plasma-old
mv *rc plasma-old/
mv kdeglobals plasma-old/

If you have an Nvidia GPU, then you can check the /etc/X11/mhwd.d/nvidia.conf file and eventually create a new config via Nvidia X Server settings.

1 Like

Thanks for the suggestions - I will use them when I have more time for troubleshooting in case I brake something in the process. In the meantime I have a “work around”. I have set global scale to 106.25% which works fine.

I’ve just encountered this problem.

I resetted all the KDE configs but the issue was still the same.
Found out that it was this line in /etc/X11/mhwd.d/nvidia.conf that was the cause:
In the Section “Screen” (I have 2 monitors)

Option         "metamodes" "DP-4: nvidia-auto-select +0+0 {ForceCompositionPipeline=On, ForceFullCompositionPipeline=On}, HDMI-0: nvidia-auto-select +2560+0 {rotation=left, ForceCompositionPipeline=On, ForceFullCompositionPipeline=On}"

ForceCompositionPipeline and ForceFullCompositionPipeline are the culprits it seems.
Removing this line and rebooting solved the problem.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.