Just installed Manjaro and no sound at all

To the bottom center, above master, is it mm or 00 ?

I dont have the sof-firmware anymore because Im following through a gpu hijack thing for a vm and it reset it back to having no audio outputs or inputs. Tried redownloading it again and now its still not showing up so I screwed something and Im trying to figure out what im doing wrong this time, also it was muted I unmuted it via alsamixer but now sof is not showing up there at all

Okay, can you hit f6 in alsamixer and choose the right sound card?

the only options are default and HDA NVidia

Hm, enter this sudo echo "options snd-hda-intel dmic_detect=0" | sudo tee -a /etc/modprobe.d/alsa-base.conf in the terminal, followed by sudo echo "blacklist snd_soc_skl" | sudo tee -a /etc/modprobe.d/blacklist.conf , then restart.

1 Like

My friend says you messed up my audio up more is this true?

your audio was already messed up
According to ASUS website specifications, FX505GT has

Built-in 2 W Stereo Speakers with Array Microphone

The Internal digital array microphone (DMIC) requires package sof-firmware to get the correct driver

and probably needs pulseaudio-git from AUR to get the internal audio fully supported

HP Envy - Sound does not work in Manjaro 20.1 PLASMA

kernel 5.8 together with pulseaudio-git (v13.99) made it - sound and microfone work now

I had first to remove libao, fluidsynth, lib32-fluidsynth and manjaro-pulse
after that I could install pulseaudio-git
having installed pulseaudio-git I added libao, fluidsynth, lib32-fluidsynth and manjaro-pulse

also suggest you consider updating system to latest firmware

1 Like

That option is ignored by newer kernels with the following warning:

dmic_detect option is deprecated, pass snd-intel-dspcfg.dsp_driver=1 option instead

1 Like

i’ve this issue one time and, after sleeping my pc and opening back the sound comes back, that was confusing :confused:

I did the commands and restarted what next?

It says sof-firmware is downloaded but it has not added any new drivers

[stevensoviet@steven-tufgamingfx505gtfx505gt ~]$ sudo dmesg | egrep ‘(snd|sound|sof)’
[ 0.984972] PCI-DMA: Using software bounce buffering for IO (SWIOTLB)
[ 0.984974] software IO TLB: mapped [mem 0x70d34000-0x74d34000] (64MB)
[ 9.979329] snd_hda_intel 0000:01:00.1: dmic_detect option is deprecated, pass snd-intel-dspcfg.dsp_driver=1 option instead
[ 9.979670] snd_hda_intel 0000:01:00.1: Disabling MSI
[ 9.979688] snd_hda_intel 0000:01:00.1: Handle vga_switcheroo audio client
[ 10.023686] input: HDA NVidia HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card0/input21
[ 10.023887] input: HDA NVidia HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card0/input22
[ 10.024002] input: HDA NVidia HDMI/DP,pcm=8 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card0/input23
[ 10.024095] input: HDA NVidia HDMI/DP,pcm=9 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card0/input24
[ 10.590872] snd_hda_intel 0000:01:00.1: bound 0000:01:00.0 (ops nv50_audio_component_bind_ops [nouveau])

Edit: I rebooted various times

I now know what do to but I do not know the command im exactly supposed to type in to libao , fluidsynth , lib32-fluidsynth and manjaro-pulse, and I do not know the exact command to install pulseaudio-git or know how to add libao , fluidsynth , lib32-fluidsynth and manjaro-pulse. As you can tell I do not linux well. Also if you knew the command to uninstall sof-firmware that would be great I need to uninstall it and reinstall it and see if it actually does something the second time

Also its important to note that I am following this guide (How I Built The "Poor-Shamed" Computer... - YouTube) and am so far up to 19:45

inxi -Fazy (Updated Output):
Kernel: 5.8.11-1-MANJARO x86_64 bits: 64 compiler: N/A
parameters: BOOT_IMAGE=/boot/vmlinuz-5.8-x86_64
root=UUID=a57be26f-d971-46e2-9b28-5909ec18d0c2 rw quiet apparmor=1
security=apparmor resume=UUID=c35f853d-c432-47ca-aef1-19864243bea9
Desktop: Xfce 4.14.2 tk: Gtk 3.24.20 info: xfce4-panel wm: xfwm4
dm: LightDM 1.30.0 Distro: Manjaro Linux
Type: Laptop System: ASUSTeK product: TUF Gaming FX505GT_FX505GT v: 1.0
Mobo: ASUSTeK model: FX505GT v: 1.0 serial:
UEFI: American Megatrends v: FX505GT.307 date: 06/24/2020
ID-1: BAT0 charge: 39.8 Wh condition: 39.8/48.1 Wh (83%) volts: 12.7/11.7
model: Simplo SDI ICR18650 type: Li-ion serial: status: Full
cycles: 41
Device-1: hidpp_battery_0 model: Logitech Wireless Mouse M510
serial: charge: 55% (should be ignored) rechargeable: yes
status: Discharging
Topology: Quad Core model: Intel Core i5-9300H bits: 64 type: MT MCP
arch: Kaby Lake family: 6 model-id: 9E (158) stepping: D (13) microcode: D6
L2 cache: 8192 KiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
bogomips: 38408
Speed: 800 MHz min/max: 800/4100 MHz Core speeds (MHz): 1: 807 2: 803 3: 840
4: 881 5: 844 6: 850 7: 843 8: 844
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
Type: srbds mitigation: TSX disabled
Type: tsx_async_abort status: Not affected
Device-1: Intel UHD Graphics 630 vendor: ASUSTeK driver: i915 v: kernel
bus ID: 00:02.0 chip ID: 8086:3e9b
Device-2: NVIDIA TU117M [GeForce GTX 1650 Mobile / Max-Q] vendor: ASUSTeK
driver: nouveau v: kernel bus ID: 01:00.0 chip ID: 10de:1f91
Device-3: IMC Networks USB2.0 HD UVC WebCam type: USB driver: uvcvideo
bus ID: 1-11:4 chip ID: 13d3:56a2 serial:
Display: x11 server: X.Org 1.20.9 driver: intel,modesetting,nouveau
alternate: fbdev,nv,vesa display ID: :0.0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
s-diag: 582mm (22.9")
Monitor-1: eDP1 res: 1920x1080 hz: 60 dpi: 143 size: 340x190mm (13.4x7.5")
diag: 389mm (15.3")
OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa 20.1.8
direct render: Yes
Device-1: Intel Cannon Lake PCH cAVS vendor: ASUSTeK driver: sof-audio-pci
alternate: snd_hda_intel,snd_soc_skl,snd_sof_pci bus ID: 00:1f.3
chip ID: 8086:a348
Device-2: NVIDIA vendor: ASUSTeK driver: snd_hda_intel v: kernel
bus ID: 01:00.1 chip ID: 10de:10fa
Sound Server: ALSA v: k5.8.11-1-MANJARO
Device-1: Intel Wireless-AC 9560 [Jefferson Peak] driver: iwlwifi v: kernel
port: 5000 bus ID: 00:14.3 chip ID: 8086:a370
IF: wlo1 state: up mac:
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: ASUSTeK driver: r8169 v: kernel port: 3000 bus ID: 03:00.0
chip ID: 10ec:8168
IF: enp3s0 state: down mac:
Local Storage: total: 1.38 TiB used: 6.16 GiB (0.4%)
SMART Message: Required tool smartctl not installed. Check --recommends
ID-1: /dev/nvme0n1 vendor: Intel model: SSDPEKNW512G8 size: 476.94 GiB
block size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4
serial: rev: 002C scheme: GPT
ID-2: /dev/sda vendor: Seagate model: ST1000LM048-2E7172 size: 931.51 GiB
block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
rotation: 5400 rpm serial: rev: SDM1 scheme: GPT
ID-1: / raw size: 442.30 GiB size: 434.36 GiB (98.20%) used: 6.16 GiB (1.4%)
fs: ext4 dev: /dev/nvme0n1p2
Kernel: swappiness: 60 (default) cache pressure: 100 (default)
ID-1: swap-1 type: partition size: 34.34 GiB used: 0 KiB (0.0%) priority: -2
dev: /dev/nvme0n1p3
System Temperatures: cpu: 55.0 C mobo: 27.8 C gpu: nouveau temp: 42 C
Fan Speeds (RPM): cpu: 2700
Processes: 275 Uptime: 4m Memory: 31.22 GiB used: 1.36 GiB (4.4%)
Init: systemd v: 246 Compilers: gcc: N/A Packages: pacman: 1056 lib: 311
flatpak: 0 Shell: Bash v: 5.0.18 running in: xfce4-terminal inxi: 3.1.05

Edit: So I just reinstalled manjaro on my SSD and deleted it on my HDD which I previously installed it on, I followed the same instructions in the beginning of this forum and got sof-firmware to work, my problem was that it was muted and at volume 0 in alsamixer so I changed it in there. (Just type ‘alsamixer’ in terminal, hit f6, go to the sof drivers, use arrow keys to navigate to the master bar which is on the left, and hit M once over it and use the up arrow key to increase the volume.) I have to do this every boot because for some reason it boots it as muted and at 0 but at least it isnt to difficult

The thing is it reset like I never installed those drivers when I passed over some hardware and reinstalling sof-firmware did not work so im going to follow through the tutorial I previously linked again and hope it does not give me that issue again.

Alright I fixed this problem somehow solution is above I got another that isnt really manjaro related and more virtual machine related about hiding NVIDIA cards thanks for the help people

changes in alsamixer are normally not persistent and settings will reset on reboot unless they are saved

sudo alsactl store

see this

A new version of PulseAudio (v13.99) was included in [Testing Update] 2020-10-16
so installing pulseaudio-git from AUR is no longer needed, just switch to testing branch and update to get the new package version
or wait a week or so and it may also be released to stable branch

How did you get it fixed?

PulseAudio v13.99 was included with Stable Update 2020-11-04
so updating on stable branch provided the package to support internal dmic with sof-firmware

make sense , thankyou.
This seems replace sof-audio-pci with the old version, snd-hda-intel.