Hibernate doesn't work, shuts down instead

I have a dell inspiron 3542 laptop and hibernating doesn’t seem to work.
i have tried issuing the systemctl hibernate command as well as the kde gui stuff.
I have also tried switching kernels, both 5.15 and 5.10(LTS) failed to successfully hibernate.
every time i issue the hibernate command the computer screen would turn off and then turn on again with a completely back screen for a few seconds and then turn off the screen as well as the computer. It would only come back up if i press the power button but when I do so, it would boot like it were shutdown and not hibernating. I would start with a completely new session with none of the windows previously open.
Can someone help me with this?
sorry for not posting the system info before, here is my system info:

  Kernel: 5.15.12-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=fe780552-423e-483f-a39f-82c6a23f80b4 rw quiet apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: KDE Plasma 5.23.4 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
Machine:
  Type: Portable System: Dell product: Inspiron 3542 v: N/A
    serial: <superuser required> Chassis: type: 8 serial: <superuser required>
  Mobo: Dell model: 0KHNVP v: A13 serial: <superuser required> UEFI: Dell
    v: A13 date: 01/30/2018
Battery:
  ID-1: BAT0 charge: 34.7 Wh (86.1%) condition: 40.3/41.6 Wh (96.9%)
    volts: 16.3 min: 14.6 model: SMP-LG2.85 DELL 1C12X31 type: Li-ion
    serial: <filter> status: Charging
Memory:
  RAM: total: 3.74 GiB used: 1.95 GiB (52.1%)
  RAM Report:
    permissions: Unable to run dmidecode. Root privileges required.
CPU:
  Info: model: Intel Core i3-4005U bits: 64 type: MT MCP arch: Haswell
    family: 6 model-id: 0x45 (69) stepping: 1 microcode: 0x26
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 3 MiB desc: 1x3 MiB
  Speed (MHz): avg: 1642 high: 1696 min/max: 800/1700 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 1696 2: 1696 3: 1696
    4: 1481 bogomips: 13573
  Flags: abm acpi aes aperfmperf apic arat arch_perfmon avx avx2 bmi1 bmi2
    bts clflush cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64
    dtherm dts epb ept ept_ad erms est f16c flexpriority flush_l1d fma fpu
    fsgsbase fxsr ht ibpb ibrs ida invpcid invpcid_single lahf_lm lm mca mce
    md_clear mmx monitor movbe msr mtrr nonstop_tsc nopl nx pae pat pbe pcid
    pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts rdrand
    rdtscp rep_good sdbg sep smep ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp
    syscall tm tm2 tpr_shadow tsc tsc_adjust tsc_deadline_timer vme vmx vnmi
    vpid xsave xsaveopt xtopology xtpr
  Vulnerabilities:
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
    mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
    IBRS_FW, STIBP: conditional, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel Haswell-ULT Integrated Graphics vendor: Dell driver: i915
    v: kernel bus-ID: 00:02.0 chip-ID: 8086:0a16 class-ID: 0300
  Device-2: Microdia Integrated_Webcam_HD type: USB driver: uvcvideo
    bus-ID: 1-1.5:3 chip-ID: 0c45:670b class-ID: 0e02
  Display: x11 server: X.Org 1.21.1.2 compositor: kwin_x11 driver:
    loaded: modesetting alternate: fbdev,vesa display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0")
    s-diag: 414mm (16.3")
  Monitor-1: eDP-1 res: 1366x768 hz: 60 dpi: 101 size: 344x193mm (13.5x7.6")
    diag: 394mm (15.5")
  Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:
  Device-1: Intel Haswell-ULT HD Audio vendor: Dell driver: snd_hda_intel
    v: kernel bus-ID: 00:03.0 chip-ID: 8086:0a0c class-ID: 0403
  Device-2: Intel 8 Series HD Audio vendor: Dell driver: snd_hda_intel
    v: kernel bus-ID: 00:1b.0 chip-ID: 8086:9c20 class-ID: 0403
  Sound Server-1: ALSA v: k5.15.12-1-MANJARO running: yes
  Sound Server-2: sndio v: N/A running: no
  Sound Server-3: JACK v: 1.9.19 running: no
  Sound Server-4: PulseAudio v: 15.0 running: yes
  Sound Server-5: PipeWire v: 0.3.42 running: no
Network:
  Device-1: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter
    vendor: Dell driver: ath9k v: kernel bus-ID: 06:00.0 chip-ID: 168c:0036
    class-ID: 0280
  IF: wlp6s0 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  Device-2: Realtek RTL810xE PCI Express Fast Ethernet vendor: Dell
    driver: r8169 v: kernel port: e000 bus-ID: 07:00.0 chip-ID: 10ec:8136
    class-ID: 0200
  IF: enp7s0 state: down mac: <filter>
  WAN IP: <filter>
Bluetooth:
  Device-1: Qualcomm Atheros AR9462 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 1-1.6:6 chip-ID: 0cf3:0036 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 2 state: up address: see --recommends
Logical:
  Message: No logical block device data found.
RAID:
  Message: No RAID data found.
Drives:
  Local Storage: total: 931.51 GiB used: 103.82 GiB (11.1%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000LM024 HN-M101MBB
    size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: HDD rpm: 5400 serial: <filter> rev: 0004 scheme: GPT
  Optical-1: /dev/sr0 vendor: HL-DT-ST model: DVD+-RW GU90N rev: A1C0
    dev-links: cdrom
  Features: speed: 24 multisession: yes audio: yes dvd: yes
    rw: cd-r,cd-rw,dvd-r,dvd-ram state: running
Partition:
  ID-1: / raw-size: 70 GiB size: 68.35 GiB (97.64%) used: 16.58 GiB (24.3%)
    fs: ext4 dev: /dev/sda2 maj-min: 8:2 label: root
    uuid: fe780552-423e-483f-a39f-82c6a23f80b4
  ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%)
    used: 288 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1 label: N/A
    uuid: AE3A-D706
  ID-3: /home raw-size: 53 GiB size: 51.87 GiB (97.86%)
    used: 4.57 GiB (8.8%) fs: ext4 dev: /dev/sda3 maj-min: 8:3 label: home
    uuid: d2f8fd7a-7f22-4b97-8ad7-b2fa88b7a451
  ID-4: /media/storage raw-size: 702.36 GiB size: 702.36 GiB (100.00%)
    used: 82.67 GiB (11.8%) fs: ntfs dev: /dev/sda5 maj-min: 8:5 label: storage
    uuid: 3C8E47E5341FDBFD
Swap:
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 8 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/sda4 maj-min: 8:4 label: N/A
    uuid: 61a1b64b-c795-4beb-881a-0ea46ed95b4e
Unmounted:
  ID-1: /dev/sda6 maj-min: 8:6 size: 97.66 GiB fs: ext4 label: backuptimeshift
    uuid: 87eb4f07-8984-46b0-8994-9d0d0338e3e7
USB:
  Hub-1: 1-0:1 info: Full speed or root hub ports: 2 rev: 2.0 speed: 480 Mb/s
    chip-ID: 1d6b:0002 class-ID: 0900
  Hub-2: 1-1:2 info: Intel Integrated Rate Matching Hub ports: 8 rev: 2.0
    speed: 480 Mb/s chip-ID: 8087:8000 class-ID: 0900
  Device-1: 1-1.5:3 info: Microdia Integrated_Webcam_HD type: Video
    driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA
    chip-ID: 0c45:670b class-ID: 0e02
  Device-2: 1-1.6:6 info: Qualcomm Atheros AR9462 Bluetooth type: Bluetooth
    driver: btusb interfaces: 2 rev: 1.1 speed: 12 Mb/s power: 100mA
    chip-ID: 0cf3:0036 class-ID: e001
  Device-3: 1-1.8:5 info: Realtek RTS5129 Card Reader Controller
    type: <vendor specific> driver: rtsx_usb,rtsx_usb_ms,rtsx_usb_sdmmc
    interfaces: 1 rev: 2.0 speed: 480 Mb/s power: 500mA chip-ID: 0bda:0129
    class-ID: ff00 serial: <filter>
  Hub-3: 2-0:1 info: Hi-speed hub with single TT ports: 8 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-4: 3-0:1 info: Super-speed hub ports: 4 rev: 3.0 speed: 5 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
Sensors:
  System Temperatures: cpu: 51.0 C mobo: 47.0 C
  Fan Speeds (RPM): cpu: 0
Info:
  Processes: 201 Uptime: 6m wakeups: 1 Init: systemd v: 250 tool: systemctl
  Compilers: gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1462 lib: 386
  flatpak: 0 Shell: Zsh v: 5.8 default: Bash v: 5.1.12 running-in: konsole
  inxi: 3.3.11

how do i proceed?

Provide basic Information:

I have updated the post with system info. thanks