Hi, i was running manjaro kde. Nothing is working after Update

I’m not sure what is happening.
Kindly check the screenshot. I have provided.
If any further information needed, kindly ask me.

I’m newbie.

Waiting 10 seconds for device…

Error . Not found.

Skipping fsck

Mounting uuid … On real root.
Mount /new_root can’t find uiidxxxxxx
You Are now being dropped into an emergency shell.
Sh can’t access tty . Job control turned off.
Mkinitcpio . Not found. I tried cat /boot/grub/grub.cfg
Can’t open. No such file or directory.

Any help will be highly appreciated.

Then probably the update was interrupted.

1 Like

How to boot from USB into live Manjaro (for repair):

Welcome to Manjaro! :smiling_face_with_three_hearts:

  1. Please read the information behind this link. It will help you to post necessary information. [HowTo] Provide System Information
  2. Please press the three dots below your post and then press the :pencil2:
  • If you give us information about your system, we can see what we’re talking about and make better suggestions.
  • You can do this by using inxi in a terminal or in console.
inxi --admin --verbosity=7 --filter --no-host --width
  • Personally identifiable information such as serial numbers and MAC addresses are filtered out by this command
  • Presenting the information in this way allows everyone to be familiar with the format and quickly find the items they need without missing anything.
  1. Copy the output from inxi (including the command) and paste it into your post.
  • To make it more readable, add 3 backticks ``` on an extra line before and after the pasted text.
    (Wisdom lies in reading :wink: )

You can also use maxi -eg

to collect information about the boot process. This works,

  • when you are in your running system (with CTRL+ALT+F2).
  • And also in a live environment
1 Like

Could you please tell me what steps i need to follow to get the system back to normal?

I am interested to install pop os using a pendrive and copy files from manjaro to pop os + i would like to install windows 10 or any version as dual boot.

I urgently need this help.
I will be very grateful for a detailed guidance.
I’m kind of a beginner specially with archlinux.
Instead of telling me: edit /remove or do this and update /or anything similar, kindly give me the direct command line input codes that i may type on the PC. When system brings me to rootfs… However, there’s a way i know that i can get into grub cmd line. There’s an option.

So kindly tell me the right way to do this. Because i don’t know anything. But you guys are experts.

It’s a great privilege for me to interact with expert Linux experts.
I personally admire Linux OS very much.
Many thanks in advance for anyone who would like to show some kindness and help me solve the issues.

See post #3.

What is post number 3? I could not understand. I’m sorry.

Could you please copy and paste and give me the commands to enter if i am in rootfs shell . If i enter password and try to login to manjaro or any other option below it. Rootfs appears.

Or if i am in grub menu . (This is accessible when i input the password and then advanced boot open opens where it shows manjaro. And fall back something like that.
And at the bottom center. There is option to go to grub.

I’m very afraid now to use Linux because if nobody will help me, my laptop will become a garbage and i will have no more access to a computer system.

I wish there could be a Linux OS that doesn’t go into such serious problems like manjaro where probably because of update interruption or another reason, it is not even possible now to install any os using a pendrive and copy files from old partition and save yourself. Ah.
I’m very much sad.

Sorry. You can’t embed media items in a… I tried to send screenshot of pc.

all linux distros would get messed up after a botched/interrupted update…
boot into manjaro live usb, connect to internet, chroot:
manjaro-chroot -a
and from there rerun update again:
pacman-mirrors -f 5 && pacman -Syyu
if there were no errors, and you up to date, post output from:
mhwd-kernel -li
cat /etc/fstab

and our data is not lost, you can access it from the live usb…

Wow! Your name is Brahma. I have seen your several answers on various questions. You are a very expert person in Linux.

Thank you very much Brahma for your kind assistance. I will definitely follow your guidance and update back here in the comments the outputs.

Meanwhile, while following your instructions, i might get into another error, because i am absolutely a newbie and know almost nothing, i will post the output in that case too.

Kindly keep supporting me.

Also, i would like to contact you for helping me build a tool using python or any other language.
I will pay you for your guidance or help or if you could please create the tool based on my preferences.
I will be grateful too.

Many many thanks again, Brahma. I highly appreciate your kind efforts and time for writing to help me. :handshake:

Boot with open source drivers
Boot with proprietary drivers
Edit boot options
Installed BIOS system on.

What should I select?
Thanks again

I clicked on boot with proprietary drivers…

And then i opened mate cmd line.

It shows.


I typed :

manjaro-chroot -a

grub-probe: error: cannot find a Grub drive for /dev/ssb1. Check your device.map

grub-probe: error:. . . . . . (same as above)

==> ERROR: No Linux Partitions detected!

However, if i power on pc without live usb manjaro, the grub menu opens and asks for password of my manjaro account. pc user. I enter password.
Then it says opening slot 0 .
And then errors and dropped into emergency shell. No tty . .

Can anyone please guide me?
I’m sitting on the pc and waiting for someone’s help.
Thank you.

do you have encryprtion?
from the live usb post output from:


and use formatting, click this icon in the editor: </>

Sure. I will do it now.
I am in love usb manjaro mate.
I will open mate terminal and type these commands and then type here the output.

I hope i understood you correctly.

you dont have to type out the output, just copy it and use formatting:

your output here


your output here

My apologies but i cannot copy or paste because i am using this area on my phone. And typing on pc.

of course you can copy… just log in to the forum from the live usb and copy the output

I’ll try this now.

I will try to access this page on a browser in the live usb manjaro in pc now. Kindly wait for me for a moment.

Hi. Wifi is connected but i opened the firefox and no any page is loading. Firefox can’t access internet. What should I do?

well i cant help you with that… close firefox, check if you are actually connected to your wifi, and try again

I will try to access internet now. On pc.

hi, i hae internet access in pc now. i will tyr given command in mate terminal noww and paste the output

PATH                                                  PTTYPE PARTTYPE FSTYPE      PARTTYPENAME
/dev/loop0                                                            squashfs    
/dev/loop1                                                            squashfs    
/dev/loop2                                                            squashfs    
/dev/loop3                                                            squashfs    
/dev/sda                                              dos                         
/dev/sda1                                             dos    0x83     crypto_LUKS Linux
/dev/sdb                                              dos             iso9660     
/dev/sdb1                                             dos    0x0      iso9660     Empty
/dev/sdb2                                             dos    0xef     vfat        EFI (FAT-12/16/32)
/dev/mapper/luks-2e1b47f7-ac28-47f5-ba82-e00da8b4bb99                 ext4  

ok, so you have encyption, thats why the manjaro chroot command didnt work…
run these to chroot:

sudo cryptsetup -v luksOpen /dev/sr0 cryptDrive
sudo mount /dev/mapper/cryptDrive /mnt
sudo manjaro-chroot /mnt

and post output from it, to check if everything is ok

1 Like
[manjaro@manjaro-mate ~]$ sudo cryptsetup -v luksOpen /dev/sr0 cryptDrive
sudo mount /dev/mapper/cryptDrive /mnt
sudo manjaro-chroot /mnt
Device /dev/sr0 does not exist or access denied.
Command failed with code -4 (wrong device or file specified).
mount: /mnt: special device /dev/mapper/cryptDrive does not exist.
       dmesg(1) may have more information after failed mount system call.
mount: /mnt/proc: mount point does not exist.
       dmesg(1) may have more information after failed mount system call.
==> ERROR: failed to setup API filesystems in chroot /mnt

ok, so post output from:
sudo fdisk -l

1 Like