Hi, I connected PPPoE connection to router and connected router to PC through LAN cable and can't browse Internet on browser

ISP said i dont need IP Address Address, MAC, DNS.
Also telling me to change OS to Win7. Can i get help browsing internet on manjaro linux without ISP’s help.(they are so unhelpful…)

The router settings:

  • WAN connection has to be set to PPPoE with the user and password provided by ISP
  • LAN connection i guess is sett to 192.168.0.1 (or whatever the default it); Subnet Class 255.255.255.0
  • The DHCP server must be enabled and the Starting IP should be in the same class, but not the same as the router LAN - example 192.168.0.100 while End IP should be 192.168.0.199
  • Default gateway should be the router IP, hence 192.168.0.1

Your Manjaro install Network Settings:

  1. General
  • Connect Automatically should be enabled
  • All users may connect … is optional, but can be enabled
  1. Wired
  • you can restrict to the mac address
  • Link negotiation can be Automatic
  1. IPv4
  • Automatic
  1. IPv6
  • you can disable it …

Restart all your devices after that and you should be connected.

A Bit more info might help here.

Did your ISP supply the Router? In which case they would have already set up the WAN connection… which might be why they are say you don’t need IP Address Address, MAC, DNS.

Also if they supplied the router, the DHCP server will also be set up by them, so that it doesn’t matter if you are connecting to the Router Via Wireless or EtherNet cable, either way NetworkManager on Manjaro should have auto detected the Local network connection, as soon as the cable was connected, or the WiFi came on line.

As far as you being required to have Windows is concerned they don’t know how to support Linux, as it’s not in the support script they read from (that’s the polite version).

@bogdancovaciu i followed your instructions. But its not working,
maybe i’m doing it wrong.
i restarted my pc, router and i restricted to device with MAC address ,
then it connects to a new “wired connection 2” which has “link negotiations” set to “ignored” and no "Restrict to device MAC Address.
which MAC address should I use? LAN IPV6 || WAN?
should i also restart modem?
@tracyanne ISP didn’t supply router, i bought and entered id&pass my self. My NetworkManger did detect a “wired connection”, but if I search in my browser it says "DNS/IP did not found "
But strangely “add/remove software” can access internet download apps.:disappointed:
(they also said my PC won’t last two months because I use Manjaro🤣)

your router also has to have modem functionality → modem + router as
one or 2 devices.

there you need to enter your ISP details

no mac restriction or things whatever

after that if you plugged things right you
should have internet

What kind of modem?

@bogdancovaciu A white sqare box they call “onu”. It is directly plugged in with the main broadband wire and router is plugged into it.
@ycom1 i did enter ISP details, and i can use wifi on phones or laptops. But i wanted to also use Internet on pc.
But it dosen’t work :sweat_smile:

Via the Green or Blue port i guess

The router WAN connector to the onu modem yellow LAN connector?
And your PC is connected to the LAN of the router, and you can access the router web interface admin and the PPPoE status shows connected, and the test from Tools of the router shows also successful ping to outside?

Yes
It shows that its connected.


But on browser it shows “ip address could not be found”.
Also it can download apps from repos,aur etc.

Do you have two LAN interfaces on your PC? If not, remove one from settings.
Share from terminal
inxi -Nazy

inxi -Nazy  :heavy_check_mark:
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = “”,
LC_ALL = (unset),
LC_ADDRESS = “bn_BD”,
LC_IDENTIFICATION = “bn_BD”,
LC_MEASUREMENT = “Default.UTF-8”,
LC_MONETARY = “Default.UTF-8”,
LC_NAME = “bn_BD”,
LC_NUMERIC = “Default.UTF-8”,
LC_PAPER = “bn_BD”,
LC_TELEPHONE = “bn_BD”,
LC_TIME = “Default.UTF-8”,
LANG = “Default.UTF-8”
are supported and installed on your system.
perl: warning: Falling back to the standard locale (“C”).
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Foxconn driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: e800 bus-ID: 02:00.0 chip-ID: 10ec:8168 class-ID: 0200

If i fill MAC address in “restricted to device”, it makes a new " wired connection 2" and connectes to it.

And now you have only one wired connection in Network Settings, right? Also make sure no Proxy in System settings

image

You can rename it to whatever you want, for example Realtek and delete the other one that is not connected.

Browser still showing “op address Could not be found”


Add Networks widget to your Panel or use the default System Tray and hide the entries you don’t what to see, but at least have it there … and let me know if after that your network is working.
What other browser you tested?

@bogdancovaciu Brave, firefox

What happens if you run from terminal
systemctl restart NetworkManager

What is showing the command
cat /etc/resolv.conf
and
ip addr

Did you add the system tray back to your panel? Is the network status showing connected and the correct IP?
Your issue seems to be the opposite of this one

@bogdancovaciu
Yes i did add the widget in the panel, correct ip
systemmctl restart NetworkManger
(Showing some (tick,correct) symbols)
   ~  sudo cat /etc/resolv.conf  1 ✘  7s

MADE-BY-RP-PPPOE

nameserver 8.8.8.8
   ~  ip addr  :heavy_check_mark:
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
valid_lft forever preferred_lft forever
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
2: enp2s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
link/ether d0:27:88:51:36:af brd ff:ff:ff:ff:ff:ff
inet 192.168.0.102/24 brd 192.168.0.255 scope global dynamic noprefixroute enp2s0
valid_lft 28708sec

You used initially the PPPoE connection from your linux box i guess, but if you want to use a custom DNS you better set that in the router, or use the one provided by your ISP.
Change /etc/resolv.conf to
nameserver 192.168.0.1

Restart the modem, the router and your PC just to make sure, but all should be fine.

(they also said my PC won’t last two months because I use Manjaro🤣)

Not to put too fine a point on it That was a bald faced lie.

@bogdancovaciu ihave edited it with nano text editor. Restarted pc, modem & router But still browser is showing "Google’s IP address could not be found":disappointed:
@tracyanne

Yeah man😂