Apps and system not connecting to internet but browsers do


I am having issues with my internet connection: applications (Thunderbird, RStudio, etc) cannot access internet but web browsers can. Also, I cannot update any package through terminal.
When I connect to other networks everything is ok: system and application access internet. My other pc (also Manjaro but KDE) does not have this issue on the same network.

Week or two ago, everything worked flawlessly.

I am using -MANJARO x86_64 20.2.1 Nibia GNOME 3.38.3 kernel: 5.9.16-1

I did:

  • router factory reset
  • disable IPv6
  • NetworkManager restart
  • firewall disabled

Do you have any recommendations?

Thank you

Hi @Grunf11, and welcome!

That, to me, sounds kind of like some kind of proxy somewhere.

Double chefk that and make sure you didn’t, knowingly or accidentally set a proxy somewhere. Maybe one for KDE only. Not dure.

Hope this helps.

There was no proxy but I managed to solve it by changing nameserver in etc/resolv.conf to google servers by adding these lines:


and also in etc/resolvconf.conf adding this line:


I still dont know why this issue randomly started few weeks ago but these lines in resolv.conf solved it.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.