Headphones have no application output, only system audio


I’m new to Manjaro and installed it a few days ago on my laptop (GIGABYTE G6 KF-H3DE854SD
Now I want to use my headphones but they don’t work on any applications, only on the system audio (test audio for example).
here are a few info that might be important (saw it on other problems):

pactl info                                                                                                                                              ✔ 
Server String: /run/user/1000/pulse/native
Library Protocol Version: 35
Server Protocol Version: 35
Is Local: yes
Client Index: 154
Tile Size: 65472
User Name: (my-username)
Host Name: (my-username)
Server Name: PulseAudio (on PipeWire 1.0.5)
Server Version: 15.0.0
Default Sample Specification: float32le 2ch 48000Hz
Default Channel Map: front-left,front-right
Default Sink: alsa_output.pci-0000_00_1f.3.analog-stereo.3
Default Source: alsa_input.pci-0000_00_1f.3.analog-stereo
Cookie: 3af7:0e83
wpctl status
PipeWire 'pipewire-0' [1.0.5,  (my-username)@ (my-username), cookie:989269635]
 └─ Clients:
        32. kwin_wayland                        [1.0.5, (my-username)@ (my-username), pid:832]
        33. WirePlumber                         [1.0.5,  (my-username)@ (my-username), pid:898]
        41. WirePlumber [export]                [1.0.5,  (my-username)@ (my-username), pid:898]
        42. xdg-desktop-portal                  [1.0.5,  (my-username)@ (my-username), pid:842]
        48. pipewire                            [1.0.5,  (my-username)@ (my-username), pid:1313]
        62. libcanberra                         [1.0.5,  (my-username)@ (my-username), pid:1005]
        63. plasmashell                         [1.0.5,  (my-username)@ (my-username), pid:1005]
        64. Plasma PA                           [1.0.5,  (my-username)@ (my-username), pid:1005]
        65. Firefox                             [1.0.5,  (my-username)@ (my-username), pid:1381]
        68. wpctl                               [1.0.5,  (my-username)@ (my-username), pid:3647]

 ├─ Devices:
 │      43. HDA NVidia                          [alsa]
 │      44. Built-in Audio                      [alsa]
 ├─ Sinks:
 │      52. Built-in Audio Analog Stereo        [vol: 1.00]
 ├─ Sources:
 │      49. Built-in Audio Analog Stereo        [vol: 1.00]
 ├─ Filters:
 └─ Streams:

pactl list short sinks                                                                                                                                  ✔ 
301     alsa_output.pci-0000_00_1f.3.analog-stereo.4    PipeWire        s32le 2ch 48000Hz       RUNNING

This one is the speaker, no headphones there
I also tried to fix it with different kernels.

Thanks for helping in advance.

Sometimes you might need to adjust that at the application level, depending on the application concerned; often by selecting a preferred output.

U mean at the bottom of the screen right-click on volume than on the application?
i can’t right-click on it if I have speaker as output, and if I change on the system on headphones as the output the application doesn’t show up.

Also edit application doesnt show any setting to change preferred output

the application sound output is sometimes set via the audio mixer output selection tab,

you can activate the mixer via the volume control icon … or via settings pulseaudio volume control (Desktop Environment dependent)

Only see at pulseaudio volume control:
System Sounds and a bar I can change.
Also FireFox but can only change the bar, Silence strikes out when I play sound on firefox, but cant hear anything

On Output device, I can change the port to Speakers or Headphones (unplugged)
But they are plugged in

On Configuration, I can activate HDA NVidia to unavailable HDMI X Outputs or Built-in Audio

What I want to mention my laptop has only 1 audio device, speakers and headphone don’t have separate audio devices.

No. I mean within the settings of any particular application. There is no example to give, as it depends on the application. As I said, sometimes outputs may need to also be configured on whatever application you use.

At a system level, settings will also vary from one DE to another.

In any case, a little housekeeping…

As a new user, please take some time to familiarise yourself with Forum requirements; in particular, the many ways to use the forum to your benefit. To that end, some or all these links will be invaluable.

Please read through them, as they will help you understand the types of information that you should provide (logs, system details, etc) in order to have others help effectively.

And last, but not least, the Stable Update Announcements, which you should check frequently for important update related information. Occasionally an issue might be directly related to a particular update; it’s always best to check those announcements.

I hope this helps. Cheers.

I managed to figure out the issue with the help of a friend.

The headphone jack detection is not working, so the headphones were always listed as unplugged.
After disabling jack detection with hdajackretask it now works.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.