Has anyone had success getting the Canon LBP6230 running?

I’ll be straight to the point:

  • I have a budget laser printer - Canon LBP6230
  • I ran pamac build cups-bjnp and then pamac build cnrdrvcups-sfp
  • I ran lpadmin -p "Canon_LBP6230" -v dnssd://Canon%20LBP6230dw._printer._tcp.local/ -E
  • This didn’t work, and I then found out that Canon has official drivers for my printer. They only work with Debian and Red Hat. I actually pulled out my Debian laptop and was begrudgingly willing to use that to print, but then I remembered that I need to use my Arch PC because I need to be connected to the same network switch as it is a cheap laser printer and one of the cost cutting measures was rudimentary networking.
  • This is actually not my first time trying to print to this printer, a few months ago I wasted a few hours trying to get this running under regular Arch and eventually gave up and booted into Windows 10. This is important because I managed to find the relevant files (the file extension of which I don’t remember, and I don’t remember where said files where so I can’t refind the file extension) within Canon’s drivers and import them into CUPS somehow, but I got the same result as I am now with drivers from the aur.
  • The result being, I print, the cups control panel shows the print job as having been completed, but nothing actually happened. I’m either getting no errors or do not know where to look for errors beyond the control panel.

If I REALLY have to I will set up a Windows 10 VM but I would really just like to be able to print from my Arch PC. What am I missing?

If anybody has or has had luck then feel free to reply but I personally have given up and am currently setting up a Windows 10 VM. I imagine a Windows 7 or XP VM might work if resources are a concern, however I’m frankly done trying to get this printer working with an OS the manufacturer seems to not care for.

I think this printer needs this kind of driver:

Canon CAPT - ArchWiki

I have an LBP2900
and have several posts here detailing the installation
and, more importantly, configuration
since other people with similar printers had problems getting theirs to work.
You’ll find them …

This matrix here is why I think that you (so far) where trying to make your printer work
using the wrong driver:

CUPS/Printer-specific problems - ArchWiki

which, of course, will not work :wink:

It is for a different Canon printer, but this user was able to install and the steps are outlined. I hope this may be of some help.

I downloaded the CAPT-SRC from the AUR but can’t get it to work, I tried with terminal and the website I read the whole cups documentation on the website, but I can’t get it to work it always doesn’t work it says its printing but it doesn’t print.

I plugged it in, and it just works IDK what I did so???

So I tried something, I grabed a ppd file from Canon’s official driver website and try it with CUPS but it doesn’t work

I downloaded a tar file and extracted it and I found Red Hat drvers and Debian Drivers and I also found a file with all the ppd files I grabbed the one with LBP 2900 with it and try it

I just realised someone changed the title, I also have that printer I also can’t get it to work

No one changed the title.
This is not your original thread - it’s someone elses with a similar problem.

im just tying so I can send 6 words

So I tried all the ppd files none of them work don’t bother with them

I don’t think this has been mentioned:

Make sure that the user is added to both the groups: lp and sys

 sudo gpasswd -a  your user name sys lp

So long and nby got it working, is it because the drivers are outdated or canon just decide to f with us?

I did, and I’m not the only one. It works and continues to work.
And I linked to the procedure in the Arch wiki as well as described it in the original thread.

None of the above.
I’m willing to guide you through the procedure - including first cleaning up the mess that your previous attempts may have left.

In a separate thread.

From your posts it appears to me that you simply did not follow the described procedure. :man_shrugging:
Without going through all the previous I recall that you where the guy who’s computer delivers electrical shocks.
That would indicate to me that this computer might not be functioning reliably and thus foil your efforts … :wink:

This thread here was about a different printer model anyway - although it should work just the same.

Maybe my post some minutes ago will help you. I, too, was preparing for a long installation procedure as mentiones in the ArchWiki, but it wasnt necessary at all! Luckily!

It won’t help here
because this (your) printer does not need the Canon CAPT driver
which apparently is difficult to get working
… it’s really not - but it’s a different procedure than to just install a ppd and point Cups to it …