How to use the LBP 2900 on manjaro linux XFCE version?

I have two printers one is a newer Canon Pixma printer which works flawlessly on manjaro linux its plug and play, but for my old printer the Canon LBP2900 it totally doesn’t work. I tried installing the drivers but there all .deb files, I tried searching the drivers automatically and manually and updating my Os but NOTHING!! Can someone help me cause this is the only printer I can use for now.

1 Like

You have drivers in AUR, install them:

I didnt work

It does.
I know because I have that printer.

It’s not enough to just install the driver.
Setup is a little different - you can’t use any graphical interface.
You have to configure and start the ccpd service as well as Cups.
It’s a little messy :wink:

but works flawlessly.

IIRC this topic came up here before - so there should be some info on this here in the forum as well.

1 Like

I have no idea what is cups and this can u tell me step by step. I tried opening cups butit just brings me to a website.

I tried CUPS for about an hour and I still cant get it too work and its overly complicated, I JUST WANT TO PRINT STUFF MAN!!! I tried searrching other forums but didnt find anything. Like what is a pool or class or job what is ccp what is ipp thingy do I need to add the file? I added the printer but it doesnt print and just keep making the sound like brrrrrr so I deleted the printer, Idk what to do?

I linked you to the Arch Wiki describing the setup.
It contains all the info.

I know it is next to impossible to follow and implement for someone who doesn’t know the first thing about doing things per command line.
It can be overwhelming.
Lack of experience will have you perceive what you read there as pure gibberish … :wink:

But that’s just how it is.

I may be able to assist you during the weekend.
But you need to do your part - try to follow that guide and document and report what you did and where and at what point you get stuck.

It could take some time beyond the weekend - gradually explaining and guiding you through the steps …

If you are not willing to invest that time and mental effort …
just get rid of that printer and buy a different one that is easier to set up, supported by standard cups drivers …

I really mean that.

How much is that printer worth?
(I got mine ~5 years ago - and it was already old then - it cost me ~ € 30,- )

How much does another one cost?

Is it worth (to you) to save 20 or 40 bucks (or Euros …) and keep struggling for many hours … :wink:


Thank you for wriing back,
I will keep trying to connect and read the documention, Hope my mental health will be fine after this.
Getting rid of the printer is not an option for me im litterally 12 years old with a crappy laptop trying to DO ONLINE CLASS BUT THE LAPTOP IS SO SLOW so I just switched to linux as Im willing to get my feet wet, btw the printer isnt mine its my dad’s and hes a cheap guy HAHAHA!, so he will NEVEr CHANGE IT UNTIL IT JUSt STOP WORKING which its close cuz I thnk the printer is older than me!!!
Tbh im actually enjoy using linux and touching stuff I shouldnt touch, sometimes I will break my pc will break cuz i screwed smthin up(like changing a whole desktop environment but dont know how to revert it back) but I use time shift so its fine.

Cheers to you too
Realised I wrote this too long : )

I realised tht the printer isnt older than me

I did all the steps and the printer just prints blank papers and doesnt print what I want, I think I still dont know how.

My bash history (saving the commands I typed, so I can review them) was set too low - so I don’t have the exact commands that I did to configure the printer anymore.

But going by memory
and by the description in the Arch Wiki that I linked you to

which also contains a link to an Ubuntu page on how to set it up there

CanonCaptDrv190 - Community Help Wiki

what I did was this:

  • install that Canon CAPT driver from AUR

  • ensure Cups is running - and is enabled

(so it will be started after reboot)

systemctl status cups.service
sudo systemctl start cups.service
sudo systemctl enable cups.service

(I think it’s enabled by default and should be already running - but make sure
don’t cut and paste all three lines at once
run each command separately - so you better see what’s happening)

  • add the CAPT printer to Cups:

sudo lpadmin -p LBP2900 -m CNCUPSLBP2900CAPTK.ppd -v ccp://localhost:59687 -E

(this step above is what doesn’t work through the graphical setup tools - at least not for me
and the Wiki mentions it as well
and you need the command line later anyway …)

  • then, per the description, register the CAPT driver itself via ccpdadmin

sudo ccpdadmin -p LBP2900 -o /dev/usb/lp0

  • then, start and enable the CAPT daemon with:

sudo systemctl ccpd.service start
sudo systemctl ccpd.service enable

(so it will also be started after reboot …)

I hope that helps you.

there was a thread and discussion on it previously which may also help
should contain the same info and perhaps even more
it’s in german - but the english version of one of my posts is just below
The rest you’ll have to run through google translate … or ask :wink:

the commands are highlighted and should explain a lot of it

Just out of curiosity:
what are the specs of your “crappy laptop”, my young friend?

I admire your persistence!

It took me a while and a few tries to gather the concept behind these commands
(not that that is an indication that it is difficult - but it was for me)
and to get it right and working.

1 Like

Thanks for the reply,
I will maybe try out the solutions tommorow cause I have alot of homework from school. My school just reopened and now Im having exam next week so OOF. Also thank you for trying so hard to help me!!

Tbh my dads laptop(Acer Aspire 5 but idk from what year) its not that bad its just old and really out of shape. The webcam is broken, chassis is warp and damaged badly, mic is broken, battery is literally zero life(when u plug out the charger the laptop just shuts off), AND WORSE OF ALL It SHOCKS U ALOT even the tying can get u shocked I need to use gloves for my laptop I mean its not dangerous electricity but it FREAKIN HURTS!!! also one of the speakers is totally dead, and only 2 USB 2.0 ports this is actually kinda annoying.

Cpu= I5 3rd gen mobile dont really know the model of the cpu cuz idk how to check on linux lol
Gpu=Intergrated graphics 15 fps on Roblox when I use Windows 7 (u cant use linux to play roblox but i dont really play it anymore so idc)
Ram= 4gb (ddr3) sodim
Fan noise= very noisy when watching yt videos or twitch
Keyboard= totaly trash cuz its kinda broken

Things I like about this laptop=
1 its better than my brothers laptop
2 it still delivers what I mostly want ( able to enjoy and relax just the fan tho very laud)
3 its ok

That is totally sufficient to run any OS, certainly enough to run Manjaro.
My specs are the same. It’s a Sony Vajo SVE14

But if it is giving you electrical shocks when you touch it
I advise not to touch or use it.
Using gloves to circumvent that is … just plain stupid. Really!
and, of course, dangerous as well

Have someone open it, to repair it and to clean the fan.
If you have to pay for that work - including replacing the keyboard while you are at it,
it’s probably not worth it.
Get a better used one.

Not my laptop so cant do anything about it. My dad says the shock arent that bad. In my opinion its just very painful I dont think its dangerous.

Found the actual specs in neofetch
CPU: Intel i5-2467M (4) @ 2.300GHz
GPU: Intel 2nd Generation Core Processor Family
apparently its 2nd gen i thought its 3rd gen

Your opinion is likely not based upon extensive experience, given your age.
Oh well.
Let’s hope that you won’t find out the hard way that it really is, even though you think it isn’t.

I reinstalled the printer driver and I typed all the liines one by one and Im gonna reboot now, I should be able to print after rebooting right?

After rebooting, I opened note pad and tried to print some alphabets to test the printer but it didn’t even print the paper. The printer is just idle and when I check on CUPS it says processing and after some time it still havent print so I think it didn’t work.

Some superficial troubleshooting.
please post the output of every following command:

ls -hl /etc/cups/ppd

sudo cat /etc/cups/printers.conf

cat /etc/ccpd.conf

sudo ls -hl /etc/systemd/system/

sudo ls -hl /etc/systemd/system/

Is cups running?

systemctl status cups

systemctl status cups.socket

Is ccpd running?

systemctl status ccpd

Is something in the print queue?

Look at the logs for clues.

Hey, I am having the same issue. I followed this all the way.

total 32K
-rw-r----- 1 root cups 13K Apr 30 17:48 LBP2900.ppd
-rw-r----- 1 root cups 13K Apr 30 17:40 LBP2900.ppd.O
# Printer configuration file for CUPS v2.3.3op2
# Written by cupsd
NextPrinterId 8
<DefaultPrinter LBP2900>
PrinterId 7
UUID urn:uuid:f2543012-57e0-3331-439c-c69e4015019f
Info Canon LBP2900
Location xqx-Manjaro
MakeModel Canon LBP2900 CAPT ver.1.5
DeviceURI ccp://localhost:59687
State Idle
StateTime 1619783924
ConfigTime 1619785100
Type 8392836
Accepting Yes
Shared Yes
JobSheets none none
QuotaPeriod 0
PageLimit 0
KLimit 0
OpPolicy default
ErrorPolicy stop-printer
# Canon Printer Daemon for CUPS Configuration Data

# CUPS configuration file path.
#  Default  /etc/cups/

CUPS_ConfigPath   /etc/cups/

# Log directory path.
#  LogDirectoryPath /var/log/CCPD/


# Printer entries.
#  Mapping each "Printer Name" to each "Printer Device Port".
#  The "Printer Name" has to be identical to the CUPS printer queue name.
#  For example, if you prepare a printer named "LBP3200" as a CUPS printer
#  queue name, and the printer is connected to the USB port "/dev/usb/lp0",
#  you can use the following three lines example just by removing the
#  comment symbol "#" of each line.
#<Printer  LBP3200>
#DevicePath  /dev/usb/lp0

<Printer LBP2900>
DevicePath /dev/usb/lp0

# Status monitoring socket port.
#  Default 59787
UI_Port  59787
PDATA_Port  59687
total 0
lrwxrwxrwx 1 root root 36 Apr 30 16:31 ccpd.service -> /usr/lib/systemd/system/ccpd.service
lrwxrwxrwx 1 root root 36 Apr 30 15:27 cups.service -> /usr/lib/systemd/system/cups.service
total 0
lrwxrwxrwx 1 root root 35 Apr 30 15:27 cups.socket -> /usr/lib/systemd/system/cups.socket
lrwxrwxrwx 1 root root 36 Apr 21 22:01 snapd.socket -> /usr/lib/systemd/system/snapd.socket
● cups.service - CUPS Scheduler
     Loaded: loaded (/usr/lib/systemd/system/cups.service; enabled; vendor preset: disabled)
     Active: active (running) since Fri 2021-04-30 17:33:18 IST; 22min ago
TriggeredBy: ● cups.socket
             ● cups.path
       Docs: man:cupsd(8)
   Main PID: 588 (cupsd)
     Status: "Scheduler is running..."
      Tasks: 3 (limit: 9384)
     Memory: 65.2M
     CGroup: /system.slice/cups.service
             ├─  588 /usr/bin/cupsd -l
             ├─21717 /usr/lib/cups/notifier/dbus dbus://
             └─21718 /usr/lib/cups/notifier/dbus dbus://

Apr 30 17:33:17 xqx-Manjaro systemd[1]: Starting CUPS Scheduler...
Apr 30 17:33:18 xqx-Manjaro systemd[1]: Started CUPS Scheduler.
● cups.socket - CUPS Scheduler
     Loaded: loaded (/usr/lib/systemd/system/cups.socket; enabled; vendor preset: disabled)
     Active: active (running) since Fri 2021-04-30 17:33:17 IST; 22min ago
   Triggers: ● cups.service
     Listen: /run/cups/cups.sock (Stream)
      Tasks: 0 (limit: 9384)
     Memory: 0B
     CGroup: /system.slice/cups.socket

Apr 30 17:33:17 xqx-Manjaro systemd[1]: Listening on CUPS Scheduler.
● ccpd.service - Canon CAPT daemon
     Loaded: loaded (/usr/lib/systemd/system/ccpd.service; enabled; vendor preset: disabled)
     Active: active (running) since Fri 2021-04-30 17:37:49 IST; 17min ago
   Main PID: 7358 (ccpd)
      Tasks: 3 (limit: 9384)
     Memory: 8.2M
     CGroup: /system.slice/ccpd.service
             ├─ 7358 /usr/bin/ccpd
             ├─ 7360 /usr/bin/ccpd
             └─26206 captmon2 --data-write-fd=3 --data-read-fd=10 --cmd-write-fd=11 --cmd-read-fd=14 --output-fd=-1 --input-fd=-1

Apr 30 17:37:49 xqx-Manjaro systemd[1]: Starting Canon CAPT daemon...
Apr 30 17:37:49 xqx-Manjaro systemd[1]: Started Canon CAPT daemon.