GRUB Disappears as soon as Boot USB is removed


I have been using Manjaro for a while now on my laptop on a NVME (/dev/nvme0n1) drive.
Today I decided to install Windows on my separate SSD (/dev/sda). Doing this, it completely erased my Manjaro’s boot loader. So, I booted up on a Live USB (/dev/sdb), however, following the Forum posting on Restoring the GRUB Bootloader, I was then able to boot my Manjaro again. I turned off the laptop, unplugged the USB and then I could no longer boot back into Manjaro unless I did the whole process again and KEPT the USB in.

Is there any reason to why this could be happening?

Something to try. Get back into manjaro on your system. Once there open a terminal & enter

sudo update-grub

Reboot & see how you go.

Doesn’t show up in Boot Options still

It sounds like you installed GRUB to the USB drive.

When you followed the above guide, you made sure to do the manjaro-chroot command on your Manajro’s root ( / ) partition before continuing? It might be /dev/nvme0n1p2 or something to that effect.

1 Like

Yes, and when I did manjaro-chroot -a and then followed up with lsblk, the correct drives (nvme0n1) were mounted.
/dev/nvme0n1p1 /boot/efi
/dev/nvme0n1p5 /

I also removed the windows drive, then used the usb to boot into my Manjaro install. I ran the commands to update the GRUB (so without chroot), removed the USB, then restarted. The Manjaro boot is still missing.

When you get into your normal system, via the “USB plugged in trick”, what device is mounted as /boot/efi? (Before you issue any grub commands.)

Can you review the commands in here? EDIT: (GRUB commands, sorry for not being clear on that.)

What I did:
Booted into my normal system via the USB
nvme0n1p1 /boot/efi
nvme0n1p5 /
Ran the commands:
grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --recheck
grub-mkconfig -o /boot/grub/grub.cfg
This resulted in zero errors. I also ran a update-grub just in case.

Can you paste the output of:
sudo parted /dev/nvme0n1 print

Model: RPFTJ256PDD2MWX (nvme)
Disk /dev/nvme0n1: 256GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags:

Number Start End Size File system Name Flags
1 1049kB 538MB 537MB fat32 boot, esp
5 5649MB 255GB 249GB ext4

Now I wonder if Windows changed something about your motherboard’s boot settings. Are you able to get into your motherboard’s BIOS and see if there is something that has been toggled, such as “Secure Boot”, “Boot Devices”, etc? Is there a “Boot Override” option?

For what it’s worth, Manjaro correctly mounts /dev/nvme0n1p1 as /boot/efi, it’s flagged as “boot” and “esp”, and I’m sure if you list the contents of /boot/efi/EFI, you will see Manjaro’s EFI boot files.

Strange that you can only boot into your system if you have the USB stick plugged in…

Anyone else have ideas about this?

Secure Boot is disabled. Only other thing would be OS Optimized Defaults which is Enabled. (It is a pretty bad BIOS)

Disable it and try again.

Tried that after I mentioned it, still nothing.

Out of curiosity, what happens it you boot into your Manjaro system (USB plugged in trick), and then after it boots up, unplug the USB and try to list the contents of
ls -1 /boot/efi/EFI

EDIT: To be clear, when it “boots into Manjaro” you’re saying it’s booting into your system, not the live session?

Got it! I tried out these commands from Aragorn:

Thank you for sticking with me!


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.