Boot menu does not show Manjaro partition

I am dual booting Windows and Manjaro. Manjaro has worked fine for the past few months. However, upon restarting today, the boot menu stopped showing options for Manjaro and only for Windows. I was running Linux 5.8. I am currently booting System Rescue from a live USB. I am new to Linux. Any help would be much appreciated.

Welcome to the forum! :slight_smile:

Boot up from the Manjaro USB drive (or optical medium) in live mode. When up and running, open up a terminal window and type… :arrow_down:

sudo su-

Enter the password, and then enter the following command… :arrow_down:

manjaro-chroot -a

If you have only one GNU/Linux installation on your system, press 1. Then enter the following commands ─ it includes checking for updates… :arrow_down:

pacman-mirrors -f 5 && pacman -Syyu
grub-install --recheck --modules="part_gpt part_msdos"
sync && exit  

It should now be safe to reboot.

Thank you for your response. pacman -Syyu returned several error: failed retrieving file ... from ... before error: failed to synchronize all databases. I ran the remaining commands anyway and rebooted, which seemed to break the bootloader altogether, as it kept redirecting me to grub options without showing me the boot menu. I decided to make a fresh install of Manjaro on some unallocated space I had, so my next question is whether there is any way to transfer files from my old Manjaro partition to my new one.

Yes, there is. Just mount the partition with your files from the first installation, and copy (or move) them over to your new $HOME. :wink:

I have done that. Thank you very much.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.