GPG: keyserver receive failed: no name

Hi folks, I’ve tried installing the stack-static package from the AUR through yay and I’m getting this error:

gpg: keyserver receive failed: No name

I haven’t had this before, and now if I do gpg --refresh-keys I get the same error. Can anyone give me a hand?

As far as I can tell from reading the gpg man pages and google it’s trying to get the package author’s PGP key from the servers and failing for some reason. The comments on the AUR suggest using a different keyserver but that’s already the one gpg is using on my machine by default.

Hi, that should help:

Thanks for the quick reply. Would you mind explaining why that worked? Do the different servers not all hold the same keys? I’d assumed that they were mirrors

By default there is a /etc/pacman.d/gnupg/gpg.conf for pacman (offical packages), but if you install an AUR (unoffcial user packages) package through pamac it uses the local /home/$USER/.gnupg/gpg.conf. gpg also don’t create this file by itself.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.