General error problem importing keys

Trying to install keepassx but I get the error below. What am I supposed to do? Thanks

gpg: keyserver receive failed: General error
problem importing keys

There should be pub key that has to be imported. In general the keyserver could fail.

Here a different server: SKS Keyservers: Overview of the pools

you could do:

gpg --keyserver --recv-keys <key>

or permanent:

echo "keyserver hkp://" > /home/$USER/.gnupg/gpg.conf

an then:

gpg --recv-keys <key>

Hey Thanks for fast reply)!

1 Like

Worked like a Charm!! Thanks

This worked for me, but I don’t understand why. How can I find out the default keyserver used by gpg? I suspect the domain/IP is blocked in my country.

Try the command:

locate gpg.conf

and you will see that there is no file except in /etc/pacman.d/gnupg/gpg.conf by default. While pacman uses his own gpg.conf, pamac don’t use it when installing AUR packages but the gpg.conf in /home/$USER/.gnupg. Official repo and AUR repo are used by the same application “pamac”, but these are 2 different sources. AUR packages are made by users and not official supported, so it is in that manner obvious that the AUR repo has a different gpg.conf as the official one has. And by default there is just no gpg.conf in the home folder.

1 Like

Thanks for this. :smiley:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.