Gnome does not take input after update gnome-shell-extension-dash-to-dock

I updated gnome-shell-extension-dash-to-dock and after the update, the laptop stopped loading the desktop and programs the first time (it loads only after the second login after closing the lid of the laptop or when the session ends after a long period of inactivity), but after loading the desktop I can not click on anything except the icons on the dash panel.
Rebuilding packages did not help.

8 Likes

I can confirm that the newest gnome-shell-extension-dash-to-dock-71+33+g53114b4-1 upgrade package borked Gnome Shell. No input, top panel unable to function, programs setup to load on start up unable to load into the desktop. Unlike your case, closing the lid of the laptop did not help me. Everything freezes and unresponsive.

As of right now I have used Timeshift to revert the upgrade. Please give me an update once it is stable to upgrade. Thank you.

3 Likes

Idon’t have installed Timeshift (noobie here…). Is there any alternative?

1 Like

Same with me. Luckily I could restore with Timeshift to snapshot just before update.

I have that problem too. Quick fix:
pamac install gnome-shell-extension-dash-to-dock-git

6 Likes

Same issue for me under wayland. Can’t close, resize or move windows. I checked journalctl logs and I see an exception caused by dash to dock.

1 Like

I have same issue , is there anybody resolve this ?

1 Like

This worked, except I don’t see my dock when I hover my mouse to the bottom of the screen, also I don’t have dash dock settings. Any solutions to this? Working in latest Gnome.
Kind of an advanced noob user

I have Gnome and Deepin (manjaro both; I did update 2 hours ago for both) and Deepin doesn’t even boot into desktop, stays in shell. Gnome boots into desktop but no input so unusable standard desktop. But before logging in, if I select Gnome classic or Gnome on Xorg everything works.

2 Likes

I have resolved by installing manually AUR package.

AUR Package Name: gnome-shell-extension-dash-to-dock

1 - git clone {AUR-Package-URL}
2 - cd gnome-shell-extension-dash-to-dock
3 - makepkg -si

it is working now with 71.1 version on my computer

1 Like

I can also confirm that the latest version of dash to dock (gnome-shell-extension-dash-to-dock-71 + 33 + g53114b4-1) does not work. Blocks Gnome Desktop Wayland startup. It starts on the Xorg Gnome Desktop, but it cannot be controlled.

I solved the problem by rolling back gnome-shell-extension-dash-to-dock to a previous version using these instructions

3 Likes

Thanks zoOM, I turned off that extension and I’ll wait for the fix. I’m using the stable version there is ALA disabled and I don’t want to allow it.

Hi all,

After fresh installation of Manjaro gnome, everything works fine. But once updating the packages (pacman -Syu), gnome does not take keyboard and mouse input. There is no icon on dash-to-dock. Is there anyone having the same problem?

5 Likes

I found the reason and fixed the problem. The reason is that I did not rebuild python packages as described in the announcement.

I just changed the version to 3.10. Hope this helps.

pacman -Qoq /usr/lib/python3.10
yay -S $(pacman -Qoq /usr/lib/python3.10) --answerclean All

==> Update: I think this is not a solution. This does not work in another laptop.

@zo0M Is your problem solved.
I am also facing the same issue and changing the version did not work for me also.

Same problem and solution proposed by multics69 doesn’t work for me.
I tried to disable the extension on cli mode but nothing changed

I fixed the problem using the idea of @Zo0m on thread Gnome does not take input after update gnome-shell-extension-dash-to-dock - #8 by kaya.md
i just downgraded the package gnome-shell-extension-dash-to-dock :slight_smile:

1 Like

I can neither reproduce the issue on a Xorg nor a Wayland session, not sure what caused the problems.

I’m pushing gnome-shell-extension-dash-to-dock 71+33+g53114b4-2 now, see if that resolves the issue.

4 Likes