Gnome 40.0.0 doesn't work very well

Dear all,

Today i did an update of my system. Also Gnome 40.0.0 came with it.
The problem of the new Gnome is that if I press the super-key to switch throgh my workspaces or to select an window, I can’t do anything.
I cannot select an open window and i cannot select a workspace which are not shown.

How can I downgrade to the old gnome?
If it is not possible to downgrade, how can I get work Gnome 40 correctly?
Any Help?


Regarding switching workspaces via keyboard: I had the same symptom that super+<page up/down> to switch workspaces no longer worked as before. I assume my custom keyboard shortcuts got partiallly reset by Gnome 40. Looking at Gnome Settings > Keyboard Shortcuts showed that new default shortcuts Super+Alt+Up/Down were set to switch workspaces. You need to redefine your custom shortcuts again.

1 Like

I am sure it is not a shortcut problem.
After pressing my super-key i get this desktop shown in the picture. I cannot switch to the opened windows. Nothing happens when I click on a window.
The same for the workspaces plus there are no workspaces shown on the right side like before.
It is not very easy to describe and show what i mean, but I am very thankful for any help.

Best Greeds

It seems not all “layouts” work well. I switched to “Manjaro” and the problems are gone.

maz named it ‘layouts’ but it should be theme, but he’s right.

@Hustn restart Gnome with ALT-F2-r and use the tweaktool to choose another theme.
Don’t use Adwaita Compact Dark but choose one of the Matcha themes ,they work well for me.

Adwaita Compact Dark gave me the same trouble you have.

Hy guys,

Thank you a lot for your help.
@Spike1 switching to one of a match theme was not the solution, I had already one in use.

After playing a little bit around I found a very simple und stupit solution:
I just switched through all Layouts of the Layout Manager. Suddenly it works!

At all another Layout it works so I thought it’s strange why work another layout but not mine? After I tried the first alternative Layout the Super-key worked without any problems. So I switched back to mine Layout, it sucked.
So I was searching a Layout that could work for my workflow. After I tried all, including pressing the super-key, i switched back to my Layout with the problem to try just for fun. But it works now! XD

I don’t know why but I think it was neccessary for gnome to reload some funktions or somthing like that??

One more thank you guys!

Hello again,

so after a restart, gnome sucks again with the same problem. Switching through the layouts is just a temporary solution.

Any other ideas?

Best Greeds

same problem.

Same solution is working here : From Layouts swicther application, i’ve change to all layouts and going back to mine (Manjaro) and it works now…
thank you @Hustn for this “stupid solution” :slight_smile:

Gnome Shell 40 is not released to our stable branch yet. There is a huge workflow change and it mostly will break extensions you might use. What we pushed however are Gnome 40 Apps. You may test the latest Gnome 40 with this build


@philm thanks for your hint. but I am no interested to install a “unstable” version. Maybe it works, maybe it goes worse…
One question about the name of the files of the latest Gnome 40 Version:
Does LINUX510 means that a 5.10 Kernel is requiered?
I use a 5.4 kernel. Could be that the reason why it doesn’t work as it should?

BTW: I switched to the Unity-Layout in the meanwhile. This works even after a restart of the whole system.

Does it even work after a restart?

The ISO on that page is an actual ISO to install Manjaro.

the pkgs.txt file is just there to tell you what packages are in there.

It means it ships 5.10. You’re still free to use another supported kernel.

1 Like

I’ve had the super key/window freeze issues as well. Also strange intermittent graphics results from opening the app tray from the side Manjaro theme menu. When super freeze occurs some things can be closed some are unresponsive.Happens on both my Manjaro gnome updated laptops, one 10 years old and one relatively new. Initially thought the older one was at end of life (maybe coincidence). Have swapped to unity theme on newer laptop - will see how it goes. BTW installed Debian stable non-free on the older laptop, super key issue did not seem to be a problem - but hated it and reinstalled Manjaro Gnome.

Please keep updating on Unity interim solution - or anything else. Will also update any news.

After some days using unity I had had no problems with the super-key-freeze.

I’ve got the same trouble I thought I did something wrong. My topbar changed color from black to grey and the date and time moved to the left side, The Super key doesn’t work even with the shorcut Super+A buy it’s weird because it works with Super+arrows (up, down, left, right), Super+Tab, Super+D, Super+E.

As mentioned before, I tried changing layouts but it didn’t work.

No, you’re right, i’ve meet the problem again yesterday on two computers :frowning:

I got some updates again. No changes…

Same here… After updates, the problem is the same.
But, i don’t know how to reproduce, it arrive sometimes but i don’t know how…
Here is a screenshot when the system is locked…

1 Like