Activities in Gnome Shell broken with latest stable?


For now I have disabled Activities with an extension.

But when using activities it shows the windows lined up alright, but noting happen when I want to select one of the windows. Anyone experienced the same thing as me?
I have search the forum for similar problem but it might only be me that is affected.



“I have search the forum for similar problem but it might only be me that is affected.”

I have exactly the same bug. I searched the internet and forum and you were the only one with the same problem. For now, I also disabled activities.


I do not experience this behavior on stable, using the mouse or super to activate activities. Application windows gain focus when selecting with the mouse, or keyboard using + Enter

I do have a somewhat tweaked environment and don’t use any menu style extensions. For reference my active running extensions and a easy way to list / view then:

$ gsettings get enabled-extensions | tr "," "\n" |tr -d "^ ' [ ] " | sort

To me the issues look like a extension issue that you both experience, comparing the active extensions and some testing might reveal a common source of this behavior.

Got the same issue with my both machines. I have used log out to escape…

Welcome to the forum :wave:

Now there are 3 people with the same symptoms (I’m not one of them), still no solution presents itself. What could the mysterious common problem be?

Is it the same problem as here ? Gnome 40.0.0 doesn't work very well - #20 by cyprien
Which extension you have used to disable activities ?

Same problem.

You can use “Hide Activities Button” extension. You’ll find it on gnome extensions site.

Ok, thanks, i’ve also install “No Topleft Hot Corner” extension…
Hope it could resolve my problem !

Edit : It just arrive me the same problem with this two extensions installed… But i don’t know how to reproduce it… It seems to arrive randomly.

1 Like

Confirm the issue. I am on Intel UHD 630 graphics if it does matter. I tried other kernels, switched from Wayland to X session, but problem remains. The only workaround is to log out.


same problem. even sometimes i dont need to click on 'Show application button" it just freezes if i have opened more than one app.

1 Like

Hi all in this thread :wave: , this post in the stable update thread points to a possible solution.

1 Like

I think this is happening to me. The task switcher (Activities or whatev) usually works for me but a few mins ago, I pressed super or clicked (I forget which) and the thing would now allow me to return to the desktop. I had to logout and back in. This is a fresh install w/updates.

is there a log for that feature?

I switched the layout to gnome and everything is fine now. Can someone verify?

The problem is that i can’t reproduce the bug…
I think it arrive randomly, but, if someone can repoduce it as he wants, it could be useful to correct it.

Same thing happening here. Apparently it happens kind of randomly, and it can be by using the hot corner, or the super button. The only way to get out of it is by logging off.

I’ve read several times to limit the gnome extensions to the ones available in pamac. These are tested by manjaro team members, and one can manage it with Extensions gnome app. Give a try to remove all web-installed ones ? Plus we are in the process to move to gnome 40, extensions devs will have to check if it is compatible with.

1 Like

Hey guys,
I have the same problem as well, I don’t know why but GNOME’s Activity menu just breaks on my Manjaro stable release install.

Does the solution @hb01 posted work for you?

If this is a fresh stable install I’d post it in the release thread with info about the running extentions, your inxi and some logging

i reinstalled the manjaro with a new iso downloaded from the manjaro website. “A clean install” worked well. After that i played around With the gnome extensions a bit mostly the dash to dock and issue reappeared.
The i switched to the Gnome layout and the issue is resolved. I also noticed that the extensions enabled were dynamically controlled by the layout switcher.
I suspect this might be an issue with some unsupported extension feature which is not used by the gnome layout, It may not be the issue with the Gnome itself