GCC12 preventing update

Hi, when trying to upgrade, I get the following errors:
error: failed to commit transaction (conflicting files)
gcc13: /usr/lib/gcc/x86_64-pc-linux-gnu/lib/libgcc_s.so exists in filesystem (owned by gcc12)
gcc13: /usr/lib/gcc/x86_64-pc-linux-gnu/lib/libgcc_s.so.1 exists in filesystem (owned by gcc12)
I saw a similar post here (Gcc12 - Problem updating manjaro libgcc_s.so exists), but I cannot remove gcc.

  • removing gcc12 breaks dependency ‘gcc12’ required by cuda

Could you please let me know how to find / remove the conflicting packages ?
Alternatively, how can I find the packages installed from AUR ?
Thanks !

inxi -zv8
Kernel: 6.6.19-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
Desktop: KDE Plasma v: 5.27.11 tk: Qt v: 5.15.12 info: frameworks
v: 5.115.0 wm: kwin_x11 vt: 2 dm: SDDM Distro: Manjaro base: Arch Linux
Info: model: 12th Gen Intel Core i5-12400F
Device-1: NVIDIA TU106 [GeForce RTX 2060 12GB] driver: nvidia v: 550.54.14

To locate packages installed using custom scripts

pacman -Qm

I have a lot ! I have not installed all by myself.
Do I need to remove all of them ??

baloo5 5.115.0-1
clang15 15.0.7-2
compiler-rt15 15.0.7-1
dbus-python 1.3.2-2
electron18 18.3.15-4
electron19 19.1.9-5
gcc12 12.3.0-3
gcc12-libs 12.3.0-3
khotkeys 5.27.11-1
khtml 5.115.0-1
kjs 5.115.0-1
kpeoplevcard 0.1-2
kquickcharts5 5.115.0-1
krunner5 5.115.0-1
ksysguard 5.22.0-2
kuserfeedback5 1.3.0-4
libsidplay 1.36.59-10
linux65 6.5.13-7
linux65-virtualbox-host-modules 7.0.12-20
llvm15-libs 15.0.7-1
manjaro-documentation-en 20181009-1
manjaro-firmware 20160419-1
manjaro-hotfixes 2024.1-2
manjaro-settings-manager-kcm 0.5.7-21
noto-fonts-compat 20151217-1
plasma-simplemenu 1.0.12-1
pyside2 5.15.12-1
python-manjaro-sdk 1:0.1.1-1
python-pep517 0.13.0-1
python-shiboken2 5.15.12-1
spectre-meltdown-checker 0.46+23+g0f2edb1-1
srm 1.2.15-2
systemd-fsck-silent 239-1
systemd-kcm 1.2.1-8
web-installer-url-handler 2.3-1

To solve your issue with updating - yes

The manjaro related packages is obsolete and has been removed from repo - you don’t need any of them.

If there is something you really must have - make a note and rebuild them after a succesful sync.

To remove them

sudo pacman -R $(pacman -Qqm)

Then run a full system sync

sudo pacman -Syu

Please note that building custom scripts using AUR implies using as a minimum Manjaro testing branch.

I still have an issue
if I try to remove gcc12, I get
could not satisfy dependencies:

  • removing gcc12 breaks dependency ‘gcc12’ required by cuda
    but cuda is not in the list above
    how can I settle these dependencies issues ?

Add cuda to the command

sudo pacman -R $(pacman -Qqm) cuda

That is an old and unsupported kernel - you should switch to a newer/LTS one.

I endeed up removing a lot of packages beside cuda
sync seemed ok
but, I got a black screen

Login page: oK
Manjaro loading page appears -stays around 2s
Black screen - stays 5 seconds
Manjaro splash screen - stays around 20s
Black screen

I can access TTY and Terminal
I install systemsettings that desappeared and to try to switch to another theme (BreathDark) - does not change anything
I tried X11 / Wayland - no change
I tried to update again: nothing to do

I am stucked at this point.
Could you please let me know what to do ?

As your sync is very likely to include plasma 6 and plymouth there is some adjustments to watch out for.

I don’t know what is specifically needed for your system but the following is likely helpful

Especially check the 2024-05-13 section on the KDE Plasma update

Hi, I tried different things and I am stuck
I upgraded to 6.69, in tty
Kernel: 6.9.2-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 14.1.1
Device-1: NVIDIA TU106 [GeForce RTX 2060 12GB] driver: nvidia v: 550.78

I do not have plymouth installed
pamac list | grep plymouth → nothing

I set the parameters as explained in different sections:

grub, MODULES have been amended and updated
GRUB_CMDLINE_LINUX_DEFAULT=“quiet udev.log_priority=3”

MODULES=(nvidia nvidia_modeset nvidia_uvm nvidia_drm)

HOOK was already ok
HOOKS=(base udev autodetect modconf kms block keyboard keymap consolefont filesystems fsck)

I wipe using the script

I follow the System settings advises, except for:

  • backup, I do not mine my settings / widgets
  • Workspace: I do not have any workspace menu in systemsettings

No improvement !
only make wayland worst: blackscreen, I cannot even access terminal. Only TTY worked

Do you have any idea of what I could do more ?
thanks !

When you are using Nvidia please see the suggestions for that scenario

Nvidia and Wayland are known to require configuration per system - I cannot provide the insight - I do not use Nvidia - I have only very secondary knowledge from years ago - before I send Nvidia out cold.

I thought of dumping NVIDIA as well :slight_smile:

Ok, I think I get your point.
Seems the only solution is to proceed with a fresh install with the latest ISO

Thanks for your patience and help !

1 Like

It worked, with any issue
Solution: completely reinstalled the OS

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.