Fresh installation won't start

Boot a live session and open a terminal:

manjaro-chroot -a


cat /etc/fstab

Is there anything?

Thank you. I opened a terminal on a live session and ran the commands, here’s what I got:

[manjaro@manjaro ~]$ manjaro-chroot -a
grub-probe: error: cannot find a GRUB drive for /dev/sda1. Check your
grub-probe: error: cannot find a GRUB drive for /dev/sda1. Check your
==> Mounting (ManjaroLinux) [/dev/nvme0n1p3]
→ mount: [/mnt]
→ mount: [/mnt/boot/efi]

[manjaro /]# cat /etc/fstab
/etc/fstab: static file system information.

Use ‘blkid’ to print the universally unique identifier for a device; this may
be used with UUID= as a more robust way to name devices that works even if
disks are added and removed. See fstab(5).

UUID=371B-8D86 /boot/efi vfat umask=0077 0 2
UUID=126cc94b-bbc3-40aa-a68c-050012c9dff1 / ext4 defaults,noatime 0 1

Is there a problem with GRUB? Maybe something is wrong with ‘/dev/sda1’. If I open the KDE partition manager, the partitions look a bit different:

/dev/nvme0n1p1 fat32 /mnt/boot/efi
/dev/nvme0n1p3 ext4 /mnt
/dev/nvme0n1p2 linuxswap

Do I have to change the partitions? I’m sorry if it’s a dumb question, this is the first time I have an SSD. In previous installations (using HDDs) I always had partitions with names like ‘sda1’.

By the way, if I run ‘blkid’ (based on what the terminal says), I get the following information:

[manjaro /]# blkid
/dev/sda1: BLOCK_SIZE=“2048” UUID=“2021-05-19-14-17-55-00” LABEL=“MANJARO_KDE_2105” TYPE=“iso9660”
/dev/loop0: TYPE=“squashfs”
/dev/loop1: TYPE=“squashfs”
/dev/loop2: TYPE=“squashfs”
/dev/loop3: TYPE=“squashfs”
/dev/nvme0n1p1: LABEL_FATBOOT=“EFI” LABEL=“EFI” UUID=“371B-8D86” BLOCK_SIZE=“512” TYPE=“vfat” PARTUUID=“3
/dev/nvme0n1p2: LABEL=“Swap” UUID=“4613b107-7bca-437f-af3f-9ab11239a96c” TYPE=“swap” PARTUUID=“aca97379-f
/dev/nvme0n1p3: LABEL=“Manjaro” UUID=“126cc94b-bbc3-40aa-a68c-050012c9dff1” BLOCK_SIZE=“4096” TYPE=“ext4”

Well here it looks good. What could be also a problem is when something else than “AHCI” is enabled, like “RAID” or “IDE”. Please check also if “AHCI” is enabled at your UEFI. Otherwise I have no idea what could be the problem. I would bet it is a firmware or UEFI problem, but not sure.

Dear Megavolt, thank you so much for your replies and help.

I checked the BIOS once again to see if I could find any of the acronyms that you mentioned and I’m afraid that I couldn’t find much. Here’s a picture of the BIOS:

If I press Enter where it says “Intel (R) Rapid Storage Technology” I get to choose the SSD and then the following:

There’s nothing that I can turn on or off, but it says that the status is “Non-RAID”. Is that a good thing?

Regarding the other settings, the BIOS suggests that the first two (Internal Pointing Device and FN Lock Option) have to do with the touchpad and the FN keys so I guess they’re irrelevant. Then, when I try to toggle the Hyper-Threading setting it says that it may cause the system to malfunction, so I just left it enabled (which is the default option).

I disabled the other three settings (Intel Virtualisation Technology, Intel AES-NI and VT-d) and restarted the laptop to see if Manjaro would start but I’m afraid that I got the same message (the ERROR device UUID not found thing).

All the other tabs and settings from the BIOS don’t seem to do much about this, but I could enable or disable anything else if you think it’d work.

I really don’t know much about these Intel technologies and BIOS settings, but I believe that maybe I got something wrong on the GRUB settings or how I created the partitions. When I installed Manjaro the first time I chose the default graphical settings (which didn’t work) but then I tried to set the partitions manually so that I could have a swap partition (but it didn’t work either). I tried to follow the Manjaro User Guide but I’m not 100% sure that I got it right.

What I’m trying to say is that I have installed Manjaro several times before (on laptops with traditional HDDs) and never ran into any issues like these. Now I got a new laptop with an SDD (no HDD) and I thought that the default setup would work but maybe I’m doing something wrong (or I missed something).

I think that it’s probably something easy to set up but I just can’t find it yet, hahaha. I have already read other posts online but haven’t found a solution.

Anyways, thanks for trying to help me, you’re giving me hope :slight_smile:

(I apologise if I made spelling mistakes or wrote something that sounds weird, English is not my native language).

I know that Intel RST causes a lot of problems with Linux. No idea what it means with “Non-Raid”… Does it mean by this “AHCI” ? Maybe yes… :man_shrugging:

There must be a way to disable it or change the mode. I can’t believe that it is not possible… Shame on you, ASUS!

Could you please post the model of your Vivobook?

inxi -Fazy


Well, for a non-native speaker, i can understand pretty everything what you write, but hey… I am also a non-native speaker, so what? :crazy_face:

1 Like

Thanks. This is an Asus VivoBook X413E with an i5-1135G7. Here’s the inxi output:

Kernel: 5.10.36-2-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0
parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC
misobasedir=manjaro misolabel=MANJARO_KDE_2105 quiet systemd.show_status=1
apparmor=1 security=apparmor driver=free nouveau.modeset=1 i915.modeset=1
Desktop: KDE Plasma 5.21.5 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM
Distro: Manjaro Linux base: Arch Linux
Type: Laptop System: ASUSTeK product: VivoBook_ASUSLaptop X421EAY_X413EA
v: 1.0 serial:
Mobo: ASUSTeK model: X421EAY v: 1.0 serial:
UEFI: American Megatrends LLC. v: X421EAY.212 date: 10/14/2020
ID-1: BAT0 charge: 17.9 Wh (43.1%) condition: 41.5/42.1 Wh (98.7%)
volts: 11.8 min: 11.8 model: ASUSTeK ASUS Battery type: Li-ion serial: N/A
status: Discharging
Info: Quad Core model: 11th Gen Intel Core i5-1135G7 bits: 64 type: MT MCP
arch: Tiger Lake family: 6 model-id: 8C (140) stepping: 1 microcode: 60
cache: L2: 8 MiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
bogomips: 38720
Speed: 1301 MHz min/max: 400/4200 MHz Core speeds (MHz): 1: 1301 2: 1578
3: 1366 4: 1298 5: 1323 6: 1340 7: 1344 8: 1291
Vulnerabilities: Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Device-1: Intel Iris Xe Graphics vendor: ASUSTeK driver: i915 v: kernel
bus-ID: 0000:00:02.0 chip-ID: 8086:9a49 class-ID: 0300
Device-2: IMC Networks USB2.0 HD UVC WebCam type: USB driver: uvcvideo
bus-ID: 1-6:3 chip-ID: 13d3:56e6 class-ID: 0e02 serial:
Display: x11 server: X.Org 1.20.11 compositor: kwin_x11 driver:
loaded: intel unloaded: modesetting alternate: fbdev,vesa display-ID: :0
screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
s-diag: 582mm (22.9")
Monitor-1: eDP1 res: 1920x1080 hz: 60 dpi: 157 size: 310x170mm (12.2x6.7")
diag: 354mm (13.9")
OpenGL: renderer: Mesa Intel Xe Graphics (TGL GT2) v: 4.6 Mesa 21.0.3
direct render: Yes
Device-1: Intel Tiger Lake-LP Smart Sound Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel alternate: snd_sof_pci bus-ID: 0000:00:1f.3
chip-ID: 8086:a0c8 class-ID: 0403
Sound Server-1: ALSA v: k5.10.36-2-MANJARO running: yes
Sound Server-2: JACK v: 0.125.0 running: no
Sound Server-3: PulseAudio v: 14.2 running: yes
Sound Server-4: PipeWire v: 0.3.27 running: no
Device-1: Intel Wi-Fi 6 AX201 driver: iwlwifi v: kernel port: 3000
bus-ID: 0000:00:14.3 chip-ID: 8086:a0f0 class-ID: 0280
IF: wlo1 state: up mac:
Device-1: Intel type: USB driver: btusb v: 0.8 bus-ID: 1-10:5
chip-ID: 8087:0026 class-ID: e001
Report: rfkill ID: hci0 rfk-id: 3 state: up address: see --recommends
Hardware-1: Intel Volume Management Device NVMe RAID Controller driver: vmd
v: 0.6 port: 3000 bus-ID: 0000:00:0e.0 chip-ID: 8086.9a0b rev:
class-ID: 0104
Local Storage: total: 246.12 GiB used: 0 KiB (0.0%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital
model: PC SN530 SDBPNPZ-256G-1002 size: 238.47 GiB block-size:
physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 rotation: SSD
serial: rev: 21106000 temp: 26.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 type: USB vendor: HP model: v100w size: 7.65 GiB
block-size: physical: 512 B logical: 512 B serial: rev: 0119
scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Message: No partition data found.
Alert: No swap data was found.
System Temperatures: cpu: 44.0 C mobo: N/A
Fan Speeds (RPM): cpu: 0
Processes: 250 Uptime: 2m wakeups: 135 Memory: 7.46 GiB
used: 1.9 GiB (25.4%) Init: systemd v: 247 tool: systemctl Compilers:
gcc: N/A Packages: pacman: 1219 lib: 326 flatpak: 0 Shell: Bash v: 5.1.8
running-in: konsole inxi: 3.3.04

What caught my attention is the fact that I was able to install Ubuntu (which boots just fine) but I can’t get Manjaro to work. So, I believe that the problem has to do with the software configuration rather than the BIOS setting (I could be wrong, it’s just a hunch).


What comes to my mind is that setting an admin password will unlock more advanced feature at some UEFIs. Maybe try that…

Also check this list:

Dear @megavolt, I went back to the BIOS and set an admin password but still got no additional options, I’m afraid I still have the same menu entries and I can’t disable Rapid Storage Technology or any of the other terms that are mentioned here. I don’t have Optane memory.

Is there anything else that can I do? (on the BIOS or using a USB live session). Thank you for all your help.

Sorry no idea then. The driver is loaded:

But it needs then a setup with dmraid (fake raid) …

Last thing i could suggest, is wipe the while disk:

Delete all possible signatures:

sudo wipefs -a /dev/nvme0n1

Unload the driver

sudo modprobe -r vmd

Create a new partition table and install again.

If there any OS installed before in “Raid mode”, then the signature still survive even if you create a new partition table.

If that does not work, well, then i am out of ideas, since Asus does not allow you to disable it or change the mode.

I ran those two commands (wipefs and modprobe) on a live session and then created a new partition table and new partitions using GParted (following the Manjaro User Guide). After that, I installed Manjaro once again and the result is the same:

I guess this laptop has some weird BIOS configuration. Maybe it’s something new to prevent us from installing GNU+Linux (they expect us to use Windows and their default settings).

Don’t worry @megavolt, you have already done a lot to help me and I just can’t thank you enough for all your ideas and support, you have been extremely generous and kind. Have a nice day!

I have already read other topics on other forums (like the Arch forum) and it seems that I’m not the only one, so I guess I’ll probably find other things to try. By the way, I tried Endeavour OS too and the same thing happened, so I think that this issue is somehow related to Arch-based distros (I’m not complaining, I’m just pointing out my conclusions).

I don’t want to give up yet because Manjaro is so good :heart: that I really don’t want to try any other distro. If I find a solution I’ll post it here.

I struggled yesterday with the same problem on a brand new Zenbook ux325. I think it’s an Asus specific problem on their newer 11th gen Intel laptops. After reading around I stumbled upon a theory that they may not be turning off safe boot correctly and it was suggested that I try one of the distros that support safe boot. Following that I effortlessly installed Fedora and am running it right now. I would really love to get back to Manjaro though.


I found this on the arch linux forum and I managed to get it working.

Here’s what you need to do AFTER installation:

  1. Boot the system from a live-usb or dvd.
  2. Mount the manjaro partition using the console to make it accessible.
  3. Access the the mounted partition using manjaro-chroot path/to/mounting-point.
  4. Open /etc/mkinitcpio.conf using your favorite editor - e.g vi /etc/mkinitcpio.conf
  5. Add vmd to your modules array, so it looks like this:


  1. Save the file.
  2. Inside the folder /etc/mkinitcpio.d/ you should see a preset. Mine was linux510.preset
  3. Run the preset with mkinitcpio -p linux510 (Or your preset name)
  4. Log out and reboot the computer, Manjaro should now be bootable!

Interesting… So the vmd driver for Intel RST needs to be loaded early…

1 Like

try bios instedad of uefi
bios is lot more reailabe than uefi

Here’s some extra info. It seems to be a known issue with arch.

did you disable secure boot?

THIS! This helped me so much, thank you. I just got an ASUS Tufbook, and was scouring around trying to figure out the answer, the MODULES=(vmd) after manjaro-chrooting in was the answer! Thanks so much!

Another solution, disable VMD controller on BIOS if possible.

Dear @Sparereach, thank you so much for your reply. Changing the MODULES thing like you said solved the problem and now I can use Manjaro properly (yay! :star_struck:).

In case that someone else has the same issues after a new installation, I recommend following Sparereach’s solution or the steps described in this post.

I’m sorry about the delay, I had some busy weeks at work.

Have a nice day, guys!

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.