ERROR: device 'UUID=<device_uuid>' not found. Skipping fsck

I see, anyway thank you!

On the Manjaro Wiki there’s an article called GRUB/Restore the GRUB Bootloader - Manjaro. Maybe this fixes the problem…

Edit: link to wiki

Doesn’t look good to me, 5550e9430 is not part of the UUID you posted. :slight_smile:

1 Like

I’ll check it!

Oh you think those extra characters shouldn’t be there? I’ll try to remove those and try again then. Or how can I know if they’re correct?

lsblk -o UUID /dev/nvme0n1p2

By the way, the fsck is not run from within GRUB. It’s run from within the initramfs. So if fixing the UUID in /etc/fstab doesn’t work, then you may need to rebuild the initramfs.

sudo mkinitcpio -P
1 Like

Yes it throws me this:

Okay I ran this and said Image generation successful, do I have to do anything else or I reboot and that’s it? (I don’t know about these things)

OK then you missed a bit off the UUID earlier, I did think it was a bit short, it helps when you post the correct information. :slight_smile:

1 Like

I would try that, yes.

Oh no! I’m sorry it was not on purpose, now I understand the characters you asked me about :man_facepalming: I didn’t realize I didn’t copy the entire line

1 Like

I rebooted but got the same error

No worries. :slight_smile:

Hey @dibyte

Somebody reported a similar issue in the thread below:

The solution would be adding vmd to the MODULES section in the /etc/mkinitcpio.conf file. Then, regenerate initramfs and reboot.

It looks like this is an ongoing issue with mkinitcpio already reported on the Arch Bug Tracker

Hope that helps!

Edit: The above procedure needs to be done under chroot.


It actually looks like the problem I have, however, I’m getting the same error or I don’t know if I’m doing something wrong:

  1. I boot Manjaro from pendrive
  2. I run sudo vim /etc/mkinitcpio.conf and then add the “vmd” module:
    MODULES=(vmd), then I save and quit.
  3. Run sudo mkinitcpio -P
  4. Reboot
  5. Get same error

Did you do a chroot for this?

If not, do a chroot and try again under the chroot

1 Like

Thank you very much!
These were the steps I’ve done:

sudo su
mount /dev/nvme0n1p1 /mnt/boot/efi
mount /dev/nvme0n1p2 /mnt
mount -t proc proc /mnt/proc
mount -t devtmpfs udev /mnt/dev
mount -t sysfs sys /mnt/sys
chroot /mnt
(here I saw with vim etc/mkinitcpio.conf already had the MODULES=(vmd))
mkinitcpio -P (under chroot)

Then rebooted and it worked!!


Glad it worked for you! :+1: :smiley:

Thank you all and for your patience :grin:

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.