Frequent wifi disconnects after updating to 21.2.3

Hello! I am having some issues where my wifi continually disconnects and reconnects. From looking at the system journal, it looks like my device is roaming back and forth between two access points and failing to authenticate. It may also be some DHCP issue. This causes gaps in network connectivity. This was not an issue prior to the update. I have an Inspiron 5515 with an Intel AX200 wifi card. Interestingly, after some research, I disabled IPv6 on the wifi connection and the problem went away for a while but is now back.

02:00.0 Network controller: Intel Corporation Wi-Fi 6 AX200 (rev 1a)

Here is a snippet from my syslog of the problem happening: Feb 12 10:00:56 ares audit[174963]: USER_AUTH pid=174963 uid=1000 auid=1000 ses= -

OS: Manjaro 21.2.3
Kernel: x86_64 5.16.5-1-MANJARO
DE: Plasma 5.23.5

I did update to 21.2.3 and the 5.16 kernel at the same time and haven’t done any messing with that yet. I wanted to see if there was any community knowledge before I started really messing around with trying to fix it. Thanks!

Hi @jsimon0,

  1. Please see [HowTo] Provide System Information.
    1.1. If applicable, please see [HowTo] post screenshots and links
    1.2. If applicable, also see [HowTo] Increase your chances of solving your issue

  2. Have you tried with a different kernel? Preferably 5.4, 5.10 or 5.15 as they are the current LTS versions?


According to this site:

So, perhaps not version 5.4.

No, I haven’t tried another kernel, as I wanted to preserve the failing state in case there was meaningful information to retrieve. I’m trying to solve the problem moving forward not pinning myself to a specific kernel.

Here is my inxi output:

  Kernel: 5.16.5-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.16-x86_64
    root=UUID=00fa247c-36af-46bf-bf5f-96fbf4cc5edf rw quiet
    root=/dev/mapper/luks-7905b9d4-bf86-474f-861a-fdda4c9515a4 apparmor=1
  Console: pty pts/9 wm: kwin_x11 DM: SDDM Distro: Manjaro Linux
    base: Arch Linux
  Type: Laptop System: Dell product: Inspiron 5515 v: 1.2.0 serial: <filter>
    Chassis: type: 10 v: 1.2.0 serial: <filter>
  Mobo: Dell model: 0KDKG8 v: A00 serial: <filter> UEFI: Dell v: 1.2.0
    date: 05/13/2021
  ID-1: BAT0 charge: 50.8 Wh (91.2%) condition: 55.7/54.0 Wh (103.1%)
    volts: 16.4 min: 15.0 model: SMP-ATL3.66 DELL XDY9K15 type: Li-poly
    serial: <filter> status: Discharging
  RAM: total: 30.77 GiB used: 10.26 GiB (33.3%)
  Array-1: capacity: 64 GiB slots: 2 EC: None max-module-size: 32 GiB
    note: est.
  Device-1: DIMM 0 size: 16 GiB speed: 3200 MT/s type: DDR4
    detail: synchronous unbuffered (unregistered) bus-width: 64 bits
    total: 64 bits manufacturer: 859B0000802C part-no: CT16G4SFRA32A.C16FP
    serial: <filter>
  Device-2: DIMM 0 size: 16 GiB speed: 3200 MT/s type: DDR4
    detail: synchronous unbuffered (unregistered) bus-width: 64 bits
    total: 64 bits manufacturer: 859B0000802C part-no: CT16G4SFRA32A.C16FP
    serial: <filter>
  Info: model: AMD Ryzen 7 5700U with Radeon Graphics socket: FP6 bits: 64
    type: MT MCP arch: Zen 2 family: 0x17 (23) model-id: 0x68 (104) stepping: 1
    microcode: 0x8608103
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB L3: 8 MiB
    desc: 2x4 MiB
  Speed (MHz): avg: 1800 min/max: 1400/4370 boost: enabled
    base/boost: 1800/4350 scaling: driver: acpi-cpufreq governor: performance
    volts: 1.2 V ext-clock: 100 MHz cores: 1: 1800 2: 1800 3: 1800 4: 1800
    5: 1800 6: 1800 7: 1800 8: 1800 9: 1800 10: 1800 11: 1800 12: 1800
    13: 1800 14: 1800 15: 1800 16: 1800 bogomips: 57518
  Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1
    bmi2 bpext cat_l3 cdp_l3 clflush clflushopt clwb clzero cmov cmp_legacy
    constant_tsc cpb cpuid cqm cqm_llc cqm_mbm_local cqm_mbm_total
    cqm_occup_llc cr8_legacy cx16 cx8 de decodeassists extapic extd_apicid
    f16c flushbyasid fma fpu fsgsbase fxsr fxsr_opt ht hw_pstate ibpb ibrs ibs
    irperf lahf_lm lbrv lm mba mca mce misalignsse mmx mmxext monitor movbe
    msr mtrr mwaitx nonstop_tsc nopl npt nrip_save nx osvw overflow_recov pae
    pat pausefilter pclmulqdq pdpe1gb perfctr_core perfctr_llc perfctr_nb
    pfthreshold pge pni popcnt pse pse36 rapl rdpid rdpru rdrand rdseed rdt_a
    rdtscp rep_good sep sha_ni skinit smap smca smep ssbd sse sse2 sse4_1
    sse4_2 sse4a ssse3 stibp succor svm svm_lock syscall tce topoext tsc
    tsc_scale umip v_spec_ctrl v_vmsave_vmload vgif vmcb_clean vme vmmcall
    wbnoinvd wdt xgetbv1 xsave xsavec xsaveerptr xsaveopt xsaves
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional,
    IBRS_FW, STIBP: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: AMD Lucienne vendor: Dell driver: amdgpu v: kernel bus-ID: 03:00.0
    chip-ID: 1002:164c class-ID: 0300
  Device-2: Sunplus Innovation Integrated_Webcam_HD type: USB
    driver: uvcvideo bus-ID: 3-1:2 chip-ID: 1bcf:2a02 class-ID: 0e02
    serial: <filter>
  Display: server: compositor: kwin_x11 driver:
    loaded: amdgpu,ati unloaded: modesetting alternate: fbdev,vesa
  Message: Unable to show advanced data. Required tool glxinfo missing.
  Device-1: AMD Renoir Radeon High Definition Audio vendor: Dell
    driver: snd_hda_intel v: kernel bus-ID: 03:00.1 chip-ID: 1002:1637
    class-ID: 0403
  Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor vendor: Dell
    driver: snd_rn_pci_acp3x v: kernel alternate: snd_pci_acp3x,snd_pci_acp5x
    bus-ID: 03:00.5 chip-ID: 1022:15e2 class-ID: 0480
  Device-3: AMD Family 17h HD Audio vendor: Dell driver: snd_hda_intel
    v: kernel bus-ID: 03:00.6 chip-ID: 1022:15e3 class-ID: 0403
  Sound Server-1: ALSA v: k5.16.5-1-MANJARO running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.45 running: yes
  Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel bus-ID: 02:00.0
    chip-ID: 8086:2723 class-ID: 0280
  IF: wlp2s0 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  WAN IP: <filter>
  Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 3-3:3
    chip-ID: 8087:0029 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 6 state: up address: see --recommends
  Message: No logical block device data found.
  Device-1: luks-7905b9d4-bf86-474f-861a-fdda4c9515a4 maj-min: 254:0
    type: LUKS dm: dm-0 size: 897.43 GiB
  p-1: nvme0n1p2 maj-min: 259:2 size: 897.43 GiB
  Device-2: luks-a9ae68e6-6196-4930-9bd0-7b0ef487a7cd maj-min: 254:1
    type: LUKS dm: dm-1 size: 33.78 GiB
  p-1: nvme0n1p3 maj-min: 259:3 size: 33.79 GiB
  Message: No RAID data found.
  Local Storage: total: 931.51 GiB used: 470.78 GiB (50.5%)
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 980 1TB
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 type: SSD serial: <filter> rev: 1B4QFXO7 temp: 29.9 C scheme: GPT
  SMART: yes health: PASSED on: 6d 13h cycles: 133,279
    read-units: 6,920,982 [3.54 TB] written-units: 6,993,538 [3.58 TB]
  Message: No optical or floppy data found.
  ID-1: / raw-size: 897.43 GiB size: 882.27 GiB (98.31%)
    used: 469.51 GiB (53.2%) fs: ext4 block-size: 4096 B dev: /dev/dm-0
    maj-min: 254:0 mapped: luks-7905b9d4-bf86-474f-861a-fdda4c9515a4
    label: N/A uuid: 00fa247c-36af-46bf-bf5f-96fbf4cc5edf
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 452 KiB (0.1%) fs: vfat block-size: 512 B dev: /dev/nvme0n1p1
    maj-min: 259:1 label: NO_LABEL uuid: 283C-5D87
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 33.78 GiB used: 1.27 GiB (3.7%)
    priority: -2 dev: /dev/dm-1 maj-min: 254:1
    mapped: luks-a9ae68e6-6196-4930-9bd0-7b0ef487a7cd label: swap
    uuid: ade41883-e456-4e57-84db-442de3f8b4a4
  Message: No unmounted partitions found.
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 4 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-2: 2-0:1 info: Super-speed hub ports: 2 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Hub-3: 3-0:1 info: Hi-speed hub with single TT ports: 4 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 3-1:2 info: Sunplus Innovation Integrated_Webcam_HD type: Video
    driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA
    chip-ID: 1bcf:2a02 class-ID: 0e02 serial: <filter>
  Device-2: 3-3:3 info: Intel AX200 Bluetooth type: Bluetooth driver: btusb
    interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA chip-ID: 8087:0029
    class-ID: e001
  Device-3: 3-4:9 info: Shenzhen Goodix Goodix USB2.0 MISC
    type: <vendor specific> driver: N/A interfaces: 1 rev: 2.0 speed: 12 Mb/s
    power: 100mA chip-ID: 27c6:639c class-ID: ef00 serial: <filter>
  Hub-4: 4-0:1 info: Super-speed hub ports: 2 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 43.0 C mobo: 36.0 C gpu: amdgpu temp: 51.0 C
  Fan Speeds (RPM): cpu: 0
  Processes: 545 Uptime: 3d 34m wakeups: 7240 Init: systemd v: 250
  tool: systemctl Compilers: gcc: 11.1.0 clang: 13.0.0 Packages: apt: 0
  pacman: 1909 lib: 511 flatpak: 0 Shell: Zsh (doas) v: 5.8 default: Bash
  v: 5.1.16 running-in: konsole inxi: 3.3.12

While I understand perfectly, using an LTS kernel might be the only thing that works. LTS stand for Long Term Support, so contains more bugfixes than others. Therefore, it might contain newer, updated drivers for the card that a normal kernel doesn’t.

I have seen many problems with this specific adapter, and while I can’t remember the exact solution, I think it was using a different kernel.


This page on the Archwiki had this to say about the Intel Wi-Fi 6 AX200:

For models with the Intel AX200 Wi-Fi adapter, the interface can engage in power saving when running on battery which increases network latency.

To avoid this issue, you can disable power saving by following the instructions in Power management#Network interfaces

So give that a go as well, it might help.

I also have this wifi card and I also had problem with disconnecting (not very often, only from time to time). You can disable mac address randomization (or set one by hand as I did), that helped me:

As a note, I’m a software engineer who deals with embedded linux systems, I know what LTS stands for. :wink: My first thought was to try the 5.15 LTS if not for the reason previously stated. I appreciate the community’s (read: your) help.

Thanks for the link. I suppose it could be powersave although the problem happens randomly and while I’m actively using the network interface. Also, I believe this has occurred while connected to mains power. But I’ll give it a shot and see what happens. It’s hard to prove a negative but I’ll report back if anything interesting happens (or doesn’t happen?).

Thanks for chiming in. Interestingly, that thread is where I got the idea to disable IPv6. I don’t have MAC randomization enabled so nothing to disable.

I might be wrong about this, but AFAIK the powsersave setting changes the adapter’s behavior both on battery power as well as when using mains, so night still be worth looking into.

As an update, downgrading to 5.15 LTS does not address this issue. Regardless of kernel version, it seems to be fine until I hibernate and then resume.

Forcing power save mode off for the wifi seems to have addressed this, at least while running 5.15 LTS. Interesting that it didn’t happen prior to recent updates. I’ll update to 5.16 again and see if maintaining that setting still fixes the problem.

The specific fix was to put:

# never power save wifi, the chip will disconnect from the network randomly on 5GHz

ACTION=="add", SUBSYSTEM=="net", KERNEL=="wl*", RUN+="/usr/bin/iw dev $name set power_save off"

in /etc/udev/rules.d/81-wifi-powersave.rules as suggested by the link @Mirdarthos posted. Thanks @Mirdarthos !

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.