Flickering display.

Hello. My monitor is 75hz. RTX 2060. Proprietary driver. KDE. Display settings with 75 Hz. With 60 Hz it does not suit me. At what the upper half of the screen flickers.

Have you set Force Composition Pipeline and Force Composition Full Pipeline in the Nvidia-Settings ? And check the OpenGL Settings there.
Please post the output of xrandr

Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 32767 x 32767
DP-0 disconnected (normal left inverted right x axis y axis)
DP-1 disconnected (normal left inverted right x axis y axis)
DP-2 disconnected (normal left inverted right x axis y axis)
DP-3 disconnected (normal left inverted right x axis y axis)
HDMI-0 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 527mm x 296mm
   1920x1080     60.00 +  74.97*   59.94    50.00  
   1680x1050     59.95  
   1440x900      59.89  
   1280x1024     75.02    60.02  
   1280x960      60.00  
   1280x720      60.00    59.94    50.00  
   1024x768      75.03    70.07    60.00  
   800x600       75.00    72.19    60.32    56.25  
   720x576       50.00  
   720x480       59.94  
   640x480       75.00    72.81    59.94    59.93  
DP-4 disconnected (normal left inverted right x axis y axis)
DP-5 disconnected (normal left inverted right x axis y axis)

No. Force Composition Pipeline and Full FCP not enabled. Now i’m enabled this.

After rebooting the system, these settings were reset. How do I get the system to start with these defaults enabled?

after some time of use - I observe that the flickering has not disappeared.

There is a similar problem reported in the last update thread

Has flickering started after the last update?

It started since April with a Manjaro Stable update (related to a new nvidia driver).

Till the last stable update (i never used unstable/tested updates yet) it was possible to fix it with the workaround nvidia_drm.modeset=1 in Grub.

Nvidia ignored this bug till the 08.July and working on a fix with high priority and the only other workaround that i know and helps against flickering is to use Max Performance Presets from the nvidia driver.

My card went from 9 Watt to 45Watt but this is the price i have to pay till lazy nvidia doing his job and fixing the bug.

I also reported this bug at the 31 of March but lazy nvidia never really payed attention.


Never mind. I’m install back windows 10 and this problem is gone :smiley:

With max performance change in XServer the problem is gone too…

There is no way to save the settings so what is the point of changing them? It keeps telling the path is write protected.

Huh? I can save it without problems.

Btw. nvidia response to this bug last week ago and we may will see a finally fix for it soon… if we have luck in the next driver update.

Which file you try to overwrite?

I dont see how that would help me. It is the same with Kubuntu, When I try to save the xserver-settings I get the message “unable to open x config file /etc/X11/xorg.conf for writing”. Maybe because there is no such file at this path?

If it is indeed the driver then I wonder why I have no flickering on Kubuntu.

As far i remember… 3years ago with my first steps in Manjaro i was running into the same issue and i open xserver with sudo… to save the file (overwrite) because of missing adminrights…

Someone told me later that its not a good idea (atleast normaly) for GUI Applications…
So i dont know if this is the recommend solution for your issue now, but i think this was helping me in the past.

You only have this flickering in Manjaro? And you using the same driver in Kubuntu?

I am not so good with console thus I dont know howto start the x-server console via sudo.
sudo nvidia x-server settings didnt open it :smiley:

Tbh. I am just always updating to the latest driver. No clue which one is running on Kub but it just updated recently. But I remember I had that flickering for a while on Kub too until it went away. Until it disappeared on Kub II kinda blamed the firmwareupdate of the monitor because I thought the flickering started with that.

without the - ?


sudo nvidia x server settings

sry i dont want to start it when i dont have to… because its resets my colour profile when i open xserver without a reason xD

on Kub is running 525.125.06, but the previous versions caused no flickering as well. Afair it started somewhere in March or April and ended like a week later on Kub. But on Manj it never stopped :frowning:

Ye with the “-” I typed it like it was named, I should check the package name I guess.

sudo nvidia x server settings gives “command not found”

no wonder… 525 was running fine with Manjaro too, the bug was introduced with 5.30 release.

Odd considering I have been having that flickering since early this year.

I did not expect Kub to be so far behind, but it seems to be a good thing in this case because that flickering really irritates me.

I created this Topic on 31 March:

So your nvidia Kubunto driver was pretty long not refreshed… good for you… but it was easy to fix it with a grub command… that its no longer working since 1 month :frowning:

my bad it was:

sudo nvidia-settings

Thats the odd thing. I get nv-drivers like weekly with the auto-update. But since they are soo far behind maybe they rolled back because of the flickering?

I have to admit that I do not pay attention to the version even when I see that there is an update.

sudo nvidia-settings worked thanks but saving the settings still prompted the same error message.