Firefox does not open link from other applications

My xorg got recently messed up after installing an update, which pushed (forced) me to start over from scratch. I installed the most recent Manjaro Gnome (21.0.7) and then ran all the updates, so that I’m now up to date.

The new installation is now running with Wayland. Most things work okay so far, but Firefox has some issues.

It works normal, when I open Firefox. I can also open multiple new windows e.g. with “Dash to dock”.

But if there is one instance already open, I cannot open links from within other applications. For example clicking on a link in Slack causes the error message below.
If there is no Firefox open, I can open links with Slack. But then I cannot open another new Window directly (same error). Also, the window opened through Slack (which contains all my previous tabs before closing the app) does not show up on the dock like an open FF instance. The little indicator dot is next to the Slack icon (so slack icon has 2 dots, FF has none)

Error message:
Firefox is already running, but is not responding. To use Firefox, you must first close the existing Firefox process, restart your device, or use a different profile.

I already tried this, with no success:

(MOZ_ENABLE_WAYLAND=1 even was already in my /etc/environment)

Does about:support show Wayland or xwayland? I remember running into the same issue but not the exact fix.

It says Window Protocol is wayland

I run KDE on Xorg, and Firefox does the same here. I thought that was normal behavior, so I have learned to endure it.

In addition to this environment variable, have you tried what is mentioned in the Arch Wiki page of Firefox (under Troubleshooting)?

Bug report in Firefox Bugzilla:

Setting MOZ_DBUS_REMOTE=1 improves the situation a lot, since I can now open links even if Firefox is already running.

But if I open e.g. Slack first (no FF running) and open a link, FF opens with the tabs of the previous session. But no indicator on dash to dock and 2 dots at the Slack icon. And the same for switching tasks (I have to use Alt+` instead of Alt+Tab)

Same issue here. With both MOZ_DBUS_REMOTE=1 and MOZ_ENABLE_WAYLAND=1 in /etc/environment but I can’t open links from any external apps (terminal, Slack, Discord, Obsidian, it doesn’t matter)

Also, I CAN open links from those apps if Firefox IS CLOSED. If the Firefox proc was started from inside Slack, for example, by clicking a link, I can open links from any program

If I start Firefox from it’s application (or my Browser shortcut) it simply bugs


I’ve had the same issue, been troubleshooting like crazy, played with those ENVs and with the .desktop files. Just can’t get Firefox on Wayland to sometimes open links from the terminal.

There is something that I’m missing because using plain xdg-open URL does work.

The problem is some incompatibility between display servers. Firefox may be using one display server and the application you are clicking the link in, may be using a different one. The solution to this is to have both applications use the same display server or compatible display servers.

In my case, I couldn’t open links in Discord with Firefox. I found that if I set export MOZ_ENABLE_WAYLAND=0 or export GDK_BACKEND=x11 and ran Firefox, I could then open links in Discord.

If you close out of Firefox and open a link in the application you want to be able to open links, Firefox should start up with the correct display server and open your link. If you go to about:support and find the “Environment Variables” section, you should be able to compare which environment variables were set by your application in order to get Firefox to open links. Take those and set them so that every time you open Firefox, it uses the display server compatible with the application you wish to open links in.

1 Like