Error opening links: Firefox is already running, but not responding

G’day everyone! I switched to manjaro from windows. everything seems to be working fine. but I’m facing an issue. when I click a link in discord or signal.

I get an error:

Firefox is already running, but not responding. To use Firefox, you must first close the existing Firefox process, restart your device, or use a different profile.

I have tried running Firefox in safe mode, Refresh Firefox, and even uninstalling and reinstalling it. but still getting the same error.

If I close the Firefox window and click the link again, it works. but that is not a good solution because I have to close what I am working on.

any suggestion?

thanks for your answer. the arch wiki is saying set an env variable. any ideas how to set env variables in manjaro?

Update: I fixed the error by setting an env variable. to set the env variable we have to run this command in the terminal


Update 2: we will have to add this line to the /etc/environment. because after restarting same error occurs

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.