Failed to Start Load Kernel Module

I’ve been purposely avoiding the December update, but yesterday I tried to update one package with pamac and it ended up updating everything. I figured I’d avoided it long enough and thought “What could possibly go wrong?” so I let it run. Long story short, there were some things broken. I decided to use timeshift to revert to pre-update configuration. Apparently, it didn’t go so well. When I attempt to boot, I get the error:

Failed to start Load Kernel Modules

and nothing else.

I’m booted into a Live DVD, and this is the output of lsblk:

[manjaro@manjaro ~]$ lsblk
loop0 7:0 0 85.1M 1 loop /run/miso/sfs/livefs
loop1 7:1 0 619.2M 1 loop /run/miso/sfs/mhwdfs
loop2 7:2 0 1.3G 1 loop /run/miso/sfs/desktopfs
loop3 7:3 0 663.5M 1 loop /run/miso/sfs/rootfs
sda 8:0 0 238.5G 0 disk
├─sda1 8:1 0 200M 0 part
├─sda2 8:2 0 119.4G 0 part
└─sda3 8:3 0 118.9G 0 part
sdb 8:16 0 931.5G 0 disk
└─sdb1 8:17 0 931.5G 0 part
sr0 11:0 1 2.7G 0 rom /run/miso/bootmnt
[manjaro@manjaro ~]$

I’m not quite sure where to go from here. : (

Can anyone offer some help? I really don’t want to screw this up any further . . .

After seeing that switch to TTY with Ctrl + Alt + F2 and use journalctl --no-hostname -b -p3 to look through the log to find out what’s exactly gone nuts.

Looks like the video drivers are probably the cause.

> systemd-modules-load[253]: Failed to insert module 'nvidia' . . . 
> systemd-modules-load[253]: Failed to insert module 'nvidia_drm' . . . 
> Failed to start Load Kernel Modules.
> Failed to start Light Display Manager.

The output of inxi -b shows kernel 5.4.80 but also says no driver no installed is for my graphics card (GTX 760).

Device-2: NVIDIA GK104 [GeForce GTX 760] driver: N/A

With yesterday’s stable update, on my XFCE manjaro with kernel 5.10 and 5.4 (both with nvidia 340xx drivers), with kernel it works perfect, but with manjaro does not work, it does the disk check and then the screen is black with the cursor (until version it worked perfect), apparently it is an incompatibility of the nvidia driver with the kernel, so I think we will have to wait for a new version of this kernel. Luckily I have 2 kernels installed (plus a backup with timeshift) so I don’t have to reinstall anything again

Yeah, I had a backup in timeshift too, but when I tried to revert to the backup I did just before the upgrade, everything went to hell, lol.

Not to be a help vampire, but can anyone give me an idea of how to proceed with this?

You’ve missed 6-7 stable updates already. The more you don’t update, the more likely your installation will be broken after the next update. There were also a lot of security updates between then and now.

You have to update every package installed to prevent partial upgrades, which can easily break your installation.

If you do not like to update often, I recommend going to a non-rolling release distro.

Instead of being a help vampire, looking up “Failed to start Load Kernel Modules” on the forum is a good start.

There is a reason why on the main page of the forum it says:

Please use the search function of the forum before posting any help requests.

This has been solved many many times. Majority of them are NVIDIA related due to the update in January, but posts solved the issue within the same day.

I did search it first, and there are a bunch of threads with different proposed solutions. So rather than blindly entering commands and hoping nothing else craters, I posted information specific to my system hoping to get specific information to fix it.

It’s not that I don’t like to update often; I’ve been running Manjaro for a couple years and the Dec update was the first one I’ve put off for any reason.

mhwd -a pci free 0300 output:

Warning: config '/var/lib/mhwd/local/pci/video-hybrid-amd-nvidia-prime/MHWDCONFIG' is invalid!
Skipping already installed config 'video-linux' for device: 0000:03:00.0 (0300:10de:1187) Display controller nVidia Corporation GK104 [GeForce GTX 760]
Skipping already installed config 'video-linux' for device: 0000:02:00.0 (0300:1002:683d) Display cotroller ATI Technologies Inc Cape Verde XT [Radeon HD 7770/8760 / /R7 250X]

pamac search -r nvidia flags these as installed:

> mhwd-nvidia-390xx    [INSTALLED] 390.132-1 core
> mhwd-nvidia          [INSTALLED] 460.39-1  core
> linux54-nvidia       [INSTALLED] 460.39-9  extra
> linux419-nvidia      [INSTALLED] 460.39-8  extra
> lib32-nvidia-utils   [INSTALLED] 460.39-1  multilib
> nvidia-390xx-utils   [INSTALLED] 390.141-1 extra
> nvidia-prime         [INSTALLED] 1.0-4     extra

inxi -b relevant output:

Device-2: NVIDIA GK104 [GeForce GTX760] driver: N/A

No change when rebooting. Still getting Failed to start Load Kernel Modules

Do pacman -Syu and then try to re-install your kernel modules with sudo pacman -S linux54-nvidia linux419-nvidia that will in turn initiate a regeneration of initrd images.
Also tell us if your machine is an Optimus laptop or a desktop.

Thank you. It is a desktop. pacman is unable to sync the databases. Does this need to be done via a Live DVD & chroot so I have internet connectivity? I’m currently in TTY.

There are issues with mirrors lately.

What is the output of pacman-mirrors ?

To be sure, you may reset your mirrors with sudo pacman-mirrors -c all then sudo pacman -Syyu

It shows:

 Pacman-mirrors version 4.16.4
 : :Downloading status failed!
 : :Please check you network connection ...

I don’t know the TTY commands but obviously one has to fix network connection first.

Yeah, and I’ve no idea how to connect to WiFi from TTY, or if that’s even possible.

I searched and found the commands to connect to WiFi but it fails, telling me it can’t find a network with that SSID (which I know for a fact exists). If I have to drag everything to another room so I can cable it to ethernet, I will.

Maybe the best approcah would be to boot from a live DVD, be sure to connect to Internet, use sudo manjaro-chroot -a and check again from the pacman mirrors.

And maybe reset the mirror list and retry a full update.

What is done is done, but, these past 3 months were particularly rich in updates/new functionalities.
More frequent updates are recommended.

If I remember correctly, nm-cli can help you to establish a connection to your WiFi network.