"Failed to start Light Display Manager"

When trying to launch my laptop, lightdm didn’t run. Running lightdm --test-mode --debug, it is revealed that the display server was stopped because “no sessions require it”. Just below that: “greeter display server failed to start”. I threw some preexisting solutions I found on google (not really google) at the problem with no effect. I am posting this from my phone.

I would try to boot with a Manjaro live USB, then chroot into your Manjaro installation (manjaro-chroot -a) and try to update just in case.

Was everything working right before the problem? What did you do to get to this error?

You tagged the topic with openbox and lightdm.

Is it because you have created an installation from scratch?

Maybe you have forgotten to enable the lightdm service?

sudo systemctl enable lightdm --force

The testmode is for running inside X - did you run it from a TTY - after all lightdm didn’t start so I assume you must be in TTY and the message “no sessions require it” seems to back it.

sudo systemctl start lightdm

Which solutions?

Are you running in circles - the xy problem kind of circle?

1 Like

I have the same problem, the solution is to edit /etc/lightdm/lightdm.conf, add the line logind-check-graphical=true.

5 Likes

+1 This worked for me

@manhallo You saved my day. Thank you!

For anyone who may have the same problem, you can try ctrl+alt+f2 to enter the console, no need for a live USB. Then login and edit the cofig file as @manhallo suggested.

1 Like

It worked for me too! Thanks!

1 Like

Works like a charm!

Thanks!!

For me it does work in 9 of 10 boots :frowning:
And in the logfile there is a log of lightdm restarting 3 to 5 times

I’m afraid that this didn’t work for me on a new install on Framework laptop i7-1165G7.
It =does= appear that the problem is a race condition because I was able to fix it as per
an archlinux forum post (267646) by adding a delay:

edit:
/etc/systemd/system/display-manager.service
add to:
[Service]
Restart=always
RestartSec=0.5

Actually I didn’t add the Restart=always line and it worked fine.

2 Likes

This is a link :thinking:

display-manager.service -> /usr/lib/systemd/system/lightdm.service

Did you copy the file and replace the link, or did you edit /usr/lib/systemd/system/lightdm.service ?

Beware to put this line in the [LightDM] section !
Thanks @manhallo :sunny:

Hello i cant access that file when I’m in ctr+alt+f2
i tried sudo /etc/lightdm/lightdm.conf but it give me command not found how i can access that file please I’m stuck for hours with black screen and i have work to do

what is the solution for that please

I have no idea what the issue is. This topic has been necrobumped several times.

There has never been any clear indications just someone posting a change where it most likely is just bandaid for an unknown issue.

I will refrain from commenting on the bandaid.


Another option is to replace lightdm with sddm

sudo pacman -S sddm

Then replace the service

sudo systemctl enable --now sddm --force

The original topic was tagged with openbox and as the maintainer of openbox I suggest using a more pleasant theme - of course this is a matter of taste - but anything is better than the default theme

sudo pacman -S norse-sddm-theme

Then add the theme

echo  "[Theme]\nCurrent=Norse\n" | sudo tee /etc/sddm.conf

Norse theme preview

1 Like

echo -e ? :wink:

closed due to necrobumping