Several issues after problems with hdd

Hi all,

About a year ago, in set up a Lenovo V17-iil with Manjaro Linux in XFCE Version. It is a dual-boot next to windows10 as i was not sure, if the user will accept manjaro instead of win10. The OS’ are installed on a ssd and we have a hdd for data, which is formatted in exfat, so it can be used from both, win10 an linux. We had some starting issues like freezing system caused bei LAN adapter, not working Touchpad and so on but with the help of this forum I got it up and running propperly. One issue stayed all the time: the read/write speed from the hdd was quiet slow within linux, in win10 it was not great, but ok.
In the last weeks, the read/write got way slower. Now, finally, while a longer Screen-Recording session, Manjaro hung up and was shut down by long pressing the power-button.
After that, the system won’t start propperly anymore with the message:
"[ 9.939974] Disabling IRQ #9

[FAILED] Failed to mount /home/birgit/Datenplatte. [DEPEND] Dependency failed for Local File Systems.

You are in emergency mode. After logging in, type “journalct1-xb” to view system logs, “systenctl reboot” to reboot, “systemctl default” or “exit” to boot into default mode.

Administratorpasswort für Wartungszwecke eingeben

(oder drücken Sie Strg+D, un fortzufahren):"

After removing the entry for the external HDD from /etc/fstab, the system started up fine. I saw, that there are some updates available and thought, that maybe they could help, so I installed them. But now, when starting the system, it errors with:
“[FAILED] Failed to start Light Display Manager.”

I googled this problem, and found some possible solutions. I did try:
“sudo systemctl enable lightdm --force”
This didnt change anything

After that I tried:
“sudo systemctl start lightdm”
This starts the graphic user interface and i get to the login-screen. But when I try to login, i get the graphic error message:
“Einstellungsserver kann nicht kontaktiert werden.
Verbindung ist gescheitert: Berbindungsaufbau abgeleht”
Which in english should be someting like:
“Settings server can not be contacted.
Connection failed: Connection denied”

Now at this point I can not find any further solutions in the web.

Does anybody habe a clue, what is going on here? I dont know, if those problems have the same root-cause, or are completely different problems?
What are the next steps to do? What can I surch for?
I hope, that my description of this problem helps. If you need an further information I can send it.
I would be so glad, if you can help me.

Thanks all in advance.

Additional information:
In Windows, i checked the SMART data of the drive with CrystalDiskInfo. The result is the following:

Can this be the problem?

Ich glaube ja nicht daß die angezeigten Werte korrekt sind.
Wenn sie korrekt sind … ist die Platte am Ende.

man kann die Daten auch in Linux mit smartctl auslesen …

Hallo @SimonStr,

erstmal versuch nochmal ein Update mit:

sudo pacman -Syyu

Um deinen Rechner besser einschätzen zu können bitte mal Ausgabe von inxi posten:

inxi -Fxxa

Um dein Manjaro Problem zu lösen.

Bei deiner Platte empfehle ich dir, dich um ein backup zu bemühen. Falls das Dateisystem auf der hdd defekt ist lässt sich das mM von Windows aus besser reparieren, da es mit ntfs formatiert ist.

… da @Nachlese auch auf deutsch geantwortet hat las ich mal mein schlechtes englisch weg! :laughing:

Oh - I didn’t really notice. Somehow the few german phrases lead me to respond in german. My bad.
More people will be able to participate if we keep it in english like he started it.

I was just voicing my opinion that based upon what is shown in that picture, the hdd seems to be shot.
and suggested to use the equivalent Linux tool smartctl to pull the same diagnostic data.
Not really helpful - I know.

Thank you very much for your fast response.

I tried to back-up the data within windows to an external hdd, but the copy failed due to “unknown error”. During this, the Current pending sector count rose to 3660.
In the moment I’m trying to copy the data to the external hdd by using a fedora live-stick, i had around.
I will come back and give the asked information as soon as this copy is (hopefully succesfully…) finished.


Just in case the disk is in really bad shape and your method of trying to save the data is proving insufficient:
there is dd - and dd-rescue, made specifically for getting data off of disks with read problems.
You can have it run in several passes, each time recovering more of what is still accessible.
Good Luck!

thanks a lot for this, I will try to find more information about dd-rescue, as the last rescue attempt did fail as well an the Current Pending Sector Count from smartctl is now 13928, so getting more extremely fast now…

Does not look that good…:

Hello together,

short update from my side:

  1. I tried to rescue the data on the hdd in different ways. IN the end I managed to rescue about 95% of it before the HDD died completely. Now it wasn’t even recognized in the BIOS.

  2. I removed the HDD from the Laptop to see, if this broken hardware causes some problems. Now the Bios-time until I can select if I want to boot in Manjaro or Windows is way faster than before. But the new Problem with the error message
    [FAILED] Failed to start Light Display Manager.
    stays. But now, after going to teminal and using
    sudo systemctl start lightdm
    the GUI starts and I can login and use it as normal. So I did all available updates in the Software GUI and also updated the kernel from Linux to 5.10.89-1. But this did not change anything.

My question now: As the dual boot with windows was only done, so the user of the PC, who was former Windows user, could swith back to windows in no time in case she needs to, but now is very happy with manjaro, I don’t need Windows anymore. So I want to remove it anyways.
So does it make sence to first repair my manjyro installation and afterwards remove windows, or is there a way to do a clean new install on Manjaro, but, somehow, keep the onstalled programs and their properies? So e.g. we have “photo import” installed and it was quite some work to adjust the settings, so it does the import the was she wants it, it would be great, if I somehow could keep all those user settings. Is this possible? and if yes, how?
For overview of the Laptop here the partition table:

Output of inxi -Fxxa will follow in a second

Thanks a lot and best regards

[birgit@birgit-laptop ~]$ inxi -Fxxa
  Host: birgit-laptop Kernel: 5.10.89-1-MANJARO x86_64 bits: 64 compiler: gcc
    v: 11.1.0 parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64
    root=UUID=10456a60-f05a-468e-99e8-abc0f1684d1b rw i8042.nopnp=1 pci=nocrs
    quiet apparmor=1 security=apparmor udev.log_priority=3
  Desktop: Xfce 4.16.0 tk: Gtk 3.24.29 info: xfce4-panel wm: xfwm 4.16.1
    vt: 7 dm: LightDM 1.30.0 Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: LENOVO product: 82GX v: Lenovo V17-IIL
    serial: <superuser required> Chassis: type: 10 v: Lenovo V17-IIL
    serial: <superuser required>
  Mobo: LENOVO model: LNVNB161216 v: SDK0J40709 WIN
    serial: <superuser required> UEFI: LENOVO v: EMCN40WW date: 08/10/2020
  ID-1: BAT0 charge: 25.1 Wh (58.6%) condition: 42.8/42.0 Wh (102.0%)
    volts: 11.4 min: 11.4 model: LGC L19L3PF4 type: Li-poly serial: 2310
    status: Discharging cycles: 12
  Info: model: Intel Core i7-1065G7 bits: 64 type: MT MCP arch: Ice Lake
    family: 6 model-id: 0x7E (126) stepping: 5 microcode: 0xA6
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 320 KiB desc: d-4x48 KiB; i-4x32 KiB L2: 2 MiB desc: 4x512 KiB
    L3: 8 MiB desc: 1x8 MiB
  Speed (MHz): avg: 1301 high: 1302 min/max: 400/3900 scaling:
    driver: intel_pstate governor: powersave cores: 1: 1301 2: 1302 3: 1301
    4: 1300 5: 1301 6: 1301 7: 1301 8: 1302 bogomips: 23968
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2
    mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel Iris Plus Graphics G7 vendor: Lenovo driver: i915 v: kernel
    bus-ID: 00:02.0 chip-ID: 8086:8a52 class-ID: 0300
  Device-2: Acer Integrated Camera type: USB driver: uvcvideo bus-ID: 1-5:2
    chip-ID: 5986:1135 class-ID: 0e02 serial: 200901010001
  Display: x11 server: X.Org compositor: xfwm4 v: 4.16.1 driver:
    loaded: modesetting alternate: fbdev,vesa display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
    s-diag: 582mm (22.9")
  Monitor-1: eDP-1 res: 1920x1080 hz: 60 dpi: 128
    size: 382x215mm (15.0x8.5") diag: 438mm (17.3")
  Message: Unable to show advanced data. Required tool glxinfo missing.
  Device-1: Intel Ice Lake-LP Smart Sound Audio vendor: Lenovo
    driver: snd_hda_intel v: kernel alternate: snd_sof_pci bus-ID: 00:1f.3
    chip-ID: 8086:34c8 class-ID: 0403
  Sound Server-1: ALSA v: k5.10.89-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.42 running: no
  Device-1: Intel Ice Lake-LP PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 00:14.3 chip-ID: 8086:34f0 class-ID: 0280
  IF: wlp0s20f3 state: up mac: fc:44:82:9d:d8:11
  Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 1-10:4 chip-ID: 8087:0026 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 3 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: see --recommends
  Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci
    v: 3.0 port: 3060 bus-ID: 00:17.0 chip-ID: 8086:282a rev: N/A
    class-ID: 0104
  Local Storage: total: 238.47 GiB used: 108.48 GiB (45.5%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Toshiba
    model: KBG40ZNT256G MEMORY size: 238.47 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: 80EPG60JQAC1
    rev: 0105AELA temp: 18.9 C scheme: GPT
  ID-1: / raw-size: 119.68 GiB size: 117.3 GiB (98.01%)
    used: 108.45 GiB (92.5%) fs: ext4 dev: /dev/nvme0n1p5 maj-min: 259:5
  ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%)
    used: 28.7 MiB (11.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  Alert: No swap data was found.
  System Temperatures: cpu: 35.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 248 Uptime: 19m wakeups: 1 Memory: 7.34 GiB
  used: 1.83 GiB (25.0%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 11.1.0 Packages: pacman: 1336 lib: 426 flatpak: 0 Shell: Bash
  v: 5.1.12 running-in: xfce4-terminal inxi: 3.3.11

Okay, I have no Idea, why I didn’t find this before…
The solution within this topic LINK helped perfect.
Now I only need to somehow get rid of windows, but I think that there will be lots of tutorials on how to do this in the internet. Any advice, which tutorial works fine?

Thanks a lot and best regards