[Stable Update] 2022-08-07 - Kernels, Nvidia, Thunderbird, Cinnamon, Glibc, GCC, LibreOffice, Firefox, MangoHud, KDE-git

For that warning message there is never a leading forward slash, that’s normal.

They are now, anyway. When that warning appears, that means the specified folders / files were previously installed, but were not found while updating the package that owns them. The files will be installed regardless.

Perhaps you removed locale files for languages you do not use? I seem to remember doing something that once a long time ago.

Hmm, interesting. Since glibc is a base package it is kinda hard to hold that update back. Maybe post more about that issue and if upstream is tracking that one …

I got a lot of copies of this when updating:

perl: warning: Setting locale failed.
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = "",
        LC_ALL = (unset),
        LC_ADDRESS = "de_DE.UTF-8",
        LC_NAME = "de_DE.UTF-8",
        LC_MONETARY = "de_DE.UTF-8",
        LC_PAPER = "de_DE.UTF-8",
        LC_IDENTIFICATION = "de_DE.UTF-8",
        LC_TELEPHONE = "de_DE.UTF-8",
        LC_MEASUREMENT = "de_DE.UTF-8",
        LC_TIME = "en_GB.UTF-8",
        LC_NUMERIC = "en_GB.UTF-8",
        LANG = "en_GB.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").

And after a reboot, I get issues like this:

(process:6227): Gtk-WARNING **: 17:31:48.961: Locale not supported by C library.
        Using the fallback 'C' locale.
terminate called after throwing an instance of 'std::runtime_error'
  what():  locale::facet::_S_create_c_locale name not valid

Elsewhere, I found this, to be put into .profile:

export LC_ALL=C; unset LANGUAGE

But I think that’s just a workaround for the fallback, not a fix and not for the main method.

You may want to read the 2022-06-12 troubleshoot note in the second post @Fabian

It’s BACK ! A few updates ago (June) my wine game stop working. Half way through the intro, it got stuck on a black screen. That was not a wine problem as I downgrade it. This new update has finally fix it. Both my Nvidia (GT750TI) and AMD (RX570) based computer had the problem at the same time. It is not a “driver” issue apparently nor wine, so I don’t know but that’s good again. Tx

I’m not sure it’s related to the update, but I didn’t edited nor changed anything else.
Upon reboot the system, LightDM didn’t start with message « Failed to start Light Display Manager».
I solved with this solution.

1 Like

After the update Plymouth is flickering: Plymouth flicker on Linux 5.19

Temporary workaround for now is to use the flatpak version of steam:

sudo pacman -S flatpak --needed --noconfirm
sudo flatpak install com.valvesoftware.Steam -y

You can use flatseal (another flatpak app) to grant it access to your existing game library so you don’t have to re-download your games (add the game library install path under “Other files” under “Filesystem”).

sudo flatpak install com.github.tchx84.Flatseal -y

FYI to @philm and advanced users: patched glibc and lib32-glibc are available here. They remove the commit that broke EAC.

A post was split to a new topic: CommonIncludes.hpp exists in both libuinputplus and libevdevplus

After applying the update & rebooting I get a white screen saying "“uh oh, something went wrong, the system cant recover” :scream:
I do have a timeshift, but not sure how to revert if I cant boot. I do have a USB somewhere…

OK, managed to fix it :sweat_smile: booted to tty & ran full update again. it was already downloaded, but a bunch of things had been skipped. after a reboot back to normal.


Ah, nice. :expressionless:

Suspend is broken on my laptop again. This is like the third time an update did this (while staying on the LTS kernel 5.15.x series).

Something’s going on with upstream kernel development. I’ve experience three or four issues while on 5.15.x that break suspends and/or reboots.

What makes me resistant to troubleshoot this (again) is that the previous times all my troubleshooting efforts were in vain, since it was a matter of waiting for the regression to be fixed by the upstream kernel developers.


i have the weird scratching sound again. i had the same problem with the RC of kernel 5.19, so i went back to 5.17
it appears sometimes when i start a video/music/etc after i do not play any sounds for a while. i cannot even mute it. i scratches for a few sec and then its gone as long as sounds playing

i have an RX580 and i use HDMI for soundoutput

with kernel 5.19.0-2 the leds showing microphone and audio disabled not working
5.18 and 5.15 they hare fine for it

Since last Stable im still experience Firefox Coredumb errors.

1 Like

Yes, kernel 5.19 has the same problem as 5.18 with scratching sound sound on AMD Ellesmere HDMI Audio Radeon RX 590. Noise starting sound on AMD Ellesmere HDMI Audio Radeon RX 590.

Fortunately, kernel 5.15 does not have that problem.

1 Like

Can this glibc issue be added to the list of known issues in the Known issues and solutions? I am also affected by this issue and can’t play some games. I always look at this list of known issues for serious issues before updating.

@thingsiplay having EAC broken by a core package update is not critical for us as a distro. However, for those who are affected I’ve added the flatpak workaround and mentioned the patched glibc packages we don’t recommend to install officially.

having issue with wifi usb adapter TP-LINK TL-WN821N after this kernel update. In fact all my network devices disappeared after update and running inxi -N returns “No PCI device data found.” message.

was able to get it working by installing rtl8192eu-git drivers package. Previously it was working on rtl8192eu package itself but its not a case anymore.

My update has no problem, but I suddenly got two orphaned packages:


Not sure what to do with them. I assigned them as explicit but don’t know where did they come from.

This update broke gcc/g++:

-- The CXX compiler identification is GNU 12.1.1
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - failed
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ - broken
CMake Error at /usr/share/cmake/Modules/CMakeTestCXXCompiler.cmake:62 (message):
  The C++ compiler


  is not able to compile a simple test program.

  It fails with the following output:

    Change Dir: /home/ave/Documents/oss/wors_tracer/build/CMakeFiles/CMakeTmp
    Run Build Command(s):/usr/bin/ninja cmTC_6166d && [1/2] Building CXX object CMakeFiles/cmTC_6166d.dir/testCXXCompiler.cxx.o
    [2/2] Linking CXX executable cmTC_6166d
    FAILED: cmTC_6166d 
    : && /usr/bin/c++   CMakeFiles/cmTC_6166d.dir/testCXXCompiler.cxx.o -o cmTC_6166d   && :
    /usr/bin/ld: /usr/lib/libm.so.6: unknown type [0x13] section `.relr.dyn'
    /usr/bin/ld: skipping incompatible /usr/lib/libm.so.6 when searching for /usr/lib/libm.so.6
    /usr/bin/ld: cannot find /usr/lib/libm.so.6
    /usr/bin/ld: /usr/lib/libm.so.6: unknown type [0x13] section `.relr.dyn'
    /usr/bin/ld: skipping incompatible /usr/lib/libm.so.6 when searching for /usr/lib/libm.so.6
    /usr/bin/ld: /usr/lib/libmvec.so.1: unknown type [0x13] section `.relr.dyn'
    /usr/bin/ld: skipping incompatible /usr/lib/libmvec.so.1 when searching for /usr/lib/libmvec.so.1
    /usr/bin/ld: cannot find /usr/lib/libmvec.so.1
    /usr/bin/ld: /usr/lib/libmvec.so.1: unknown type [0x13] section `.relr.dyn'
    /usr/bin/ld: skipping incompatible /usr/lib/libmvec.so.1 when searching for /usr/lib/libmvec.so.1
    collect2: error: ld returned 1 exit status
    ninja: build stopped: subcommand failed.

Or is the issue deeper than I can see?

❯ pacman -F /usr/lib/libm.so.6
usr/lib/libm.so.6 is owned by core/glibc 2.35-6

❯ pacman -Qi glibc
Name            : glibc
Version         : 2.36-1

So why is libm owned by an old glibc? Wasn’t it supposed to be upgraded?..

Anyways, downgrading gcc, gcc-libs, glibc and lib32-glibc, clang, llvm, llvm-libs helped. Please fix.