Failed to start file system check on /dev/disk/by-uuid/a

I dual booted my laptop with windows 10 and manjaro gnome Lts three months back(rarely booted to windows though). Today when I restarted the laptop it throws errors and won’t boot beyond grub. The errors are:
[FAILED] Failed to start file system check on /dev/disk/by-uuid/a2fa1…
[DEPEND] Dependency failed for /home
[DEPEND] Dependency failed for Local File Systems
You are in emergency mode.

What I’ve done is booted in manjaro with live usb and backed up my data. I want to be able to use manjaro like past days. Any help will be appreciated.

Can you check if this UUID exists:
lsblk -f

A quick search and I found this remarkably similar situation: Dependency failed for /home, it was solved and might work for you too.

Sorry for posting a picture, am new in linux stuffs

I ran the command stated there but it didn’t help. Might be due to being new to linux. I ran the command fsck -f -y
And the output was /dev/sda9 is mounted
e2fsck: Cannot continue, aborting

Did you hard-reset your laptop or was it a power failure?

I guess this issue occurs when there is a storage failure or power failure causing file inconsistencies.

Try to run e2fsck -y /dev/sda8 to fix this issue.

I hard switched off laptop twice when it freezed. I had no choice. What is recommended when the laptop freezes sometime?

That is why it is bad idea. I recommend to use REISUB that is safe for filesystem

This solution has worked. Thanks a lot

Sure. I’ll use it from the next time.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.