Evolution crashing after latest update

Evolution mail is unusable since the last update a few days ago - it opens but then freezes and closes. Getting this error:

(evolution:6624): Gtk-CRITICAL **: 09:34:11.856: _gtk_css_image_get_surface: assertion 'surface_width > 0' failed
free(): invalid pointer
Aborted (core dumped)

System info:


evolution 3.46.2 

Any ideas?

Do you confirm you did a full system update?
Have you rebooted after the update?

Hi. Not sure if it was a full system update. Yes I’ve rebooted since.

  Kernel: 5.15.81-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=8643e13d-67fa-4e6a-a82c-e45ef5ea0cb9 rw apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: GNOME v: 43.1 tk: GTK v: 3.24.35 wm: gnome-shell dm: GDM v: 43.0
    Distro: Manjaro Linux base: Arch Linux
  Type: Convertible System: HP product: HP Spectre x360 Convertible 13-ap0xxx
    v: N/A serial: <superuser required> Chassis: type: 31
    serial: <superuser required>
  Mobo: HP model: 8514 v: 09.68 serial: <superuser required> UEFI: AMI
    v: F.34 date: 10/08/2019
  ID-1: BAT0 charge: 50.3 Wh (100.0%) condition: 50.3/50.3 Wh (100.0%)
    volts: 17.1 min: 15.4 model: HP Primary type: Li-ion serial: N/A status: full
  Device-1: hid-0018:04F3:2810.0001-battery model: ELAN2514:00 04F3:2810
    serial: N/A charge: N/A status: N/A
  RAM: total: 15.28 GiB used: 3.21 GiB (21.0%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges required.
  Info: model: Intel Core i7-8565U bits: 64 type: MT MCP arch: Whiskey Lake
    gen: core 8 level: v3 note: check built: 2018 process: Intel 14nm family: 6
    model-id: 0x8E (142) stepping: 0xB (11) microcode: 0xF0
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 8 MiB desc: 1x8 MiB
  Speed (MHz): avg: 4403 high: 4601 min/max: 400/4600 scaling:
    driver: intel_pstate governor: performance cores: 1: 4337 2: 4391 3: 4484
    4: 4445 5: 4166 6: 4497 7: 4309 8: 4601 bogomips: 32012
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat
    arch_capabilities arch_perfmon art avx avx2 bmi1 bmi2 bts clflush
    clflushopt cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64
    dtherm dts epb ept ept_ad erms est f16c flexpriority flush_l1d fma fpu
    fsgsbase fxsr ht hwp hwp_act_window hwp_epp hwp_notify ibpb ibrs ida
    intel_pt invpcid invpcid_single lahf_lm lm mca mce md_clear mmx monitor
    movbe mpx msr mtrr nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm
    pdpe1gb pebs pge pln pni popcnt pse pse36 pts rdrand rdseed rdtscp
    rep_good sdbg sep sgx smap smep ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp
    syscall tm tm2 tpr_shadow tsc tsc_adjust tsc_deadline_timer vme vmx vnmi
    vpid x2apic xgetbv1 xsave xsavec xsaveopt xsaves xtopology xtpr
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf status: Not affected
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown status: Not affected
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
  Type: retbleed mitigation: IBRS
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: IBRS, IBPB: conditional, RSB filling,
    PBRSB-eIBRS: Not affected
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel WhiskeyLake-U GT2 [UHD Graphics 620] vendor: Hewlett-Packard
    driver: i915 v: kernel arch: Gen-9.5 process: Intel 14nm built: 2016-20
    ports: active: DP-4,eDP-1 empty: DP-1, DP-2, DP-3, DP-5 bus-ID: 00:02.0
    chip-ID: 8086:3ea0 class-ID: 0300
  Device-2: Quanta HP Wide Vision FHD Camera type: USB driver: uvcvideo
    bus-ID: 1-5:2 chip-ID: 0408:5251 class-ID: 0e02 serial: <filter>
  Display: x11 server: X.org v: with: Xwayland v: 22.1.5
    compositor: gnome-shell driver: X: loaded: modesetting alternate: fbdev,vesa
    dri: iris gpu: i915 display-ID: :1 screens: 1
  Screen-1: 0 s-res: 3360x1080 s-size: <missing: xdpyinfo>
  Monitor-1: DP-4 mapped: DP-2-2 pos: primary,top-left model: Dell P2319H
    serial: <filter> built: 2020 res: 1920x1080 hz: 60 dpi: 96 gamma: 1.2
    size: 509x286mm (20.04x11.26") diag: 584mm (23") ratio: 16:9 modes:
    max: 1920x1080 min: 720x400
  Monitor-2: eDP-1 pos: bottom-r model: AU Optronics 0x272b built: 2018
    res: 1440x810 hz: 60 dpi: 125 gamma: 1.2 size: 293x165mm (11.54x6.5")
    diag: 336mm (13.2") ratio: 16:9 modes: 3840x2160
  API: OpenGL Message: Unable to show GL data. Required tool glxinfo missing.
  Device-1: Intel Cannon Point-LP High Definition Audio vendor: Hewlett-Packard
    driver: snd_hda_intel bus-ID: 5-1.5:7 v: kernel chip-ID: 0bda:4014
    alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3 class-ID: 0102
    serial: <filter> chip-ID: 8086:9dc8 class-ID: 0401
  Device-2: Realtek USB Audio type: USB driver: snd-usb-audio
  Device-3: Generalplus USB Audio Device type: USB
    driver: hid-generic,snd-usb-audio,usbhid bus-ID: 5-1.7:9 chip-ID: 1b3f:2008
    class-ID: 0300
  Sound API: ALSA v: k5.15.81-1-MANJARO running: yes
  Sound Server-1: JACK v: 1.9.21 running: no
  Sound Server-2: PulseAudio v: 16.1 running: yes
  Sound Server-3: PipeWire v: 0.3.61 running: yes
  Device-1: Intel Cannon Point-LP CNVi [Wireless-AC] driver: iwlwifi v: kernel
    bus-ID: 00:14.3 chip-ID: 8086:9df0 class-ID: 0280
  IF: wlp0s20f3 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  Device-2: Realtek RTL8153 Gigabit Ethernet Adapter type: USB driver: r8152
    bus-ID: 6-1.2:3 chip-ID: 0bda:8153 class-ID: 0000 serial: <filter>
  IF: enp62s0u1u2 state: down mac: <filter>
  IF-ID-1: docker0 state: down mac: <filter>
  IP v4: <filter> scope: global broadcast: <filter>
  WAN IP: <filter>
  Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB
    driver: btusb v: 0.8 bus-ID: 1-10:4 chip-ID: 8087:0aaa class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 0 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: see --recommends
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 953.87 GiB used: 812.65 GiB (85.2%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Toshiba model: N/A
    size: 953.87 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 type: SSD serial: <filter> rev: AAHA4102 temp: 27.9 C scheme: GPT
  Message: No optical or floppy data found.
  ID-1: / raw-size: 953.57 GiB size: 937.53 GiB (98.32%)
    used: 812.65 GiB (86.7%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2
    label: N/A uuid: 8643e13d-67fa-4e6a-a82c-e45ef5ea0cb9
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 280 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1 label: N/A
    uuid: 92FD-2E54
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: file size: 20 GiB used: 0 KiB (0.0%) priority: -2
    file: /swapfile
  Message: No unmounted partitions found.
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 12 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-1:5 info: Dell Universal Receiver type: Keyboard,Mouse,HID
    driver: hid-generic,usbhid interfaces: 3 rev: 2.0 speed: 12 Mb/s power: 100mA
    chip-ID: 413c:301d class-ID: 0300
  Device-2: 1-5:2 info: Quanta HP Wide Vision FHD Camera type: Video
    driver: uvcvideo interfaces: 4 rev: 2.0 speed: 480 Mb/s power: 500mA
    chip-ID: 0408:5251 class-ID: 0e02 serial: <filter>
  Device-3: 1-9:3 info: Synaptics type: <vendor specific> driver: N/A
    interfaces: 1 rev: 2.0 speed: 12 Mb/s power: 100mA chip-ID: 06cb:00bb
    class-ID: ff00 serial: <filter>
  Device-4: 1-10:4 info: Intel Bluetooth 9460/9560 Jefferson Peak (JfP)
    type: Bluetooth driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s
    power: 100mA chip-ID: 8087:0aaa class-ID: e001
  Hub-2: 2-0:1 info: Super-speed hub ports: 6 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Hub-3: 3-0:1 info: Hi-speed hub with single TT ports: 2 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-4: 4-0:1 info: Super-speed hub ports: 2 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Hub-5: 5-0:1 info: Hi-speed hub with single TT ports: 2 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-6: 5-1:2 info: Microchip (formerly SMSC) Hub ports: 7 rev: 2.1
    speed: 480 Mb/s chip-ID: 0424:2807 class-ID: 0900
  Device-1: 5-1.5:7 info: Realtek USB Audio type: Audio driver: snd-usb-audio
    interfaces: 4 rev: 2.0 speed: 480 Mb/s power: 500mA chip-ID: 0bda:4014
    class-ID: 0102 serial: <filter>
  Hub-7: 5-1.6:8 info: Realtek 4-Port USB 2.0 Hub ports: 4 rev: 2.1
    speed: 480 Mb/s chip-ID: 0bda:5409 class-ID: 0900
  Device-1: 5-1.7:9 info: Generalplus USB Audio Device type: Audio,HID
    driver: hid-generic,snd-usb-audio,usbhid interfaces: 4 rev: 1.1
    speed: 12 Mb/s power: 100mA chip-ID: 1b3f:2008 class-ID: 0300
  Hub-8: 6-0:1 info: Super-speed hub ports: 2 rev: 3.0 speed: 5 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Hub-9: 6-1:2 info: Microchip (formerly SMSC) Hub ports: 7 rev: 3.1
    speed: 5 Gb/s chip-ID: 0424:5807 class-ID: 0900
  Device-1: 6-1.2:3 info: Realtek RTL8153 Gigabit Ethernet Adapter
    type: Network driver: r8152 interfaces: 1 rev: 3.0 speed: 5 Gb/s power: 256mA
    chip-ID: 0bda:8153 class-ID: 0000 serial: <filter>
  System Temperatures: cpu: 80.0 C pch: 66.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 278 Uptime: 39m wakeups: 3 Init: systemd v: 251 default: graphical
  tool: systemctl Compilers: gcc: 12.2.0 alt: 6 clang: 14.0.6 Packages: 2433
  pm: dpkg pkgs: 0 pm: pacman pkgs: 2420 libs: 540 tools: pamac,yay pm: rpm
  pkgs: 0 pm: flatpak pkgs: 0 pm: snap pkgs: 13 Shell: Bash v: 5.1.16
  running-in: gnome-terminal inxi: 3.3.24

Then let’s make it sure:

sudo pacman-mirrors -f5 && sudo pacman -Syyu

System is up to date:

sudo pacman-mirrors -f5 && sudo pacman -Syyu
::INFO Downloading mirrors from Manjaro
::INFO => Mirror pool: https://repo.manjaro.org/mirrors.json
::INFO => Mirror status: https://repo.manjaro.org/status.json
::INFO Using default mirror file
::INFO Querying mirrors - This may take some time
  1.939 Finland        : https://manjaro.kyberorg.fi/
  1.648 Russia         : https://mirror.kamtv.ru/manjaro/
  2.063 Uruguay        : https://manjaro.repo.cure.edu.uy/
  0.375 Austria        : https://mirror.easyname.at/manjaro/
  0.396 Poland         : https://ftp.icm.edu.pl/pub/Linux/dist/manjaro/
::INFO Writing mirror list
::Austria         : https://mirror.easyname.at/manjaro/stable
::Poland          : https://ftp.icm.edu.pl/pub/Linux/dist/manjaro/stable
::Russia          : https://mirror.kamtv.ru/manjaro/stable
::Finland         : https://manjaro.kyberorg.fi/stable
::Uruguay         : https://manjaro.repo.cure.edu.uy/stable
::INFO Mirror list generated and saved to: /etc/pacman.d/mirrorlist
:: Synchronising package databases...
 core                  163.9 KiB   428 KiB/s 00:00 [######################] 100%
 extra                1865.8 KiB  2.47 MiB/s 00:01 [######################] 100%
 community               7.5 MiB  2.86 MiB/s 00:03 [######################] 100%
 multilib              169.3 KiB  2.15 MiB/s 00:00 [######################] 100%
:: Starting full system upgrade...
 there is nothing to do

I use the same setup(gnome/evolution) but using wayland, and do not have this issue. Since the error looks like some css issue this might be theme related. Check to see if changing your theme to the default in tweaks solves this.

Thanks but that hasn’t solved it. I tried changing themes (both legacy applications and shell), disabling user themes extension, light and dark themes under settings > styles. Behaviour still the same

Hace unos días, he instalado desde los repositorios oficiales extra, Evolution 3 46.2-1 (evolution), y funciona correctamente. A veces un programa depende desde que repositorio se instala, te puede funcionar o no. (A few days ago, I installed from the official repositories extra, Evolution 3 46.2-1 (evolution), and it works correctly. Sometimes a program depends on which repository it is installed from, it may work for you or not).

That’s the same version I’ve got. I’ve tried reinstalling a number of times, still having the same issue

Just a longshot here: I know it is a PITA to setup e-mail, but have you tried backing up your current Evolution config and tried with a fresh config?

This is the one thing I haven’t dared try yet! I was hoping I wouldn’t have to…

OK I’ve tried this, still getting the same issue

This with the same error seems related or in my mind it does and it does and seems to be related to theme as the error occurs when starting evolution with a fresh config as posted.

A approach to take is make a new user, log in with that user and compare/test starting the application.

Thanks Hanzel - this works, I logged in as a new user and Evolution works fine. How to apply this to my user profile?

Also update FYI: I’m now getting a different error when I try to open Evolution in my user profile:

** (process:2): WARNING **: 13:55:43.808: Error writing credentials to socket: Error sending message: Broken pipe
free(): invalid pointer
Aborted (core dumped)

So as the new user with default settings can start the client this demonstrates that the software/default settings are correct and there are only user settings to change. One approach is to remove* folders from these locations.

Since this might still be a theme issue open the tweaks app, open appearance and under themes set the values for Cursor, Icons & Legacy applications to Adwaita (default) and Shell to Default this would be the first things to try since it is less invasive.

If either of the solutions does not solve the issue I’m out of ideas.

* make backups if you don’t have any yet and are pulling in mail and deleting it from the server and want to keep your data

The broken pipe error can be fixed by removing and recreating the account. For what it’s worth, I’ve stopped using Gnome Online Accounts and create the accounts directly in the client. GOA has to much issues in my case

Hanzel thank you so much, that’s fixed it. I tried removing all accounts from gnome online accounts, that didn’t work, I also tried resetting all my modifications with the ‘reset to default’ option in the tweaks app, also didn’t work. Then I removed the folder $HOME/.local/share/evolution and it fixed it. So glad to have it working! Thanks again.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.