Everything is big on proprietary graphics

Hi everyone, recently I assembled my custom PC, proceeded to install Manjaro (booted with Open Source Graphics) and it installed with no problems, until I installed the NVIDIA 390.xx graphics driver, everything was huge, the menus, the desktop icons and the windows, excepting the taskbar. Tried xrandr, arandr, adjusting global scale, changing resolution but nothing worked and I don’t know what else to do. The GPU worked in my previous PC with Manjaro btw.

PC specs in case of being necessary:
CPU: Intel Core i3-10100F (no integrated graphics)
GPU: ASUS GeForce GT 610 (390.xx drivers)
RAM: HyperX Fury RGB 8GB 2666MHz
Motherboard: ASUS Prime H410M-E
HDD: Seagate Barracuda 500GB

It is better to proivde the output of command inxi -Fazy instead (and make sure to post your terminal output like that between three backticks:

terminal output here

so it is properly formatted.

But your issue is probably the DPI like in this thread Nvidia Driver - Large Objects - #4 by omano? Force it to standard 96 DPI for a test (System Settings → Appearance → Font → Force Font DPI) and see if it fixes it for you after reboot.

Thanks, I’ll give it a try. And yes, I knew that there was a better way to put it, but oh well

Thank you so much omano, that fixed the issue, however, I can’t set my resolution to what I had, I used to have it at 1600x900 (primary monitor) and 1360x768 (secondary monitor), is there any way to set a custom resolution?

I don’t know, you may need to open a new thread with good title and description with lot of details on your setup so it brings people’s attention.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.