Error: file '/boot/vmlinuz-5.12-X86-64' not found you need to load the kernel first

I have been using Manjaro XFCE since version 20.1 installed in Sep 2020.
During the recent update (about 1 GB) I left the Laptop since it was going to take time. After coming back I found blank screen and could not open any terminal to do proper shutdown/restart and had to press the power button.
After restart I could not start Manjaro due to the error:
error: file ‘/boot/vmlinuz-5.12-X86-64’ not found you need to load the kernel first.

I have Ubuntu 20.04 in dual boot and I could chroot from there.
Please help.

Kamalakar

Typical n00b mistake. :stuck_out_tongue: What you should have done was let the update finish, because it’s a very CPU-intensive and I/O-intensive procedure, and that’s why the system appeared unresponsive.

Yes, and that’s because the initramfs is only generated at the end of the update procedure, and only then is GRUB updated as well.

Okay, boot up from the Manjaro CD/USB ─ any recent one will do; it doesn’t have to be the latest ─ in live mode, and then open up a terminal window. In this terminal, issue the following commands… :arrow_down:

sudo su -
manjaro-chroot -a

Select your Manjaro installation. Then issue the following commands… :arrow_down:

rm -f /var/lib/pacman/db.lck
pacman -Syu

Let the update finish this time. At the end of the procedure, it will generate the new initramfs and will add the updated kernel to the GRUB boot loader menu. :wink:

1 Like

Did as suggested. The output in terminal:

[manjaro@manjaro ~]$ sudo su -
[manjaro ~]# manjaro-chroot -a
grub-probe: error: cannot find a GRUB drive for /dev/sdb1.  Check your device.map.
grub-probe: error: cannot find a GRUB drive for /dev/sdb1.  Check your device.map.
==> Detected systems:
 --> 0) Ubuntu
 --> 1) ManjaroLinux
==> Select system to mount [0-1] : 
1
==> Mounting (ManjaroLinux) [/dev/sda7]
 --> mount: [/mnt]
 --> mount: [/mnt/boot/efi]
[manjaro /]# rm -f /var/lib/pacman/db.lck
[manjaro /]# pacman -Syu
:: Synchronizing package databases...
 core is up to date
 extra                1910.3 KiB   498 KiB/s 00:04 [######################] 100%
 community is up to date
 multilib is up to date
:: Starting full system upgrade...
 there is nothing to do
[manjaro /]# 

Did not work. Same error.

Kamalakar

1 Like

So there’s probably the last 2 steps missing - rebuild initramfs images and update grub when manjaro-chrooted into that installation:

$ sudo mkinitcpio -P
$ sudo update-grub
1 Like

mkinitcpio -P

error no presets found

That would mean you have no kernels installed?!
Please check with

$ mhwd-kernel -li

and possibly install at least one (let’s use 5.10LTS):

$ sudo mhwd-kernel -i linux510
2 Likes

I could not install linux510 but could install linux512.
After login I found that linux510 was available but not listed in grub.
I could not remove it. Anyway it may work after next update to the kernel.
Thanks my system is working now on linux512.

1 Like

This command worked on installed system and the kernel is re-installed.

Kamalakar

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.