Kernel won't boot

I am having the same issue as the person here:Boot file not found . I just did an update. When I try to boot I get the following message:

error: file’/boot/vmlinuz-5.10-x86-64’ not found
Error: you need to load the kernel first
Press any key to continue…

I get the same if I try with the other kernels I have installed (414 and 419).

I am pretty sure I inadvertently interrupted my update (I was trying to copy a bit of text in the terminal with Control - C, which I guess was pretty dumb).

Anyway, I followed the steps outlined in this post I linked to above which was:

sudo su -
manjaro-chroot -a


pacman-mirrors -f 5 && pacman -Syyu

Then after the update I entered the exit command and tried to reboot my system. I am still getting the exact same error.

When I enter

sudo su -
manjaro-chroot -a

I get

grub-probe: error: cannot find a GRUB drive for /dev/sdb1. Check your
grub-probe: error: cannot find a GRUB drive for /dev/sdb1. Check your
==> Mounting (ManjaroLinux) [/dev/sda2]
→ mount: [/mnt]
→ mount: [/mnt/boot/efi]
[manjaro /]#

I appreciate if anyone can help me out here. I am not really sure at all how to proceed, and I may be making a very basic error because I am not so experienced.

I kept reading and working on this and the situation has changed. I followed the instructions here: Error: file '/boot/vmlinuz-5.12-X86-64' not found you need to load the kernel first - #6 by freggel.doe

What I did was this:

sudo su -
manjaro-chroot -a


rm -f /var/lib/pacman/db.lck
pacman -Syu

With no result.

Then I did this:

$ sudo mkinitcpio -P
$ sudo update-grub

and after rebooting my system goes into Setup mode. I do not get the original message, which I think is acutally somehow worse. At least before I could see my grub menu, but now I don’t see anything but the Setup screen. When I navigate to uefi-grub and select it, nothing happens.

And I forgot to mention that the output of

mkinitcpio -P

is this

==> ERROR: No presets found in /etc/mkinitcpio.d

So after chroot, did you run the commands that were suggested in the post you’ve linked above?

try that…

Thanks for your help. I did this one

$ mhwd-kernel -li

and saw that my three kernels were all listed and wasn’t sure if I should do the next command.

Currently running: 5.816-2MANJARO (linux58)
The following Kernels are installed in your system:
* linux414
* linux419
* linux510

Do you think I should try

$ sudo mhwd-kernel -i linux510

Even though it is listed?

try that, not sure how mhwd is dealing with this.

or sudo pacman -Syu linux510


I did the first one, which came back with message about no targets being specified.

Then I did

sudo pacman -Syu linux510

and I got a warning that this was already installed and if I proceeded it would reinstall 510. I went forward and it seemed to complete the update process.

I am now back in my system, thank you so much!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.