[Stable Update] 2021-11-19 - Kernels, Gnome 41.1, Plasma 5.23.3, Frameworks 5.88, LxQt 1.0, Xorg-Server 21.1, Mesa

/bin/zensu script has a syntax error at line 11

elif [ -e /usr/bin/zenity ] then;

needs to be this

elif [ -e /usr/bin/zenity ]; then

The bug that I reported this summer when the nvidia-drivers where changed from 465 to 470, where on some msi-mother boards the driver could not detect a nvidia graphics card has reemerged in version 495. Currently I’m running on the nouvou driver, which is in sufficient for my needs but enough to report this problem. I have a Geforce 1070 and a MSI X370 SLI Plus motherboard, and I once again find the following error in the journal:

kernel: NVRM: GPU 0000:23:00.0: RmInitAdapter failed! (0x26:0x56:1479)                                      
kernel: NVRM: GPU 0000:23:00.0: rm_init_adapter failed, device minor number 0                               
/usr/lib/gdm-x-session[819]: (EE) NVIDIA(GPU-0): Failed to initialize the NVIDIA GPU at PCI:35:0:0.  Please 
/usr/lib/gdm-x-session[819]: (EE) NVIDIA(GPU-0):     check your system's kernel log for additional error    
/usr/lib/gdm-x-session[819]: (EE) NVIDIA(GPU-0):     messages and refer to Chapter 8: Common Problems in the
/usr/lib/gdm-x-session[819]: (EE) NVIDIA(GPU-0):     README for additional information.                     
/usr/lib/gdm-x-session[819]: (EE) NVIDIA(GPU-0): Failed to initialize the NVIDIA graphics device!           
/usr/lib/gdm-x-session[819]: (EE) NVIDIA(0): Failing initialization of X screen                             

The manual page that is referenced in the error message is completely meaning less has nothing to do with the actual problem.

The fact that updating graphics drivers often leads to these kinds of problems indicate a strong need for a simple way to downgrade them. Currently the only way is to force pacman to install older versions, assuming that you have access to the correct packages, and then hope that not something else breaks. I will try over the weak end to downgrade to the previous version of the driver, and of course older versions of the kernel so that I can use my computer to its full potential.

1 Like

After updating, the search function on the Plasma Application Launcher stopped working.
Turns out this is is a regression in Plasma 5.23 with multiple monitors
https://bugs.kde.org/show_bug.cgi?id=443131

Workaround is to remove the launcher from one of the desktops

Hi to all the fantastic maintainers of arch and manjaro!

Owning a nVidia GeForce GTX 1060 6GB and use KDE.

Was on kernel 5.12.19-1 before upgrade.

Pamac refused to upgrade. So I tried with sudo pacman -Syyu which resulted in:

Installation of nvidia-utils (495.44-4) breaks dependency »nvidia-utils=470.63.01« required by nvidia linux512-nvidia

Steps to resolve this were:

  • sudo mhwd -r pci video-nvidia
  • Installed kernel 5.15.2-2 via the kernel-GUI of manjaro.
  • Restarted into kernel 5.15.2-2 the second option of the grub menu
  • sudo pacman -Syyu (this time the upgrade worked)
  • Uninstalled 5.12.19-1 via the kernel-GUI
  • sudo mhwd -i pci video-nvidia-470xx (didn’t show me no progress, but after 10mins it finished successfully)

First time starting Plasma after this I got a crash.
Second and third time everything went smooth.
MPV/Streamlink, Youtube, Steam OpenGL/Vulkan and Plasma itself are running great now with Kernel 5.15.2-2 and nVidia driver 470.86. Felt even more performant in the few games on Steam, that I’ve tried.
Initial RAM usage of Plasma is down by a wooping 100MB.

I’d like to donate, but I’m only able to do via PayPal.
I did not find that possiblity.
Is that correct?

1 Like

Some problems I’m facing:

  1. It broke all my scaling options (some texts are either too small or too big)
  2. Some preferences(like zsh configs or showing battery percentages) are set to default
  3. The new Kickoff menu is super UGLY!!! (I know it’s on kde but just wanted to mention​:smiley::smiley:)

My main issue is scaling. Everything was right before update but now everything looks super small and compact

After update everything worked fine I rebooted the system and now I have a error on screen. Grub says I need to load the kernel first. I have both 5.10 & 5.4 lts kernels. I am not able to boot with both kernels. I don’t know how to solve this I have a manjaro live usb. I looked at this post https://forum.manjaro.org/t/error-file-boot-vmlin… it doesn’t solve it for me.

I finally managed to test the new ISOs and update the first and second post of this thread. If there are new issues we didn’t catch on our end, please open new posts in our support section!

1 Like

Problems with prime-run on Nvidia Optimus notebook with the newest kernel version 5.15.2-2

prime-run Minetest 5.4.1 does not start
prime-run steam starts, but can not create a display window. The steam process remains running in the background. So I had to kill it manually with the kill command.

Without prime-run minetest and steam start normally.

uname --all

Linux vvlap-linux 5.15.2-2-MANJARO #1 SMP PREEMPT Sat Nov 13 19:25:38 UTC 2021 x86_64 GNU/Linux

sudo prime-run minetest --version

Minetest 5.4.1 (Linux)
Using Irrlicht 1.8.4
Using LuaJIT 2.0.5
BUILD_TYPE=Release
RUN_IN_PLACE=0
USE_CURL=1
USE_GETTEXT=1
USE_SOUND=1
USE_FREETYPE=1
STATIC_SHAREDIR="/usr/share/minetest"
STATIC_LOCALEDIR="/usr/share/locale"

prime-run minetest --verbose

2021-11-19 20:47:44: INFO[Main]: Using system-wide paths (NOT RUN_IN_PLACE)
2021-11-19 20:47:44: INFO[Main]: Detected share path: /usr/share/minetest
2021-11-19 20:47:44: INFO[Main]: Detected user path: /home/vvoss/.minetest
2021-11-19 20:47:44: INFO[Main]: Detected cache path: /home/vvoss/.cache/minetest
2021-11-19 20:47:44: INFO[Main]: Using in-place locale directory /usr/share/minetest/locale even though a static one was provided.
2021-11-19 20:47:44: INFO[Main]: minetest with SER_FMT_VER_HIGHEST_READ=28, BUILD_TYPE=Release
2021-11-19 20:47:44: INFO[Main]: RUN_IN_PLACE=0
2021-11-19 20:47:44: INFO[Main]: USE_CURL=1
2021-11-19 20:47:44: INFO[Main]: USE_GETTEXT=1
2021-11-19 20:47:44: INFO[Main]: USE_SOUND=1
2021-11-19 20:47:44: INFO[Main]: USE_FREETYPE=1
2021-11-19 20:47:44: INFO[Main]: STATIC_SHAREDIR="/usr/share/minetest"
2021-11-19 20:47:44: INFO[Main]: STATIC_LOCALEDIR="/usr/share/locale"
2021-11-19 20:47:45: VERBOSE[Main]: httpfetch_init: parallel_limit=8
2021-11-19 20:47:45: INFO[Main]: Gettext: domainname="minetest" path="/usr/share/minetest/locale"
2021-11-19 20:47:45: INFO[Main]: Message locale is now set to: LC_CTYPE=de_DE.utf8;LC_NUMERIC=C;LC_TIME=de_DE.UTF-8;LC_COLLATE=de_DE.utf8;LC_MONETARY=de_DE.UTF-8;LC_MESSAGES=de_DE.utf8;LC_PAPER=de_DE.UTF-8;LC_NAME=de_DE.UTF-8;LC_ADDRESS=de_DE.UTF-8;LC_TELEPHONE=de_DE.UTF-8;LC_MEASUREMENT=
2021-11-19 20:47:45: INFO[Main]: de_DE.UTF-8;LC_IDENTIFICATION=de_DE.UTF-8
2021-11-19 20:47:45: INFO[Main]: Searching worlds...
2021-11-19 20:47:46: INFO[Main]:   In /home/vvoss/.minetest/worlds: 
2021-11-19 20:47:46: INFO[Main]: 0 found.
2021-11-19 20:47:46: INFO[Main]: Using default world at [/home/vvoss/.minetest/worlds/world]
2021-11-19 20:47:46: INFO[Main]: Using default gameid [minetest]
/dev/shm/jack_db/__db.001: Keine Berechtigung
[ALSOFT] (EE) Failed to set real-time priority for thread: Die Operation ist nicht erlaubt (1)
[ALSOFT] (EE) Failed to set real-time priority for thread: Die Operation ist nicht erlaubt (1)
2021-11-19 20:47:46: INFO[Main]: Audio: Global Initialized: OpenAL 1.1 ALSOFT 1.21.1, using OpenAL Soft
2021-11-19 20:47:46: INFO[Main]: Irrlicht: Irrlicht Engine version 1.8.5
2021-11-19 20:47:46: WARNING[Main]: Irrlicht: Warning: The library version of the Irrlicht Engine (1.8.5) does not match the version the application was compiled with (1.8.4). This may cause problems.
2021-11-19 20:47:46: INFO[Main]: Irrlicht: Linux 5.15.2-2-MANJARO #1 SMP PREEMPT Sat Nov 13 19:25:38 UTC 2021 x86_64
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  152 (GLX)
  Minor opcode of failed request:  24 (X_GLXCreateNewContext)
  Value in failed request:  0x0
  Serial number of failed request:  30
  Current serial number in output stream:  31

prime-run steam

steam.sh[1464]: Running Steam on manjarolinux 21.2.0 64-bit
steam.sh[1464]: STEAM_RUNTIME is enabled automatically
setup.sh[1537]: Steam runtime environment up-to-date!
steam.sh[1464]: Steam client's requirements are satisfied
[2021-11-20 08:29:36] Startup - updater built Nov 19 2021 20:59:37
Installing breakpad exception handler for appid(steam)/version(1637358733)
SteamUpdateUI: An X Error occurred
X Error of failed request:  BadValue (integer parameter out of range for operation)

sudo mhwd -l

> 0000:01:00.0 (0300:10de:1c60) Display controller nVidia Corporation:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
video-hybrid-intel-nvidia-prime            2021.11.04               false            PCI
video-hybrid-intel-nvidia-470xx-prime            2021.11.04               false            PCI
video-hybrid-intel-nvidia-390xx-bumblebee            2021.11.04               false            PCI
          video-nvidia            2021.11.04               false            PCI
    video-nvidia-470xx            2021.11.04               false            PCI
    video-nvidia-390xx            2021.11.04               false            PCI
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI


> 0000:00:02.0 (0300:8086:591b) Display controller Intel Corporation:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
video-hybrid-intel-nvidia-prime            2021.11.04               false            PCI
video-hybrid-intel-nvidia-470xx-prime            2021.11.04               false            PCI
video-hybrid-intel-nvidia-390xx-bumblebee            2021.11.04               false            PCI
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI


> 0000:6d:00.1 (0200:10ec:8168) Network controller Realtek Semiconductor Co., Ltd.:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
         network-r8168            2016.04.20                true            PCI

sudo mhwd -li

> Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
video-hybrid-intel-nvidia-prime            2021.11.04               false            PCI
     video-modesetting            2020.01.13                true            PCI


Warning: No installed USB configs!

inxi --admin --verbosity=7 --filter --width

System:
  Kernel: 5.15.2-2-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
  root=UUID=ecbc1446-0bef-4139-9af4-3931710cef36 rw quiet apparmor=1
  security=apparmor udev.log_priority=3
  Desktop: Xfce 4.16.0 tk: Gtk 3.24.29 info: xfce4-panel wm: xfwm 4.16.1 vt: 7
  dm: LightDM 1.30.0 Distro: Manjaro Linux base: Arch Linux
Machine:
  Type: Laptop System: XMG product: P65xHP v: N/A serial: <filter> Chassis:
  type: 10 serial: <filter>
  Mobo: XMG model: P65xHP serial: <filter> UEFI: American Megatrends
  v: 1.07.13 date: 10/02/2018
Battery:
  ID-1: BAT0 charge: 56.3 Wh (100.0%) condition: 56.3/60.2 Wh (93.6%)
  volts: 16.2 min: 14.8 model: Notebook BAT type: Li-ion serial: <filter>
  status: Full
Memory:
  RAM: total: 15.38 GiB used: 1.99 GiB (13.0%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges required.
CPU:
  Info: Quad Core model: Intel Core i7-7700HQ bits: 64 type: MT MCP
  arch: Kaby Lake family: 6 model-id: 9E (158) stepping: 9 microcode: EA
  cache: L2: 6 MiB bogomips: 44817
  Speed: 900 MHz min/max: 800/3800 MHz Core speeds (MHz): 1: 900 2: 900 3: 901
  4: 900 5: 900 6: 900 7: 900 8: 900
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon art
  avx avx2 bmi1 bmi2 bts clflush clflushopt cmov constant_tsc cpuid
  cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est
  f16c flexpriority flush_l1d fma fpu fsgsbase fxsr ht hwp hwp_act_window
  hwp_epp hwp_notify ibpb ibrs ida intel_pt invpcid invpcid_single lahf_lm lm
  mca mce md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx pae pat
  pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts
  rdrand rdseed rdtscp rep_good sdbg sep sgx smap smep ss ssbd sse sse2 sse4_1
  sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust
  tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave xsavec xsaveopt
  xsaves xtopology xtpr
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
  mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
  mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
  IBRS_FW, STIBP: conditional, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel HD Graphics 630 vendor: CLEVO/KAPOK driver: i915 v: kernel
  bus-ID: 00:02.0 chip-ID: 8086:591b class-ID: 0300
  Device-2: NVIDIA GP106BM [GeForce GTX 1060 Mobile 6GB] vendor: CLEVO/KAPOK
  driver: N/A alternate: nouveau bus-ID: 01:00.0 chip-ID: 10de:1c60
  class-ID: 0300
  Device-3: Chicony Chicony USB 2.0 Camera type: USB driver: uvcvideo
  bus-ID: 1-9:4 chip-ID: 04f2:b5a7 class-ID: 0e02
  Display: x11 server: X.Org 1.21.1.1 compositor: xfwm4 v: 4.16.1 driver:
  loaded: modesetting alternate: fbdev,vesa display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
  s-diag: 582mm (22.9")
  Monitor-1: eDP-1 res: 1920x1080 hz: 60 dpi: 142 size: 344x194mm (13.5x7.6")
  diag: 395mm (15.5")
  OpenGL: renderer: Mesa Intel HD Graphics 630 (KBL GT2) v: 4.6 Mesa 21.2.5
  direct render: Yes
Audio:
  Device-1: Intel CM238 HD Audio vendor: CLEVO/KAPOK driver: snd_hda_intel
  v: kernel bus-ID: 00:1f.3 chip-ID: 8086:a171 class-ID: 0403
  Sound Server-1: ALSA v: k5.15.2-2-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.40 running: no
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
  vendor: CLEVO/KAPOK driver: r8169 v: kernel port: d000 bus-ID: 6d:00.1
  chip-ID: 10ec:8168 class-ID: 0200
  IF: enp109s0f1 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
  broadcast: <filter>
  IP v6: <filter> type: dynamic noprefixroute scope: global
  IP v6: <filter> type: noprefixroute scope: link
  Device-2: Intel Wireless 8265 / 8275 driver: iwlwifi v: kernel
  bus-ID: 6e:00.0 chip-ID: 8086:24fd class-ID: 0280
  IF: wlp110s0 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
  broadcast: <filter>
  IP v6: <filter> type: dynamic noprefixroute scope: global
  IP v6: <filter> type: noprefixroute scope: link
  IF-ID-1: virbr0 state: down mac: <filter>
  IP v4: <filter> scope: global broadcast: <filter>
  WAN IP: <filter>
Bluetooth:
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8
  bus-ID: 1-8:3 chip-ID: 8087:0a2b class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 1 state: down bt-service: enabled,running
  rfk-block: hardware: no software: yes address: see --recommends
Logical:
  Message: No logical block device data found.
RAID:
  Message: No RAID data found.
Drives:
  Local Storage: total: 5.92 TiB used: 32.49 GiB (0.5%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Intel model: SSDPEKKW512G7
  size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
  lanes: 4 type: SSD serial: <filter> rev: PSF121C temp: 26.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: ST2000LM015-2E8174
  size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
  type: HDD rpm: 5400 serial: <filter> rev: SDM1 scheme: GPT
  ID-3: /dev/sdb maj-min: 8:16 type: USB model: StarTech RAID0 size: 3.64 TiB
  block-size: physical: 512 B logical: 512 B type: HDD rpm: 5400
  serial: <filter> rev: 0101 scheme: GPT
  Message: No optical or floppy data found.
Partition:
  ID-1: / raw-size: 200 GiB size: 195.86 GiB (97.93%) used: 32.49 GiB (16.6%)
  fs: ext3 dev: /dev/sdb3 maj-min: 8:19 label: N/A
  uuid: ecbc1446-0bef-4139-9af4-3931710cef36
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
  used: 312 KiB (0.1%) fs: vfat dev: /dev/sdb1 maj-min: 8:17 label: N/A
  uuid: 6B10-E3A8
Swap:
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 33 GiB used: 0 KiB (0.0%) priority: -2
  dev: /dev/sdb2 maj-min: 8:18 label: N/A
  uuid: 4f140957-a594-495a-810f-73c519771bce
Unmounted:
  ID-1: /dev/nvme0n1p1 maj-min: 259:1 size: 529 MiB fs: ntfs label: N/A
  uuid: 141AD4231AD40420
  ID-2: /dev/nvme0n1p2 maj-min: 259:2 size: 100 MiB fs: vfat label: N/A
  uuid: BCD5-AC3E
  ID-3: /dev/nvme0n1p3 maj-min: 259:3 size: 16 MiB fs: <superuser required>
  label: N/A uuid: N/A
  ID-4: /dev/nvme0n1p4 maj-min: 259:4 size: 476.31 GiB fs: ntfs label: Win10
  uuid: 5290DFD390DFBC23
  ID-5: /dev/sda1 maj-min: 8:1 size: 1.82 TiB fs: ntfs label: Daten
  uuid: B04062AA406276CE
  ID-6: /dev/sdb4 maj-min: 8:20 size: 3.41 TiB fs: ntfs label: ntfs
  uuid: 2DA5484F25163F57
USB:
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 16 rev: 2.0
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-7:2 info: LighTuning ES603 Swipe Fingerprint Sensor
  type: <vendor specific> driver: N/A interfaces: 1 rev: 1.1 speed: 12 Mb/s
  power: 100mA chip-ID: 1c7a:0603 class-ID: 0000
  Device-2: 1-8:3 info: Intel Bluetooth wireless interface type: Bluetooth
  driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA
  chip-ID: 8087:0a2b class-ID: e001
  Device-3: 1-9:4 info: Chicony Chicony USB 2.0 Camera type: Video
  driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA
  chip-ID: 04f2:b5a7 class-ID: 0e02
  Hub-2: 2-0:1 info: Full speed (or root) Hub ports: 8 rev: 3.0 speed: 5 Gb/s
  chip-ID: 1d6b:0003 class-ID: 0900
  Device-1: 2-6:2 info: Western Digital JMS56x Series type: Mass Storage
  driver: uas interfaces: 1 rev: 3.1 speed: 5 Gb/s power: 8mA
  chip-ID: 1058:0a10 class-ID: 0806 serial: <filter>
  Hub-3: 3-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 3-1:2 info: Logitech G502 Mouse type: Mouse,HID
  driver: hid-generic,usbhid interfaces: 2 rev: 2.0 speed: 12 Mb/s
  power: 300mA chip-ID: 046d:c07d class-ID: 0300 serial: <filter>
  Hub-4: 4-0:1 info: Full speed (or root) Hub ports: 2 rev: 3.1 speed: 10 Gb/s
  chip-ID: 1d6b:0003 class-ID: 0900
Sensors:
  System Temperatures: cpu: 51.0 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 230 Uptime: 18m wakeups: 1 Init: systemd v: 249 tool: systemctl
  Compilers: gcc: 11.1.0 Packages: pacman: 1318 lib: 434 flatpak: 0
  Shell: Bash v: 5.1.8 running-in: xfce4-terminal inxi: 3.3.08

If I am not wrong, you can discover what package have the file libffi.so=8-64 with:

pacman -Qo libffi.so=8-64

… and then install the package.

[Edit]: in response to a request for console output, I reinstalled the latest android-tools, rebooted and… everything’s working as it should. So it seems this post is irrelevant, unless it starts breaking again later.

How long nvidia property driver 470 series will be supported ?

You might have an outdated mirror. Seems @Yochanan pushed Thunderbird earlier to stable branch, without checking on libffi 3.4.2-4 presence. Therefore wait till your mirror updates or change to a more current one using pacman-mirrors tool.

1 Like

I seem to have a Virtual box conflict, and as a result it fails to update. I tried both “pamac update” and sudo pacman -Syuu", but both failed.

vb update
vb conflict

Virtual box conflict log:
:: Synchronizing package databases…
core is up to date
extra is up to date
community is up to date
multilib is up to date
:: Some packages should be upgraded first…
resolving dependencies…
looking for conflicting packages…

Packages (1) archlinux-keyring-20211028-1

Total Download Size: 0.96 MiB
Total Installed Size: 1.36 MiB
Net Upgrade Size: 0.00 MiB

:: Proceed with installation? [Y/n] y
:: Retrieving packages…
archlinux-keyrin… 979.1 KiB 2.56 MiB/s 00:00 [##############] 100%
(1/1) checking keys in keyring [##############] 100%
(1/1) checking package integrity [##############] 100%
(1/1) loading package files [##############] 100%
(1/1) checking for file conflicts [##############] 100%
(1/1) checking available disk space [##############] 100%
:: Processing package changes…
(1/1) upgrading archlinux-keyring [##############] 100%
==> Appending keys from archlinux.gpg…
==> Updating trust database…
gpg: next trustdb check due at 2022-01-20
==> Updating trust database…
gpg: next trustdb check due at 2022-01-20
:: Running post-transaction hooks…
(1/1) Arming ConditionNeedsUpdate…

:: Starting full system upgrade…
:: Replace virtualbox-guest-dkms with community/virtualbox-guest-utils? [Y/n] y
:: Replace virtualbox-guest-dkms with community/virtualbox-guest-utils-nox? [Y/n] y
resolving dependencies…
looking for conflicting packages…
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: virtualbox-guest-utils and virtualbox-guest-utils-nox are in conflict

Simply do this and try to update:

sudo pacman -Rdd virtualbox-guest-dkms

Fixed with 0.3-3.

1 Like

after today update I’m facing again in shutdown

Failed to unmount /oldroot: Device or resource busy
sd-umount: Failed to unmount /oldroot/sys: Device or resource busy
shutdown[1]: Failed to finalize file systems, ignoring.

related to systemd update?

AirVPN Eddie-UI complaining kernel 5.15.2-2 not loading iptables module when applying network lock , kernel 5.14 is fine…

3 Likes

Some tray icons have become buggy after latest update

Screenshot from 2021-11-20 02-26-59
[notice there is an additional dark background in copyq (the scissor) and nextcloud sync (the tick) icon. also the mentioned icons look quite distorted]

Any solution?

all went smooth except my clipit icon looks ugly now (think it’s the dafault one). thought it might be an issue only on i3 but I see others have similar issues.

That fixed the problem, and update was successful. Thanks a lot Philm for a quick response!

I just wish I could find a solution so to get rid of this annoying “pop up” message every time you open a voice mail message via VLC player. It simply won’t save the settings no matter what you do, and the message pops up every time. It has been like this for months, and I’m assuming it is a Thunderbird issue!
Thunderbird settings

Ouch! Looks like some sort of nasty in opencl (presumably opencl-mesa, as that was the only package upgraded).

I had opencl enabled in Gimp, but it wasn’t previously actually working (something to do with “image” not being available). It seems now that “image” is now at least partially available. So now it looks like Gimp is finding what it thinks is a working option and trying to use it. After a short time processing a picture, my entire desktop freezes. Then after about 30 seconds or so, it goes blank, then I see patches of screen flashing all over the place, then after another short period, the screen just goes black. is needed to get me back to the SDDM login.

Disabling opencl within Gimp seems to fix this problem.