Error : Failed to mount Windows Volume

when i try to mount windows partition in my manjaro i get this error message

`Failed to mount "499 GB Volume".
Error mounting /dev/sdb2 at/run/media/"USER"/B65ACOE65ACOA509: wrong fs type, 
bad option, bad superblock on /dev/sdb2, 
missing codepage or helper program, or other error.

Please post the actual command that failed. Without both the command and output, we may as well be peeing into the wind.

bad superblock usually indicates a damaged disk, or filesystem, however, in some circumstances it can also be an artifact resulting from an incorrect command or path entered.

i am using thunar file manger to mount windows volume

Assuming the partition you are trying to mount is NTFS, try this:

sudo pacman -Syu ntfs-3g
echo 'blacklist ntfs3' | sudo tee /etc/modprobe.d/disable-ntfs3.conf

Close and re-open Thunar, to see it that helps; and report back with the results.


Please provide the output of:

cat /etc/fstab

… and:


… and:

inxi -v7azy

… and, please read the following useful tutorials:

1 Like

Thanks for your help ,but i want to understand why it work after disable ntfs kernel module

You could use the search function of the forum, as this has been explained and ‘solved’ multiple times.

The gist is that its a new kernel module thats become the default, but in many cases, such as your own, it does not seem to function as expected. Blacklisting the new module and using the legacy ntfs-3g is reverting to the previous method.

I didnt pay much attention to the error itself … see the post below :point_down:

1 Like

Because it’s marked dirty (wasn’t unmounted cleanly). The kernel driver requires force option to mount dirty partitions, NTFS-3G doesn’t.


If that is true, if that is the cause - the way better fix would be to check and correct the file system
instead of kind of working around the (possibly serious issue) by ignoring the error

If there is no Windows machine to do the job, there are live CD’s like Hirens Boot CD (or very similar)
Any minimal Windows system with the proper tool to do the job - check and fix the file system.

Linux native tools cannot really do this reliably.

I agree and I think the kernel driver does the correct thing here by requiring a force flag to mount it.

hmm - mount it anyway by way of forcing it - but not addressing the source of the error, a file system error.
Can perhaps be used for “access anyway” - but is not addressing the cause.

To keep using a file system with known errors without fixing them is just asking for more trouble, me thinks.

I was answering the question about why NTFS-3G mounts it and the kernel driver doesn’t. I wasn’t recommending ignoring the error and the ArchWiki link I posted gives one way of fixing it.

Yeah … except now that I look it suggests ntfsfix for some reason … which can at best (or worst) forcibly change the flags … so really its not a good option.
One needs to use windoze (or derivative like Hirens) to truly fix its proprietary filesystem.

Well, just because it wasn’t unmounted cleanly and is marked dirty doesn’t necessarily mean that the file system is damaged. I’m guessing that NTFS-3G does exactly the same thing and forcibly clears the dirty flag if there are no other errors.

Most welcome. I’m glad this resolved your issue. Regarding why this worked, the reasons are explained in previous posts.

As I initially pointed out, bad superblock indicates errors with a disk, or partition. It would be prudent to correct any filesystem inconsistencies sooner, rather than later. Your partition now mounts, thanks to ntfs-3g, but that doesn’t mean the actual cause is fixed.

NTFS is not a Linux filesystem. Are you running a multiboot system?

If so, I suggest using chkdsk from an administrative prompt in Windows, or from a Hirens boot DVD/USB (as mentioned above), to correct any errors. Note that any errors are likely to be cross-linked files, or similar, and easily corrected by chkdsk.

This is not to say that a Linux tool won’t necessarily fix these errors, but that the Windows tool would be the better (safer) choice for NTFS, wherever possible.


This topic was automatically closed 3 hours after the last reply. New replies are no longer allowed.