Dummy Output - No Sound on Dell XPS 17 Laptop

I installed Manjaro Cinnamon on a Dell XPS 17 laptop and am experiencing an issue with sound. I can’t get sound to play through the speakers.The only sound output device I see is “Dummy Output.” The builtin webcam microphone is also not detected, though the webcam itself seems to be fully functional. I’ve come across a few similar posts and have tried some solutions but I haven’t been able to fix anything. I’m not really sure where to start with debugging this. Is there any information that would be helpful?



According to this Dell XPS 17 (9700) - ArchWiki you need sof-firmware package installed.
And according to this Dell XPS 17 (9710) - ArchWiki you should get it working with 5.15 kernel installed via MHWD.
But depends what exact model you have. Here is [HowTo] Provide System Information - so post it here.

Thank you for the reply! I should have mentioned that I already checked to see if sof-firmware was installed. Even with that package I have no audio. I have the 9710, but the audio does not work on kernel version 5.15, 5.16, or 5.17. Here is my system info:

  Kernel: 5.17.0-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.2.0
    Desktop: Cinnamon 5.2.7 tk: GTK 3.24.33 vt: 7 dm: LightDM 1.30.0
    Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: Dell product: XPS 17 9710 v: N/A
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: Dell model: 012MMP v: A01 serial: <superuser required> UEFI: Dell
    v: 1.6.0 date: 12/10/2021
  ID-1: BAT0 charge: 73.5 Wh (86.7%) condition: 84.8/95.1 Wh (89.2%)
    volts: 11.9 min: 11.4 model: BYD DELL F8CPG17 type: Li-poly
    serial: <filter> status: Discharging
  RAM: total: 62.54 GiB used: 3.24 GiB (5.2%)
  RAM Report:
    permissions: Unable to run dmidecode. Root privileges required.
  Info: 8-core model: 11th Gen Intel Core i9-11980HK bits: 64 type: MT MCP
    smt: enabled arch: Tiger Lake rev: 1 cache: L1: 640 KiB L2: 10 MiB
    L3: 24 MiB
  Speed (MHz): avg: 858 high: 1048 min/max: 800/4900:5000 cores: 1: 959
    2: 800 3: 799 4: 801 5: 791 6: 907 7: 801 8: 1048 9: 1009 10: 960 11: 801
    12: 801 13: 801 14: 791 15: 801 16: 863 bogomips: 105712
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat
    arch_capabilities arch_perfmon art avx avx2 avx512_bitalg avx512_vbmi2
    avx512_vnni avx512_vp2intersect avx512_vpopcntdq avx512bw avx512cd
    avx512dq avx512f avx512ifma avx512vbmi avx512vl bmi1 bmi2 bts cat_l2
    cdp_l2 clflush clflushopt clwb cmov constant_tsc cpuid cpuid_fault cx16
    cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est f16c flexpriority
    flush_l1d fma fpu fsgsbase fsrm fxsr gfni ht hwp hwp_act_window hwp_epp
    hwp_notify hwp_pkg_req ibpb ibrs ibrs_enhanced ida intel_pt invpcid
    invpcid_single lahf_lm lm mca mce md_clear mmx monitor movbe movdir64b
    movdiri msr mtrr nonstop_tsc nopl nx ospke pae pat pbe pcid pclmulqdq
    pdcm pdpe1gb pebs pge pku pln pni popcnt pse pse36 pts rdpid rdrand
    rdseed rdt_a rdtscp rep_good sdbg sep sha_ni smap smep split_lock_detect
    ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc
    tsc_adjust tsc_deadline_timer tsc_known_freq umip vaes vme vmx vnmi
    vpclmulqdq vpid x2apic xgetbv1 xsave xsavec xsaveopt xsaves xtopology
  Device-1: Intel TigerLake-H GT1 [UHD Graphics] vendor: Dell driver: i915
    v: kernel ports: active: eDP-1 empty: DP-1, DP-2, DP-3, DP-4
    bus-ID: 00:02.0 chip-ID: 8086:9a60 class-ID: 0300
  Device-2: NVIDIA GA106M [GeForce RTX 3060 Mobile / Max-Q] vendor: Dell
    driver: nvidia v: 510.54 pcie: speed: 16 GT/s lanes: 8 bus-ID: 01:00.0
    chip-ID: 10de:2520 class-ID: 0300
  Device-3: Microdia Integrated_Webcam_HD type: USB driver: uvcvideo
    bus-ID: 3-11:3 chip-ID: 0c45:672e class-ID: 0e02
  Display: x11 server: X.Org v: driver: X:
    loaded: modesetting,nvidia alternate: fbdev,nouveau,nv,vesa gpu: i915
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3840x2400 s-dpi: 48 s-size: 2032x1270mm (80.0x50.0")
    s-diag: 2396mm (94.3")
  Monitor-1: eDP-1 model: Sharp res: 3840x2400 hz: 60 dpi: 266
    size: 366x229mm (14.4x9.0") diag: 432mm (17") modes: 3840x2400
  Message: Unable to show GL data. Required tool glxinfo missing.
  Device-1: Intel Tiger Lake-H HD Audio vendor: Dell driver: snd_hda_intel
    v: kernel bus-ID: 00:1f.3 chip-ID: 8086:43c8 class-ID: 0401
  Device-2: NVIDIA vendor: Dell driver: snd_hda_intel v: kernel pcie:
    speed: 16 GT/s lanes: 8 bus-ID: 01:00.1 chip-ID: 10de:228e class-ID: 0403
  Sound Server-1: ALSA v: k5.17.0-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.20 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.48 running: no
  Device-1: Intel Tiger Lake PCH CNVi WiFi vendor: Rivet Networks
    driver: iwlwifi v: kernel bus-ID: 00:14.3 chip-ID: 8086:43f0 class-ID: 0280
  IF: wlp0s20f3 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: dynamic noprefixroute scope: global
  IP v6: <filter> type: dynamic noprefixroute scope: global
  IP v6: <filter> type: noprefixroute scope: link
  IF-ID-1: docker0 state: down mac: <filter>
  IP v4: <filter> scope: global broadcast: <filter>
  WAN IP: <filter>
  Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 3-14:4 chip-ID: 8087:0026 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends
  Message: No logical block device data found.
  Device-1: luks-85fc897b-4f37-47af-9fbc-2d6f2ff97789 type: LUKS dm: dm-0
    size: 1.81 TiB
  Components: p-1: nvme0n1p7
  Message: No RAID data found.
  Local Storage: total: 3.73 TiB used: 182.46 GiB (4.8%)
  ID-1: /dev/nvme0n1 vendor: KIOXIA model: KXG70PN84T09 NVMe 4096GB
    size: 3.73 TiB speed: 63.2 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: 10904105 temp: 22.9 C scheme: GPT
  Message: No optical or floppy data found.
  ID-1: / size: 1.78 TiB used: 182.37 GiB (10.0%) fs: ext4 dev: /dev/dm-0
    mapped: luks-85fc897b-4f37-47af-9fbc-2d6f2ff97789 label: N/A
    uuid: 051d882f-dbb6-465f-bcc8-4839f401a44f
  ID-2: /boot/efi size: 146 MiB used: 89.2 MiB (61.1%) fs: vfat
    dev: /dev/nvme0n1p1 label: ESP uuid: 7019-72CC
  Alert: No swap data was found.
  ID-1: /dev/nvme0n1p2 size: 128 MiB fs: <superuser required> label: N/A
    uuid: N/A
  ID-2: /dev/nvme0n1p3 size: 1.9 TiB fs: bitlocker label: N/A uuid: N/A
  ID-3: /dev/nvme0n1p4 size: 990 MiB fs: ntfs label: WINRETOOLS
    uuid: AC4C9FD14C9F94A4
  ID-4: /dev/nvme0n1p5 size: 16.39 GiB fs: ntfs label: Image
    uuid: A6569FFC569FCB85
  ID-5: /dev/nvme0n1p6 size: 1.37 GiB fs: ntfs label: DELLSUPPORT
    uuid: 7486356B86352F4C
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 1 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-2: 2-0:1 info: Super-speed hub ports: 4 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Hub-3: 3-0:1 info: Hi-speed hub with single TT ports: 16 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 3-10:2 info: Shenzhen Goodix USB2.0 MISC
    type: <vendor specific> driver: N/A interfaces: 1 rev: 2.0 speed: 12 Mb/s
    power: 100mA chip-ID: 27c6:63ac class-ID: ef00 serial: <filter>
  Device-2: 3-11:3 info: Microdia Integrated_Webcam_HD type: Video
    driver: uvcvideo interfaces: 4 rev: 2.0 speed: 480 Mb/s power: 500mA
    chip-ID: 0c45:672e class-ID: 0e02
  Device-3: 3-14:4 info: Intel AX201 Bluetooth type: Bluetooth
    driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA
    chip-ID: 8087:0026 class-ID: e001
  Hub-4: 4-0:1 info: Super-speed hub ports: 6 rev: 3.1 speed: 20 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 30.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 444 Uptime: 10h 38m wakeups: 1462 Init: systemd v: 250
  Compilers: gcc: 11.2.0 clang: 13.0.1 Packages: pacman: 1466 Shell: Zsh
  v: 5.8.1 running-in: gnome-terminal inxi: 3.3.13

You might have to do this

Thanks for the link. I followed the link to the solution and tried all combinations of the snd_intel_dspcfg.dsp_driver=1 and snd_hda_intel.dmic_detect=0 fixes but nothing seems to change. I still have no audio and the “dummy output.”

Only thing i can think of is to update the BIOS

Good idea. I just tried it but am still seeing no changes. I tried all the different GRUB options again too. Thank you for trying to help. I’m trying to avoid reinstalling, but I am considering it as an option at this point. I’ve done a lot of googling about this issue and it seems like everybody else has already had the issue resolved.

did you try to boot from a live-iso and check if this works ? that’s more easy

I’m glad you suggested this. I just tried booting into the live install image with both open-source and proprietary drivers but still didn’t see anything different.

Bumping this in case anybody else has an idea, if that’s OK. I still haven’t found a solution.