Do nothing on Laptop lid closed

I have a thinkpad hooked to an external monitor and I want to be able to close the laptop lid and still use my monitor as an external display. Unfortunately, this is not a feature supported by xfce, so I’ve manually changed the settings in etc/systemd/logind.conf and uncommented the following lines


which was suggested in this thread

Finally, I did this step xfce:xfce4-power-manager:faq [Xfce Docs]

However no changes are taking effect? Any ideas?

Have you rebooted? Have you set the external monitor as Primary display?

Yes, I just tried setting the external monitor as the primary display.
It works for around 15 seconds then the external monitor goes black

Not an expert at this by any means. If it is connected by HDMI can you rule out a bad cable by trying another?

The cable is almost brand new. Highly doubt it would be the cable.
Setting the external monitor as a primarily display, made a slight slight difference. Prior to that, the external monitor would immediate go black. So there’s progress in that sense. Anyway, thanks for your help.

I’ve just installed Manjaro myself and I have the very same problem.

I normally open the lid only to power up the machine and close it afterwards. It’s a bit annoying to have to keep the lid open to use the external monitor (HDMI connection).

I’ve disabled the laptop screen, only the external monitor is active but I still get a blank screen when I close the lid so it’s not exactly the same thing.

The distros I’ve used so far (Ubuntu, Mint) and Windows simply come with a “Do Nothing” option when the lid is closed.

I have opened a topic in the development section to report it as a problem but I’m not sure I’ve done it properly (there was no option to flag it as a problem or bug report).

I’d appreciate any suggestions. It feels like there should be a very simple solution to this.

I’m afraid it’s not that easy.
This problem has been with Manjaro XFCE for several years now and all suggested solutions are not suitable for my Lenovos and Dells. Take a Manjaro Gnome Live-Stick and be amazed how well it works there. It’s a damn and so far unsolved XFCE problem that has been around since the Manjaro XFCE was born. Very annoying that this problem has already been discussed hundreds of times, but nothing has ever changed.

1 Like

Below configuration is working fine:
HandleLidSwitch=ignore in /etc/systemd/logind.conf
IgnoreLid=true in etc/UPower/UPower.conf

I have found this on this archlinux support page.


Which Lenovo does this apply to?
Disabling the lid this radical way only “works” :smile: on my X230. However, this is not the case with the T430 and W530.

its working perfect ,thanks for help ; )

That’s a terrible shame. An OS that can’t ignore laptop lid events, just ridiculous.
I wonder how this has come to be , does it not work on standard XFCE ?

I’ve been using Manjaro for about 5 years or more, and I’ve always used it in this way:

XFCE, Laptop, lid closed, external monitor.

It has always worked just fine.

BUT, I’m now having problems with the latest xfce-21.0.7 version.

I’m posting in another thread for this problem:

So I know it can work, and I’ll post any solution in that thread.